]> git.pld-linux.org Git - packages/Apache-Gallery.git/blob - Apache-Gallery.spec
- cache_dir patch added - moved default cache dir to /var/cache
[packages/Apache-Gallery.git] / Apache-Gallery.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" during build
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         apxs            /usr/sbin/apxs
7 %define         pdir    Apache
8 %define         pnam    Gallery
9 %define         _rc     RC3
10 Summary:        An Apache module for creating an online gallery
11 Summary(pl):    Modu³ Apache'a do tworzenia galerii online
12 Name:           Apache-Gallery
13 Version:        1.0
14 Release:        0.%{_rc}.1.1
15 License:        Artistic
16 Group:          Applications/Graphics
17 Source0:        http://apachegallery.dk/download/%{name}-%{version}%{_rc}.tar.gz
18 # Source0-md5:  a705cbecf2f124d18a3bde3fc36384e8
19 Source1:        %{name}.conf
20 Patch0:         %{name}-cache_dir.patch
21 URL:            http://apachegallery.dk/
22 BuildRequires:  apache-mod_perl-devel >= 1:1.99
23 %{?with_tests:BuildRequires:    apache1-mod_perl}
24 BuildRequires:  perl-CGI >= 3.08
25 BuildRequires:  perl-Image-Imlib2 >= 1.02
26 BuildRequires:  perl-Image-Info
27 BuildRequires:  perl-Image-Size
28 BuildRequires:  perl-Text-Template
29 BuildRequires:  perl-URI >= 1.23
30 BuildRequires:  perl-devel
31 BuildRequires:  perl-libapreq2
32 BuildRequires:  rpm-perlprov >= 3.0.3-16
33 BuildRequires:  rpmbuild(macros) >= 1.268
34 Requires:       apache-mod_perl >= 1:2.0.0
35 Conflicts:      apache-mod_autoindex
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _noautoreq      'perl(APR::Table)' 'perl(Apache2)' 'perl(Apache::Const)' 'perl(Apache::RequestIO)' 'perl(Apache::RequestRec)' 'perl(Apache::SubRequest)'
39 %define         _appdir         %{_datadir}/%{name}
40 %define         _apacheicons    %{_appdir}/icons
41 %define         _cachedir       /var/cache/%{name}
42
43 %description
44 Apache::Gallery is a mod_perl handler that sits on top of your
45 DocumentRoot and creates an image gallery of the files and directories
46 there. It creates an thumbnail index of each directory and allows
47 viewing of pictures in different resolutions. Pictures are resized on
48 the fly and cached.
49
50 %description -l pl
51 Apache::Gallery to procedura obs³ugi dla modu³u mod_perl po³o¿ona w
52 DocumentRoot, tworz±ca galeriê obrazów z umieszczonych tam plików i
53 katalogów. Tworzy indeks z miniaturkami z ka¿dego katalogu i pozwala
54 na ogl±danie obrazków w ró¿nych rozdzielczo¶ciach. Obrazki s±
55 przeskalowywane w locie i buforowane.
56
57 %prep
58 %setup -q -n %{name}-%{version}%{_rc}
59 %patch0 -p1
60
61 %build
62 %{__perl} Makefile.PL \
63         INSTALLDIRS=vendor
64
65 %{__make} \
66         OPTIMIZE="%{rpmcflags}"
67
68 %{?with_tests:%{__make} test}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT{%{_appdir}/templates/{new,default},%{_apacheicons},/etc/httpd/httpd.conf,%{_cachedir}}
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 install templates/new/*.{css,tpl} $RPM_BUILD_ROOT%{_appdir}/templates/new/
78 install templates/default/*.{css,tpl} $RPM_BUILD_ROOT%{_appdir}/templates/default/
79 install htdocs/*.png $RPM_BUILD_ROOT%{_apacheicons}
80
81 install %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/httpd.conf/09_%{name}.conf
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post
87 %service -q httpd reload
88
89 %triggerpostun -- Apache-Gallery < 1.0-0.RC3.2
90 if [ -d "/var/tmp/Apache-Gallery" ]; then
91         echo "Removing old cache /var/tmp/Apache-Gallery. New location: %{_cachedir}"
92         rm -rf /var/tmp/Apache-Gallery
93 fi
94
95 %preun
96 if [ "$1" = "0" ]; then
97         %service -q httpd reload
98 fi
99
100 %files
101 %defattr(644,root,root,755)
102 %doc Changes INSTALL README TODO UPGRADE
103 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/httpd/httpd.conf/*%{name}.conf
104 %{perl_vendorlib}/Apache/Gallery.pm
105 %dir %{_appdir}
106 %dir %{_appdir}/templates
107 %dir %{_appdir}/templates/new
108 %{_appdir}/templates/new/*.tpl
109 %{_appdir}/templates/new/*.css
110 %dir %{_appdir}/templates/default
111 %{_appdir}/templates/default/*.tpl
112 %{_appdir}/templates/default/*.css
113 %dir %{_apacheicons}
114 %{_apacheicons}/*.png
115 %attr(770,root,http) %dir %{_cachedir}
116 %{_mandir}/man3/*.3*
This page took 0.074282 seconds and 3 git commands to generate.