]> git.pld-linux.org Git - packages/AfterStep-APPS.git/blob - AfterStep-APPS.spec
- adapterized.
[packages/AfterStep-APPS.git] / AfterStep-APPS.spec
1 Summary:        Applets you can use with AfterStep and compatible window managers
2 Summary(pl):    Aplety, których mo¿esz u¿ywaæ z AfterStepem oraz innymi zarz±dcami okien, które s± z nim kompatybilne
3 Name:           AfterStep-APPS
4 Version:        991125
5 Release:        4
6 License:        GPL
7 Group:          X11/Window Managers/Tools
8 Source0:        http://www.tigr.net/afterstep/as-apps/download/as-apps-%{version}.tar
9 Patch0:         %{name}-1.5beta1-glibc.patch
10 Patch1:         xiterm-utmp.patch
11 Patch2:         as-apps-miniCHESS-change_install_dirs.patch
12 Patch3:         as-apps-ascd-configure_and_install_bugfix.patch
13 #Patch4:        ascp-paths.patch
14 #Patch5:        aterm-utemp.patch
15 Prereq:         /sbin/ldconfig
16 Requires:       /usr/sbin/utempter
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _prefix         /usr/X11R6
20 %define         _mandir         /usr/X11R6/man
21
22 %description
23 What's a cool window manager without some cool applets? Well... it's
24 still cool, but these applets which can be used in the Wharf module
25 for AfterStep or Window Maker can add both spice and productivity to
26 your preferred window manager, such as a handy clock and information
27 about system resources.
28
29 If you've installed the AfterStep packages, you should also install
30 these packages. Enjoy!
31
32 %description -l pl
33 Czym jest fajny zarz±dca okien bez fajnych apletów? Có¿... jest nadal
34 fajnym zarz±dc± okien, ale aplety, które mog± byæ u¿ywane w module
35 Wharf AfterStepa lub Window Makera, mog³yby zwiêkszyæ efektywno¶æ i
36 efektowno¶æ twojego ulubionego zarz±dcy okien.
37
38 Je¿eli masz zainstalowanego AfterStepa to powiniene¶ zainstalowaæ
39 tak¿e ten pakiet. Mi³ej zabawy!
40
41 %prep
42 %setup -q -c
43 rm -f *.asc
44 for archive in *.tar.gz ; do
45         tar xzf $archive
46         rm -f $archive
47 done
48 %patch0 -p1
49 %patch1 -p1
50 %patch2 -p1
51 %patch3 -p1
52 #patch4
53 #patch5
54
55 %build
56 for package in `ls` ; do
57     cd $package
58     case $package in
59         ascd-* )
60             ./configure << EOF
61 /dev/cdrom
62 %{_bindir}
63 %{_mandir}/man1
64 %{_datadir}/afterstep/AScd
65 2
66 EOF
67             xmkmf
68             make Makefiles CXXDEBUGFLAGS="%{rpmcflags}" \
69                 CDEBUGFLAGS="%{rpmcflags}"
70             make MANDIR=%{_mandir}/man1 \
71                 BINDIR=%{_bindir} \
72                 SHLIBDIR=%{_libdir} \
73                 CXXDEBUGFLAGS="%{rpmcflags}" \
74                 CDEBUGFLAGS="%{rpmcflags}"
75             ;;
76
77         aterm* )
78             ## This program is provided by aterm rpm package.
79
80             # configure2_13 --enable-utmp
81             # make
82             ;;
83         asclock*)
84             CFLAGS="%{rpmcflags}" ./configure --prefix=%{_prefix} << EOF
85 classic
86
87 EOF
88              make CFLAGS="%{rpmcflags}"
89              ;;
90
91         ascp-* )
92
93             ## There is strange problem with this program.
94             ## The ./configure script tries to run /usr/local/bin/gtk-config
95             ## program. In PLD it should be %{_bindir}/gtk-config.
96             ##
97             ##    --with-gtk-prefix
98             ##    --with-gtk-exec-prefix
99             ## or --disable-gtktest
100             ## not help here. I don't now why.
101
102 # export LD_LIBRARY_PATH=%{_prefix}/
103             # configure2_13 \
104             #   --enable-i18n \
105             #   --x-includes=%{_includedir} \
106             #   --x-libraries=%{_libdir} \
107             #   --disable-gtktest
108 # --with-gtk-prefix=%{_prefix} \
109             #   --with-gtk-exec-prefix=%{_bindir}
110             # make
111             ;;
112
113         asfatm-* )
114             ## <sensors/sensors.h> is needed to compile this program.
115             ## I don't have it.
116
117             # cd asfatm
118             # make
119             ;;
120
121         asppp-* )
122             ## xpminit.c:7: dial.xpm: No such file or directory
123
124             # configure2_13
125             # make
126             ;;
127
128         miniCHESS-* )
129             #chess.c: In function `mouseGame':
130             #chess.c:1667: `fd_set' undeclared (first use in this function)
131             #chess.c:1667: (Each undeclared identifier is reported only once
132             #chess.c:1667: for each function it appears in.)
133             #chess.c:1667: parse error before `fdset'
134             #chess.c:1687: `fdset' undeclared (first use in this function)
135             #chess.c: In function `main':
136             #chess.c:1975: warning: return type of `main' is not `int'
137
138             #make
139             ;;
140
141         xiterm* )
142             ## You can try to build this program,
143             ## if only you have got utempter-devel.
144
145             # cough cough, hack hack -- ewt
146             # configure2_13 \
147             #   --enable-xpm-background \
148             #   --enable-utmp \
149             #   --enable-wtmp   \
150             #   --enable-menubar \
151             #   --enable-next-scroll
152             #    xmkmf
153             #    make Makefiles
154             #    cd src
155             #    sed -e "s/EXTRA_LIBRARIES =/EXTRA_LIBRARIES = -lutempter/" \
156             #       Makefile > Makefile.foo
157             #    sed -e "s/-lsocket //" Makefile.foo > Makefile
158             #    make CXXDEBUGFLAGS="%{rpmcflags}" \
159             #           CDEBUGFLAGS="%{rpmcflags}"
160             ;;
161
162         Tasks-*)
163             ## I think this program is not finished yet.
164             ## There is Makefile.in but I can't find anything to
165             ## create Makefile (there is no ./configure or configure.in)
166             ## I think that `mv Makefile.in Makefile' will be enough.
167             ## I will try this later.
168             ;;
169         xfascd-*)
170             ## I'll try to build this program later.
171             ;;
172
173         asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* \
174         | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* \
175         | astrash* | asxmcd* | asampmenu* | randbg-*)
176             ## We don't compile these
177             ;;
178
179         *)
180             #just about every other thing supports autoconf
181
182             %configure2_13
183             make
184             ;;
185     esac
186     cd ..
187 done
188
189 %install
190 rm -rf $RPM_BUILD_ROOT
191 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
192
193 for package in `ls` ; do
194     cd $package
195     case $package in
196
197         ascd-* )
198             make install install.man \
199                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
200                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
201                 MANDIR=%{_mandir}/man1 \
202                 BINDIR=%{_bindir} \
203                 SHLIBDIR=%{_libdir} \
204                 DESTDIR=$RPM_BUILD_ROOT
205             ;;
206
207         aterm*)
208             ## This program is provided by aterm.rpm package.
209
210             # make install \
211             #    AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
212             #   AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
213             #   DESTDIR=$RPM_BUILD_ROOT
214             ;;
215
216         xiterm*)
217             ## You can try to install this program,
218             ## if only you have got utempter-devel.
219             ## Don't forget build it first.
220
221
222             # make install install.man \
223             #   AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
224             #   AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
225             #   MANDIR=%{_mandir}/man1 \
226             #   BINDIR=%{_bindir} \
227             #   SHLIBDIR=%{_libdir} \
228             #   DESTDIR=$RPM_BUILD_ROOT
229             ;;
230
231         asfatm-*)
232             ## We don't install this.
233             ;;
234
235         ascp-*)
236             ## We do not install this. (If you want to know why check
237             ## the build section above).
238
239             # make install \
240             #   ASCP_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
241             #   ASCP_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
242             #   prefx=$RPM_BUILD_ROOT \
243             #   DESTDIR=$RPM_BUILD_ROOT
244             ;;
245
246         asppp-* | miniCHESS-* | Tasks-* | xfascd-*)
247             ## There were problems with these programs in build section.
248             ## We can not install it.
249             ;;
250         asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* \
251         | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* \
252         | astrash* | asxmcd* | asampmenu* | randbg-*)
253             ## We don't install these
254             ;;
255
256         *)
257             echo
258             make install install.man \
259                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
260                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
261                 DESTDIR=$RPM_BUILD_ROOT
262             ;;
263     esac
264     cd ..
265 done
266 rm -f $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}/{sessreg,xpmroot,qplot}*
267
268 %clean
269 rm -rf $RPM_BUILD_ROOT
270
271 %post -p /sbin/ldconfig
272 %postun -p /sbin/ldconfig
273
274 %files
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_bindir}/*
277
278 %{_datadir}/afterstep/*
279 %{_mandir}/man1/*
280 %{_libdir}/*
This page took 0.075672 seconds and 3 git commands to generate.