]> git.pld-linux.org Git - packages/AfterStep-APPS.git/blob - AfterStep-APPS.spec
adf964f03e2e9790bb9dfc4c36915cfeccd593cb
[packages/AfterStep-APPS.git] / AfterStep-APPS.spec
1 Summary:        Applets you can use with AfterStep and compatible window managers.
2 Name:           AfterStep-APPS
3 Version:        990329
4 Release:        2
5 Copyright:      GPL
6 Group:          X11/Applications
7 Source0:        http://www.tigr.net/afterstep/as-apps/download/as-apps-%{version}.tar
8 Patch0:         AfterStep-APPS-1.5beta1-glibc.patch
9 Patch1:         ascp-paths.patch
10 Patch2:         as-apps-compile.patch
11 Patch3:         aterm-utmp.patch
12 Patch4:         xiterm-utmp.patch
13 Prereq:         /sbin/ldconfig
14 Requires:       /usr/sbin/utempter
15 BuildRoot:      /tmp/%{name}-%{version}-root
16
17 %define         _prefix /usr/X11R6
18 %define         _mandir /usr/X11R6/man
19
20 %description
21 What's a cool window manager without some cool applets?
22 Well... it's still cool, but these applets which can
23 be used in the Wharf module for AfterStep or Window
24 Maker can add both spice and productivity to your
25 preferred window manager, such as a handy clock and
26 information about system resources.
27
28 If you've installed the AfterStep packages, you
29 should also install these packages. Enjoy! 
30
31 %prep
32 %setup -q -c
33 rm -f *.asc
34 for archive in *.tar.gz ; do
35         tar xzf $archive
36         rm -f $archive
37 done
38 %patch0 -p1
39 %patch1 -p1
40 %patch3 -p0
41 %patch4 -p1
42
43 %build
44 for package in `ls` ; do
45     cd $package 
46     case $package in
47         ascd-* )
48             ./configure << EOF
49 1
50
51 1
52
53
54
55 EOF
56             patch -p2 -b --suffix .compile < %{PATCH2}
57             xmkmf
58             make Makefiles CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
59                 CDEBUGFLAGS="$RPM_OPT_FLAGS"
60             make MANDIR=%{_mandir}/man1 \
61                 BINDIR=%{_bindir} \
62                 SHLIBDIR=%{_libdir} \
63                 CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
64                 CDEBUGFLAGS="$RPM_OPT_FLAGS"
65             ;;
66         
67         asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* | astrash* | asxmcd* )
68             # we don't compile these
69             ;;
70
71         aterm*)
72             %configure --enable-utmp
73             make
74             ;;
75
76         xiterm*)
77             # cough cough, hack hack -- ewt
78             %configure \
79                 --enable-xpm-background \
80                 --enable-utmp \
81                 --enable-wtmp \
82                 --enable-menubar \
83                 --enable-next-scroll
84             xmkmf
85             make Makefiles
86             cd src
87             sed -e "s/EXTRA_LIBRARIES =/EXTRA_LIBRARIES = -lutempter/" \
88                Makefile > Makefile.foo
89             sed -e "s/-lsocket //" Makefile.foo > Makefile
90             make CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
91                 CDEBUGFLAGS="$RPM_OPT_FLAGS"
92             ;;
93         asclock*)
94             CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} << EOF
95 classic
96
97 EOF
98              make CFLAGS="$RPM_OPT_FLAGS"
99              ;;
100         *)
101             #just about every other thing supports autoconf
102             %configure
103             make
104             ;;
105     esac
106     cd ..
107 done
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
112
113 for package in `ls` ; do
114     cd $package 
115     case $package in
116         ascd-* | xiterm*)
117             make install install.man \
118                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
119                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
120                 MANDIR=%{_mandir}/man1 \
121                 BINDIR=%{_bindir} \
122                 SHLIBDIR=%{_libdir} \
123                 DESTDIR=$RPM_BUILD_ROOT 
124             ;;
125
126         asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* | astrash* | asxmcd* )
127             # we don't install this
128             ;;
129
130         ascp-* )
131             make install \
132                 ASCP_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
133                 ASCP_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
134                 prefx=$RPM_BUILD_ROOT \
135                 DESTDIR=$RPM_BUILD_ROOT
136             ;;
137         
138
139         asppp* | aterm* )
140             make install \
141                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
142                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
143                 DESTDIR=$RPM_BUILD_ROOT
144             ;;
145         *)
146             make install install.man \
147                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
148                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
149                 DESTDIR=$RPM_BUILD_ROOT
150             ;;
151     esac
152     cd ..
153 done
154 rm -f $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}/{sessreg,xpmroot,qplot}*
155 strip --strip-unneeded $RPM_BUILD_ROOT%{_bindir}/*
156
157 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/*
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/*
168 %{_datadir}/afterstep/*
169 %{_mandir}/man1/*
This page took 0.359508 seconds and 2 git commands to generate.