]> git.pld-linux.org Git - packages/AfterStep-APPS.git/blob - AfterStep-APPS.spec
added pl translations
[packages/AfterStep-APPS.git] / AfterStep-APPS.spec
1 Summary:        Applets you can use with AfterStep and compatible window managers.
2 Summary(pl):    Aplety, których mo¿esz u¿ywaæ z AfterStepem oraz innymi zarz±dcami okien, które s± z nim kompatybilne
3 Name:           AfterStep-APPS
4 Version:        990329
5 Release:        3
6 Copyright:      GPL
7 Group:          X11/Window Managers/Tools
8 Group(pl):      X11/Zarz±dcy okien/Narzêdzia
9 Source:         http://www.tigr.net/afterstep/as-apps/download/as-apps-%{version}.tar
10 Patch0:         AfterStep-APPS-1.5beta1-glibc.patch
11 Patch1:         ascp-paths.patch
12 Patch2:         as-apps-compile.patch
13 Patch3:         aterm-utmp.patch
14 Patch4:         xiterm-utmp.patch
15 Prereq:         /sbin/ldconfig
16 Requires:       /usr/sbin/utempter
17 BuildRoot:      /tmp/%{name}-%{version}-root
18
19 %define         _prefix /usr/X11R6
20 %define         _mandir /usr/X11R6/man
21
22 %description
23 What's a cool window manager without some cool applets?
24 Well... it's still cool, but these applets which can
25 be used in the Wharf module for AfterStep or Window
26 Maker can add both spice and productivity to your
27 preferred window manager, such as a handy clock and
28 information about system resources.
29
30 If you've installed the AfterStep packages, you
31 should also install these packages. Enjoy! 
32
33 %description -l pl
34 Czym jest fajny zarz±dca okien bez fajnych apletów?
35 Có¿... jest nadal fajnym zarz±dc± okien, ale aplety, które mog± byæ u¿ywane
36 w module Wharf AfterStepa lub Window Makera, mog³yby zwiêkszyæ efektywno¶æ
37 i efektowno¶æ twojego ulubionego zarz±dcy okien.
38
39 Je¿eli masz zainstalowanego AfterStepa to powiniene¶ zainstalowaæ tak¿e ten
40 pakiet. Mi³ej zabawy!
41
42 %prep
43 %setup -q -c
44 rm -f *.asc
45 for archive in *.tar.gz ; do
46         tar xzf $archive
47         rm -f $archive
48 done
49 %patch0 -p1
50 %patch1 -p1
51 %patch3 -p0
52 %patch4 -p1
53
54 %build
55 for package in `ls` ; do
56     cd $package 
57     case $package in
58         ascd-* )
59             ./configure << EOF
60 1
61
62 1
63
64
65
66 EOF
67             patch -p2 -b --suffix .compile < %{PATCH2}
68             xmkmf
69             make Makefiles CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
70                 CDEBUGFLAGS="$RPM_OPT_FLAGS"
71             make MANDIR=%{_mandir}/man1 \
72                 BINDIR=%{_bindir} \
73                 SHLIBDIR=%{_libdir} \
74                 CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
75                 CDEBUGFLAGS="$RPM_OPT_FLAGS"
76             ;;
77         
78         asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* | astrash* | asxmcd* )
79             # we don't compile these
80             ;;
81
82         aterm*)
83             %configure --enable-utmp
84             make
85             ;;
86
87         xiterm*)
88             # cough cough, hack hack -- ewt
89             %configure \
90                 --enable-xpm-background \
91                 --enable-utmp \
92                 --enable-wtmp \
93                 --enable-menubar \
94                 --enable-next-scroll
95             xmkmf
96             make Makefiles
97             cd src
98             sed -e "s/EXTRA_LIBRARIES =/EXTRA_LIBRARIES = -lutempter/" \
99                Makefile > Makefile.foo
100             sed -e "s/-lsocket //" Makefile.foo > Makefile
101             make CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
102                 CDEBUGFLAGS="$RPM_OPT_FLAGS"
103             ;;
104         asclock*)
105             CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} << EOF
106 classic
107
108 EOF
109              make CFLAGS="$RPM_OPT_FLAGS"
110              ;;
111         *)
112             #just about every other thing supports autoconf
113             %configure
114             make
115             ;;
116     esac
117     cd ..
118 done
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
123
124 for package in `ls` ; do
125     cd $package 
126     case $package in
127         ascd-* | xiterm*)
128             make install install.man \
129                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
130                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
131                 MANDIR=%{_mandir}/man1 \
132                 BINDIR=%{_bindir} \
133                 SHLIBDIR=%{_libdir} \
134                 DESTDIR=$RPM_BUILD_ROOT 
135             ;;
136
137         asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* | astrash* | asxmcd* )
138             # we don't install this
139             ;;
140
141         ascp-* )
142             make install \
143                 ASCP_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
144                 ASCP_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
145                 prefx=$RPM_BUILD_ROOT \
146                 DESTDIR=$RPM_BUILD_ROOT
147             ;;
148         
149
150         asppp* | aterm* )
151             make install \
152                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
153                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
154                 DESTDIR=$RPM_BUILD_ROOT
155             ;;
156         *)
157             make install install.man \
158                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
159                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
160                 DESTDIR=$RPM_BUILD_ROOT
161             ;;
162     esac
163     cd ..
164 done
165 rm -f $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}/{sessreg,xpmroot,qplot}*
166 strip --strip-unneeded $RPM_BUILD_ROOT%{_bindir}/*
167
168 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/*
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post -p /sbin/ldconfig
174 %postun -p /sbin/ldconfig
175
176 %files
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_bindir}/*
179 %{_datadir}/afterstep/*
180 %{_mandir}/man1/*
This page took 0.399519 seconds and 3 git commands to generate.