]> git.pld-linux.org Git - packages/AMD.git/blob - AMD.spec
9c2c870bd5e7671a4a45445ed47c36d27a5a502e
[packages/AMD.git] / AMD.spec
1 Summary:        AMD: Approximate Minimum Degree
2 Summary(pl.UTF-8):      AMD - przybliżony algorytm minimalnego stopnia
3 Name:           AMD
4 Version:        2.4.0
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Libraries
8 Source0:        http://www.cise.ufl.edu/research/sparse/amd/%{name}-%{version}.tar.gz
9 # Source0-md5:  5044de774a2f7804d09ac0d5134d6884
10 Patch0:         amd-ufconfig.patch
11 Patch1:         amd-shared.patch
12 URL:            http://www.cise.ufl.edu/research/sparse/amd/
13 BuildRequires:  SuiteSparse_config >= 4.3.0
14 BuildRequires:  gcc-fortran
15 BuildRequires:  libtool >= 2:1.5
16 Requires:       SuiteSparse_config-libs >= 4.3.0
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 AMD is a set of routines for ordering a sparse matrix prior to
21 Cholesky factorization (or for LU factorization with diagonal
22 pivoting). There are versions in both C and Fortran. A MATLAB
23 interface is provided. Note that this software has nothing to do with
24 AMD the company.
25
26 %description -l pl.UTF-8
27 AMD to zbiór procedur do porządkowania macierzy rzadkich przed
28 rozkładem Cholesky'ego (lub do rozkładu LU z obrotami diagonalnymi).
29 Istnieją wersje zarówno w C, jak i Fortranie. Dostępny jest interfejs
30 do MATLAB-a. Uwaga: to oprogramowanie nie ma nic wspólnego z firmą
31 AMD.
32
33 %package devel
34 Summary:        Header files for AMD library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AMD
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       SuiteSparse_config >= 4.3.0
39
40 %description devel
41 Header files for AMD library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki AMD.
45
46 %package static
47 Summary:        Static AMD library
48 Summary(pl.UTF-8):      Statyczna biblioteka AMD
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static AMD library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka AMD.
57
58 %package fortran
59 Summary:        Fortran version of AMD library
60 Summary(pl.UTF-8):      Wersja biblioteki AMD dla programów w Fortranie
61 Group:          Libraries
62
63 %description fortran
64 Fortran version of AMD library.
65
66 %description fortran -l pl.UTF-8
67 Wersja biblioteki AMD dla programów napisanych w Fortranie.
68
69 %package fortran-devel
70 Summary:        Fortran version of AMD library - development files
71 Summary(pl.UTF-8):      Wersja biblioteki AMD dla programów w Fortranie - pliki programistyczne
72 Group:          Development/Libraries
73 Requires:       %{name}-fortran = %{version}-%{release}
74
75 %description fortran-devel
76 Fortran version of AMD library - development files.
77
78 %description fortran-devel -l pl.UTF-8
79 Wersja biblioteki AMD dla programów w Fortranie - pliki
80 programistyczne.
81
82 %package fortran-static
83 Summary:        Fortran version of AMD static library
84 Summary(pl.UTF-8):      Wersja statycznej biblioteki AMD dla programów w Fortranie
85 Group:          Development/Libraries
86 Requires:       %{name}-fortran-devel = %{version}-%{release}
87
88 %description fortran-static
89 Fortran version of AMD static library.
90
91 %description fortran-static -l pl.UTF-8
92 Wersja statycznej biblioteki AMD dla programów napisanych w Fortranie.
93
94 %prep
95 %setup -q -n %{name}
96 %patch0 -p1
97 %patch1 -p1
98
99 %build
100 %{__make} \
101         CC="%{__cc}" \
102         CFLAGS="%{rpmcflags}" \
103         LDFLAGS="%{rpmldflags}" \
104         libdir=%{_libdir}
105
106 %{__make} fortran \
107         CC="%{__cc}" \
108         CFLAGS="%{rpmcflags}" \
109         LDFLAGS="%{rpmldflags}" \
110         libdir=%{_libdir}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT%{_includedir}/amd
115
116 %{__make} -C Lib install install-fortran \
117         DESTDIR=$RPM_BUILD_ROOT \
118         libdir=%{_libdir}
119
120 install Include/*.h $RPM_BUILD_ROOT%{_includedir}/amd
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc README.txt Doc/{ChangeLog,License}
131 %attr(755,root,root) %{_libdir}/libamd.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libamd.so.0
133
134 %files devel
135 %defattr(644,root,root,755)
136 %doc Doc/AMD_UserGuide.pdf
137 %attr(755,root,root) %{_libdir}/libamd.so
138 %{_libdir}/libamd.la
139 %{_includedir}/amd
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libamd.a
144
145 %files fortran
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libamdf77.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libamdf77.so.0
149
150 %files fortran-devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libamdf77.so
153 %{_libdir}/libamdf77.la
154
155 %files fortran-static
156 %defattr(644,root,root,755)
157 %{_libdir}/libamdf77.a
This page took 0.067115 seconds and 2 git commands to generate.