]> git.pld-linux.org Git - packages/A3Com.git/commitdiff
- more sed-patching
authorPaweł Gołaszewski <blues@pld-linux.org>
Fri, 28 Jun 2002 11:29:15 +0000 (11:29 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- config and cache-dir added (not nice)

Changed files:
    A3Com.spec -> 1.2

A3Com.spec

index 925db9441314bd804413a73ec522c2bde6288d8d..b1dd2552bc7f2b1cb9199e4bbab1233587fd0e09 100644 (file)
@@ -33,26 +33,40 @@ to:
 %setup -q
 
 %build
+# Change path for perl:
 for i in tools/*; do
-cat $i | sed -e "s/\%{_prefix}\/local\/bin/\%{_prefix}\/bin/" > tmp
+       cat $i | sed -e "s/\/usr\/local\/bin/\%{_prefix}\/bin/" > tmp
        mv tmp $i
 done
+# Change location of config:
+for i in A3Com/*; do
+       cat $i | sed -e "s/\/usr\/local\/etc/\/etc/" > tmp
+       mv tmp $i
+done
+
+# Make modules:
 perl Makefile.PL
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_bindir}
+install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/A3Com,%{_sysconfdir}}
 
 %{__make} DESTDIR=$RPM_BUILD_ROOT install
 
 install tools/*                $RPM_BUILD_ROOT%{_bindir}
 
+cat << EOF >$RPM_BUILD_ROOT%{_sysconfdir}/a3com.conf
+GLOBALCACHEDIR = /var/lib/A3Com
+EOF
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 %doc CHANGELOG TODO README test.pl
+%attr(777,root,root) %dir /var/lib/A3Com
+%attr(644,root,root) %{_sysconfdir}/a3com.conf
 %attr(755,root,root) %{_bindir}/*
 %{perl_sitelib}/A3Com/*.pm
This page took 0.047987 seconds and 4 git commands to generate.