]> git.pld-linux.org Git - packages/4store.git/commitdiff
- 0.9.5
authoraredridel <aredridel@pld-linux.org>
Sun, 9 Aug 2009 19:25:51 +0000 (19:25 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    4store-bashisms.patch -> 1.1
    4store-termcap.patch -> 1.2
    4store.spec -> 1.2

4store-bashisms.patch [new file with mode: 0644]
4store-termcap.patch
4store.spec

diff --git a/4store-bashisms.patch b/4store-bashisms.patch
new file mode 100644 (file)
index 0000000..b902ab5
--- /dev/null
@@ -0,0 +1,91 @@
+diff -ur 4store-v0.9.5-o/src/utilities/4s-cluster-cache 4store-v0.9.5/src/utilities/4s-cluster-cache
+--- 4store-v0.9.5-o/src/utilities/4s-cluster-cache     2009-07-31 05:59:38.000000000 -0600
++++ 4store-v0.9.5/src/utilities/4s-cluster-cache       2009-08-09 13:17:49.949668010 -0600
+@@ -1,5 +1,5 @@
+ #!/bin/sh
+-if (($# == 1)) ; then
++if [ $# =  1 ]; then
+  logger -t $0 "'$*' by $USER"
+  4s-ssh-all 'for i in /var/lib/4store/'$1'/0*; do echo mv $i $i~; echo cp -a $i done'
+ else 
+diff -ur 4store-v0.9.5-o/src/utilities/4s-cluster-copy 4store-v0.9.5/src/utilities/4s-cluster-copy
+--- 4store-v0.9.5-o/src/utilities/4s-cluster-copy      2009-07-31 05:59:38.000000000 -0600
++++ 4store-v0.9.5/src/utilities/4s-cluster-copy        2009-08-09 13:18:03.015485601 -0600
+@@ -1,5 +1,5 @@
+ #!/bin/sh
+-if (($# >= 2)) ; then
++if [ $# -ge 2 ] ; then
+  logger -t $0 "'$*' by $USER"
+  4s-ssh-all-parallel 4s-backend-copy "$@"
+ else 
+diff -ur 4store-v0.9.5-o/src/utilities/4s-cluster-create 4store-v0.9.5/src/utilities/4s-cluster-create
+--- 4store-v0.9.5-o/src/utilities/4s-cluster-create    2009-07-31 05:59:38.000000000 -0600
++++ 4store-v0.9.5/src/utilities/4s-cluster-create      2009-08-09 13:18:13.348817741 -0600
+@@ -1,5 +1,5 @@
+ #!/bin/sh
+-if (($# >= 1)) ; then
++if [ $# = 1 ]; then
+  logger -t $0 "'$*' by $USER"
+  4s-ssh-all-parallel 4s-backend-setup --node '$id' --cluster '$nodes' --segments 32 "$@"
+ else 
+diff -ur 4store-v0.9.5-o/src/utilities/4s-cluster-destroy 4store-v0.9.5/src/utilities/4s-cluster-destroy
+--- 4store-v0.9.5-o/src/utilities/4s-cluster-destroy   2009-07-31 05:59:38.000000000 -0600
++++ 4store-v0.9.5/src/utilities/4s-cluster-destroy     2009-08-09 13:18:23.118819448 -0600
+@@ -1,5 +1,5 @@
+ #!/bin/sh
+-if (($# == 1)) ; then
++if [ $# = 1 ]; then
+  logger -t $0 "'$*' by $USER"
+  4s-ssh-all-parallel 4s-backend-destroy "$@"
+ else 
+diff -ur 4store-v0.9.5-o/src/utilities/4s-cluster-info 4store-v0.9.5/src/utilities/4s-cluster-info
+--- 4store-v0.9.5-o/src/utilities/4s-cluster-info      2009-07-31 05:59:38.000000000 -0600
++++ 4store-v0.9.5/src/utilities/4s-cluster-info        2009-08-09 13:19:10.108811466 -0600
+@@ -1,5 +1,5 @@
+ #!/bin/sh
+-if (($# == 1)) ; then
++if [ $# = 1 ]; then
+  4s-ssh-all-parallel 4s-backend-info "$1"
+ else 
+  echo "Usage: $0 <kbname>"
+diff -ur 4store-v0.9.5-o/src/utilities/4s-cluster-replication-disable 4store-v0.9.5/src/utilities/4s-cluster-replication-disable
+--- 4store-v0.9.5-o/src/utilities/4s-cluster-replication-disable       2009-07-31 05:59:38.000000000 -0600
++++ 4store-v0.9.5/src/utilities/4s-cluster-replication-disable 2009-08-09 13:19:17.105478080 -0600
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+-if (($# == 1)) ; then
++if [ $# = 1 ]; then
+  4s-ssh-all grep -q 'segment_m' '/var/lib/4store/'$1'/metadata.nt' '&&' sed "'/<http:\/\/id128.com\/4store#segment_m>/d'" '-i~' '/var/lib/4store/'$1'/metadata.nt'  '||' echo 'replication not enabled'
+ else 
+  echo "Usage: $0 <kbname>"
+diff -ur 4store-v0.9.5-o/src/utilities/4s-cluster-start 4store-v0.9.5/src/utilities/4s-cluster-start
+--- 4store-v0.9.5-o/src/utilities/4s-cluster-start     2009-07-31 05:59:38.000000000 -0600
++++ 4store-v0.9.5/src/utilities/4s-cluster-start       2009-08-09 13:19:24.712143630 -0600
+@@ -1,5 +1,5 @@
+ #!/bin/sh
+-if (($# == 1)) ; then
++if [ $# = 1 ]; then
+  logger -t $0 "'$*' by $USER"
+  4s-ssh-all 4s-backend "$1"
+ else 
+diff -ur 4store-v0.9.5-o/src/utilities/4s-cluster-stop 4store-v0.9.5/src/utilities/4s-cluster-stop
+--- 4store-v0.9.5-o/src/utilities/4s-cluster-stop      2009-07-31 05:59:38.000000000 -0600
++++ 4store-v0.9.5/src/utilities/4s-cluster-stop        2009-08-09 13:19:31.048806050 -0600
+@@ -1,5 +1,5 @@
+ #!/bin/sh
+-if (($# == 1)) ; then
++if [ $# = 1 ] ; then
+  logger -t $0 "'$*' by $USER"
+  4s-ssh-all "pkill -f ^4s-backend\ $1\$ || echo No matching 4store backend"
+ else 
+diff -ur 4store-v0.9.5-o/src/utilities/4s-file-backup 4store-v0.9.5/src/utilities/4s-file-backup
+--- 4store-v0.9.5-o/src/utilities/4s-file-backup       2009-07-31 05:59:38.000000000 -0600
++++ 4store-v0.9.5/src/utilities/4s-file-backup 2009-08-09 13:19:36.662147873 -0600
+@@ -1,5 +1,5 @@
+ #!/bin/sh
+-if (($# == 1)) ; then
++if [ $# = 1 ] ; then
+  (find /var/lib/4store/$1/ -newer /var/lib/4store/$1/backup || echo "always") |
+       grep "" > /dev/null || exit 2;
+  touch /var/lib/4store/$1/backup
index eccf28bc5b4b715906236ef131143f84c9f57026..6347808f941d52cb0d224f8678339d57064cf828 100644 (file)
@@ -1,23 +1,30 @@
-diff -ur 4store-v0.9.2-o/configure 4store-v0.9.2/configure
---- 4store-v0.9.2-o/configure  2009-07-14 03:10:22.000000000 -0600
-+++ 4store-v0.9.2/configure    2009-07-15 22:38:51.500429771 -0600
-@@ -32,7 +32,6 @@
+diff -ur 4store-v0.9.5-o/configure 4store-v0.9.5/configure
+--- 4store-v0.9.5-o/configure  2009-07-31 05:59:28.000000000 -0600
++++ 4store-v0.9.5/configure    2009-08-09 13:14:17.442170688 -0600
+@@ -31,7 +31,6 @@
+ pkg-config --exists glib-2.0 && pass "glib2 installed" || fail "no glib2 devel system"
  test -e "`which pcre-config`" && pass "pcre installed" || fail "no pcre devel system installed"
- libtest "readline"
  libtest "ncurses"
 -libtest "termcap"
- pkg-config --exists avahi && pass "avahi installed" || optfail "no avahi, will build without cluster support"
+ libtest "readline" "-lncurses"
+ pkg-config --exists avahi-glib avahi-client && pass "avahi installed" || ( test -e /usr/include/dns_sd.h && pass "dns_sd installed" || optfail "no mDNS library, will build without cluster support" )
  
- rm -f /tmp/configure-$$.*
-diff -ur 4store-v0.9.2-o/src/utilities/Makefile 4store-v0.9.2/src/utilities/Makefile
---- 4store-v0.9.2-o/src/utilities/Makefile     2009-07-15 22:32:12.751531050 -0600
-+++ 4store-v0.9.2/src/utilities/Makefile       2009-07-15 22:38:25.512972143 -0600
+Only in 4store-v0.9.5: configure~
+Only in 4store-v0.9.5: configure.orig
+Only in 4store-v0.9.5: configure.rej
+Only in 4store-v0.9.5: configure.rej~
+diff -ur 4store-v0.9.5-o/src/utilities/Makefile 4store-v0.9.5/src/utilities/Makefile
+--- 4store-v0.9.5-o/src/utilities/Makefile     2009-08-09 13:13:32.775689992 -0600
++++ 4store-v0.9.5/src/utilities/Makefile       2009-08-09 13:14:34.785501578 -0600
 @@ -2,7 +2,7 @@
  include ../darwin.mk
  
  CFLAGS = -Wall -g -std=gnu99 -I.. -DGIT_REV=\"$(gitrev)\" `pkg-config --cflags glib-2.0`
--LDFLAGS = $(ldfdarwin) $(ldflinux) `pkg-config --libs glib-2.0 raptor` -lreadline -ltermcap
-+LDFLAGS = $(ldfdarwin) $(ldflinux) `pkg-config --libs glib-2.0 raptor` -lreadline
+-LDFLAGS = $(ldfdarwin) $(ldflinux) -lz `pkg-config --libs glib-2.0 raptor` -lreadline -ltermcap
++LDFLAGS = $(ldfdarwin) $(ldflinux) -lz `pkg-config --libs glib-2.0 raptor` -lreadline
  
  BINS = 4s-backend-setup 4s-backend-destroy 4s-backend-info 4s-backend-copy \
   4s-backend-passwd 4s-rid
+Only in 4store-v0.9.5/src/utilities: Makefile~
+Only in 4store-v0.9.5/src/utilities: Makefile.orig
+Only in 4store-v0.9.5/src/utilities: Makefile.rej
index 0d8abf78b6c13f10b0fc4d0ce64e813d64186ac3..3cbddc2cd76cae74b03491c3067b05a13498e41a 100644 (file)
@@ -1,15 +1,16 @@
 Summary:       Fast RDF quad store
 Name:          4store
-Version:       0.9.2
+Version:       0.9.5
 Release:       1
 License:       LGPL v2+
 Group:         Applications/Databases
 Source0:       http://4store.org/download/%{name}-v%{version}.tar.gz
-# Source0-md5: 40cff8523f2bcff56d2ee6f826fec43d
+# Source0-md5: 449d1fdac43af2cdf3029e0f7392d31f
 URL:           http://4store.org/
 Patch0:                %{name}-prefix.patch
 Patch1:                %{name}-termcap.patch
 Patch2:                %{name}-destdir.patch
+Patch3:                %{name}-bashisms.patch
 BuildRequires: autoconf >= 2.59-9
 BuildRequires: automake
 BuildRequires: libstdc++-devel
@@ -57,6 +58,7 @@ Statyczne biblioteki 4store.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__make}
This page took 0.095025 seconds and 4 git commands to generate.