]> git.pld-linux.org Git - packages/0ad.git/blob - 0ad.spec
- first release, nfy
[packages/0ad.git] / 0ad.spec
1 #
2 # TODO: - use arch dependend compilers
3 #       - check licenses
4 #       - probably BRs
5 #
6 %define         svn_ver r8832
7 Summary:        Free, Open-Source, cross-platform RTS game of ancient warfare
8 Name:           0ad
9 Version:        %{svn_ver}
10 Release:        0.%{svn_ver}.1
11 License:        GPL v2+
12 Group:          X11/Applications/Games
13 Source0:        %{name}-%{version}-alpha-unix-build.tar.gz
14 # Source0-md5:  f38d660d039a37edebb2ea2f0eb6aa6d
15 URL:            http://wildfiregames.com/0ad/
16 BuildRequires:  boost-devel
17 BuildRequires:  sed >= 4.0
18 BuildRequires:  wxGTK2-unicode-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 0 A.D. (pronounced "zero ey-dee") is a free, open-source,
23 cross-platform real-time strategy (RTS) game of ancient warfare. In
24 short, it is a historically-based war/economy game that allows players
25 to relive or rewrite the history of Western civilizations, focusing on
26 the years between 500 B.C. and 500 A.D. The project is highly
27 ambitious, involving state-of-the-art 3D graphics, detailed artwork,
28 sound, and a flexible and powerful custom-built game engine.
29
30 %prep
31 %setup -q -n %{name}
32
33 # force link with libboost_*.so not libboost_*-mt.so
34 %{__sed} -i 's,-mt,,g' build/premake/extern_libs.lua
35
36 # use wx-gtk2-unicode-config instead of wx-config
37 %{__sed} -i 's,wx-config,wx-gtk2-unicode-config,' build/premake/extern_libs.lua
38
39 %build
40 export CFLAGS="%{rpmcflags}"
41 export CPPFLAGS="%{rpmcxxflags}"
42 cd build/workspaces
43 ./update-workspaces.sh \
44         --verbose \
45         --bindir %{_bindir} \
46         --datadir %{_datadir}/%{name} \
47         --libdir %{_libdir}/%{name}
48
49 cd gcc
50 %{__make} \
51         CONFIG=Release
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
56
57 # binaries
58 cp -a build/resources/0ad.sh $RPM_BUILD_ROOT%{_bindir}/0ad
59 cp -a binaries/system/pyrogenesis $RPM_BUILD_ROOT%{_bindir}
60
61 # libraries
62 cp -a binaries/system/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
63
64 # menu icon
65 cp -a build/resources/0ad.desktop $RPM_BUILD_ROOT%{_desktopdir}
66 cp -a build/resources/0ad.png $RPM_BUILD_ROOT%{_pixmapsdir}
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc README.txt
74 %attr(755,root,root) %{_bindir}/0ad
75 %attr(755,root,root) %{_bindir}/pyrogenesis
76 %dir %{_libdir}/0ad
77 %{_libdir}/0ad/*.so
78 %{_desktopdir}/0ad.desktop
79 %{_pixmapsdir}/0ad.png
This page took 0.042166 seconds and 3 git commands to generate.