]> git.pld-linux.org Git - packages/0ad.git/blob - 0ad.spec
4ac48c8821eb6a7f6f3f12e99f1f54a9ab30a75e
[packages/0ad.git] / 0ad.spec
1 #
2 # TODO: - use arch dependend compilers
3 #       - check licenses
4 #       - try to make it runnable by non-privileged users (sth wrong with boost?)
5 #       - fix problem with font finding
6 #
7 %define         svn_ver r8832
8 Summary:        Free, Open-Source, cross-platform RTS game of ancient warfare
9 Name:           0ad
10 Version:        %{svn_ver}
11 Release:        0.%{svn_ver}.1
12 License:        GPL v2+
13 Group:          X11/Applications/Games
14 Source0:        %{name}-%{version}-alpha-unix-build.tar.gz
15 # Source0-md5:  f38d660d039a37edebb2ea2f0eb6aa6d
16 URL:            http://wildfiregames.com/0ad/
17 BuildRequires:  DevIL-devel
18 BuildRequires:  OpenAL-devel
19 BuildRequires:  OpenGL-devel
20 BuildRequires:  SDL-devel
21 BuildRequires:  boost-devel
22 BuildRequires:  cmake
23 BuildRequires:  enet-devel < 1.3.0
24 BuildRequires:  enet-devel >= 1.2.0
25 BuildRequires:  libogg-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libvorbis-devel
28 BuildRequires:  libxml2-devel
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  wxGTK2-unicode-devel
31 BuildRequires:  zlib-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 0 A.D. (pronounced "zero ey-dee") is a free, open-source,
36 cross-platform real-time strategy (RTS) game of ancient warfare. In
37 short, it is a historically-based war/economy game that allows players
38 to relive or rewrite the history of Western civilizations, focusing on
39 the years between 500 B.C. and 500 A.D. The project is highly
40 ambitious, involving state-of-the-art 3D graphics, detailed artwork,
41 sound, and a flexible and powerful custom-built game engine.
42
43 %prep
44 %setup -q -n %{name}
45
46 # force link with libboost_*.so not libboost_*-mt.so
47 %{__sed} -i 's,-mt,,g' build/premake/extern_libs.lua
48
49 # use wx-gtk2-unicode-config instead of wx-config
50 %{__sed} -i 's,wx-config,wx-gtk2-unicode-config,' build/premake/extern_libs.lua
51
52 %build
53 export CFLAGS="%{rpmcflags}"
54 export CPPFLAGS="%{rpmcxxflags}"
55 cd build/workspaces
56 ./update-workspaces.sh \
57         --verbose \
58         --bindir %{_bindir} \
59         --datadir %{_datadir}/%{name} \
60         --libdir %{_libdir}/%{name}
61
62 cd gcc
63 %{__make} \
64         CONFIG=Release
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
69
70 # binaries
71 cp -a build/resources/0ad.sh $RPM_BUILD_ROOT%{_bindir}/0ad
72 cp -a binaries/system/pyrogenesis $RPM_BUILD_ROOT%{_bindir}
73
74 # libraries
75 cp -a binaries/system/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
76
77 # menu icon
78 cp -a build/resources/0ad.desktop $RPM_BUILD_ROOT%{_desktopdir}
79 cp -a build/resources/0ad.png $RPM_BUILD_ROOT%{_pixmapsdir}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc README.txt
87 %attr(755,root,root) %{_bindir}/0ad
88 %attr(755,root,root) %{_bindir}/pyrogenesis
89 %dir %{_libdir}/0ad
90 %{_libdir}/0ad/*.so
91 %{_desktopdir}/0ad.desktop
92 %{_pixmapsdir}/0ad.png
This page took 0.083533 seconds and 2 git commands to generate.