]> git.pld-linux.org Git - packages/0ad.git/blob - 0ad.spec
- more BRs
[packages/0ad.git] / 0ad.spec
1 #
2 # TODO: - use arch dependend compilers
3 #       - check licenses
4 #
5 %define         svn_ver r8832
6 Summary:        Free, Open-Source, cross-platform RTS game of ancient warfare
7 Name:           0ad
8 Version:        %{svn_ver}
9 Release:        0.%{svn_ver}.1
10 License:        GPL v2+
11 Group:          X11/Applications/Games
12 Source0:        %{name}-%{version}-alpha-unix-build.tar.gz
13 # Source0-md5:  f38d660d039a37edebb2ea2f0eb6aa6d
14 URL:            http://wildfiregames.com/0ad/
15 BuildRequires:  DevIL-devel
16 BuildRequires:  OpenAL-devel
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  SDL-devel
19 BuildRequires:  boost-devel
20 BuildRequires:  cmake
21 BuildRequires:  enet < 1.3.0
22 BuildRequires:  enet >= 1.2.0
23 BuildRequires:  libogg-devel
24 BuildRequires:  libpng-devel
25 BuildRequires:  libvorbis-devel
26 BuildRequires:  libxml2-devel
27 BuildRequires:  sed >= 4.0
28 BuildRequires:  wxGTK2-unicode-devel
29 BuildRequires:  zlib-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 0 A.D. (pronounced "zero ey-dee") is a free, open-source,
34 cross-platform real-time strategy (RTS) game of ancient warfare. In
35 short, it is a historically-based war/economy game that allows players
36 to relive or rewrite the history of Western civilizations, focusing on
37 the years between 500 B.C. and 500 A.D. The project is highly
38 ambitious, involving state-of-the-art 3D graphics, detailed artwork,
39 sound, and a flexible and powerful custom-built game engine.
40
41 %prep
42 %setup -q -n %{name}
43
44 # force link with libboost_*.so not libboost_*-mt.so
45 %{__sed} -i 's,-mt,,g' build/premake/extern_libs.lua
46
47 # use wx-gtk2-unicode-config instead of wx-config
48 %{__sed} -i 's,wx-config,wx-gtk2-unicode-config,' build/premake/extern_libs.lua
49
50 %build
51 export CFLAGS="%{rpmcflags}"
52 export CPPFLAGS="%{rpmcxxflags}"
53 cd build/workspaces
54 ./update-workspaces.sh \
55         --verbose \
56         --bindir %{_bindir} \
57         --datadir %{_datadir}/%{name} \
58         --libdir %{_libdir}/%{name}
59
60 cd gcc
61 %{__make} \
62         CONFIG=Release
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
67
68 # binaries
69 cp -a build/resources/0ad.sh $RPM_BUILD_ROOT%{_bindir}/0ad
70 cp -a binaries/system/pyrogenesis $RPM_BUILD_ROOT%{_bindir}
71
72 # libraries
73 cp -a binaries/system/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
74
75 # menu icon
76 cp -a build/resources/0ad.desktop $RPM_BUILD_ROOT%{_desktopdir}
77 cp -a build/resources/0ad.png $RPM_BUILD_ROOT%{_pixmapsdir}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc README.txt
85 %attr(755,root,root) %{_bindir}/0ad
86 %attr(755,root,root) %{_bindir}/pyrogenesis
87 %dir %{_libdir}/0ad
88 %{_libdir}/0ad/*.so
89 %{_desktopdir}/0ad.desktop
90 %{_pixmapsdir}/0ad.png
This page took 0.535165 seconds and 3 git commands to generate.