]> git.pld-linux.org Git - packages/0ad.git/blame_incremental - 0ad.spec
- BR: nvidia-texture-tools
[packages/0ad.git] / 0ad.spec
... / ...
CommitLineData
1#
2# TODO: - use arch dependend compilers
3# - check licenses
4# - try to make it runnable by non-privileged users (sth wrong with boost?)
5# - fix problem with font finding
6#
7%define svn_ver r10803
8Summary: Free, Open-Source, cross-platform RTS game of ancient warfare
9Name: 0ad
10Version: %{svn_ver}
11Release: 0.alpha.1
12License: GPL v2+
13Group: X11/Applications/Games
14Source0: http://releases.wildfiregames.com/%{name}-%{version}-alpha-unix-build.tar.xz
15# Source0-md5: 92ac750c433a8aea4db602019b27a274
16URL: http://wildfiregames.com/0ad/
17BuildRequires: DevIL-devel
18BuildRequires: OpenAL-devel
19BuildRequires: OpenGL-devel
20BuildRequires: SDL-devel
21BuildRequires: boost-devel
22BuildRequires: cmake
23BuildRequires: curl-devel
24BuildRequires: enet-devel >= 1.2.0
25BuildRequires: fam-devel
26BuildRequires: libogg-devel
27BuildRequires: libpng-devel
28BuildRequires: libvorbis-devel
29BuildRequires: libxml2-devel
30BuildRequires: nasm
31BuildRequires: nvidia-texture-tools-devel
32BuildRequires: perl-base
33BuildRequires: pkgconfig
34BuildRequires: python
35BuildRequires: python-modules
36BuildRequires: sed >= 4.0
37BuildRequires: wxGTK2-unicode-gl-devel
38BuildRequires: zip
39BuildRequires: zlib-devel
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
430 A.D. (pronounced "zero ey-dee") is a free, open-source,
44cross-platform real-time strategy (RTS) game of ancient warfare. In
45short, it is a historically-based war/economy game that allows players
46to relive or rewrite the history of Western civilizations, focusing on
47the years between 500 B.C. and 500 A.D. The project is highly
48ambitious, involving state-of-the-art 3D graphics, detailed artwork,
49sound, and a flexible and powerful custom-built game engine.
50
51%prep
52%setup -q -n %{name}-%{version}-alpha
53
54# force link with libboost_*.so not libboost_*-mt.so
55%{__sed} -i 's,-mt,,g' build/premake/extern_libs4.lua
56
57# use wx-gtk2-unicode-config instead of wx-config
58%{__sed} -i 's,wx-config,wx-gtk2-unicode-config,' build/premake/extern_libs4.lua
59
60%build
61export CFLAGS="%{rpmcflags}"
62export CPPFLAGS="%{rpmcxxflags}"
63cd build/workspaces
64./update-workspaces.sh \
65 --with-system-enet \
66 --with-system-nvtt \
67 --with-system-mozjs185
68# --verbose \
69# --bindir %{_bindir} \
70# --datadir %{_datadir}/%{name} \
71# --libdir %{_libdir}/%{name}
72
73cd gcc
74%{__make} \
75 CONFIG=Release
76
77%install
78rm -rf $RPM_BUILD_ROOT
79install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
80
81# binaries
82cp -a build/resources/0ad.sh $RPM_BUILD_ROOT%{_bindir}/0ad
83cp -a binaries/system/pyrogenesis $RPM_BUILD_ROOT%{_bindir}
84
85# libraries
86cp -a binaries/system/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
87cp -a binaries/system/*release.so.*.* $RPM_BUILD_ROOT%{_libdir}/%{name}
88
89# menu icon
90cp -a build/resources/0ad.desktop $RPM_BUILD_ROOT%{_desktopdir}
91cp -a build/resources/0ad.png $RPM_BUILD_ROOT%{_pixmapsdir}
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%files
97%defattr(644,root,root,755)
98%doc README.txt
99%attr(755,root,root) %{_bindir}/0ad
100%attr(755,root,root) %{_bindir}/pyrogenesis
101%dir %{_libdir}/0ad
102%{_libdir}/0ad/*.so
103%{_libdir}/0ad/*.so.*.*
104%{_desktopdir}/0ad.desktop
105%{_pixmapsdir}/0ad.png
This page took 0.396264 seconds and 4 git commands to generate.