]> git.pld-linux.org Git - packages/0ad.git/blame - 0ad.spec
- up to r09048
[packages/0ad.git] / 0ad.spec
CommitLineData
7b21aad0 1#
2# TODO: - use arch dependend compilers
3# - check licenses
d49dee95 4# - try to make it runnable by non-privileged users (sth wrong with boost?)
5# - fix problem with font finding
7b21aad0 6#
7d822f0e 7%define svn_ver r09049
7b21aad0 8Summary: Free, Open-Source, cross-platform RTS game of ancient warfare
9Name: 0ad
10Version: %{svn_ver}
11Release: 0.%{svn_ver}.1
12License: GPL v2+
13Group: X11/Applications/Games
7245afcd 14Source0: http://releases.wildfiregames.com/%{name}-%{version}-alpha-unix-build.tar.xz
7d822f0e 15# Source0-md5: 3ebb1b322cd947c855da75828ebcd539
7b21aad0 16URL: http://wildfiregames.com/0ad/
bfedb3d9 17BuildRequires: DevIL-devel
18BuildRequires: OpenAL-devel
19BuildRequires: OpenGL-devel
20BuildRequires: SDL-devel
7b21aad0 21BuildRequires: boost-devel
bfedb3d9 22BuildRequires: cmake
7d822f0e 23BuildRequires: curl-devel
1cae58d8 24BuildRequires: enet-devel < 1.3.0
25BuildRequires: enet-devel >= 1.2.0
7d822f0e 26BuildRequires: fam-devel
bfedb3d9 27BuildRequires: libogg-devel
28BuildRequires: libpng-devel
29BuildRequires: libvorbis-devel
30BuildRequires: libxml2-devel
7d822f0e 31BuildRequires: nasm
7245afcd 32BuildRequires: perl-base
33BuildRequires: pkgconfig
34BuildRequires: python
35BuildRequires: python-modules
7b21aad0 36BuildRequires: sed >= 4.0
2ef47886 37BuildRequires: wxGTK2-unicode-gl-devel
7245afcd 38BuildRequires: zip
bfedb3d9 39BuildRequires: zlib-devel
7b21aad0 40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
430 A.D. (pronounced "zero ey-dee") is a free, open-source,
44cross-platform real-time strategy (RTS) game of ancient warfare. In
45short, it is a historically-based war/economy game that allows players
46to relive or rewrite the history of Western civilizations, focusing on
47the years between 500 B.C. and 500 A.D. The project is highly
48ambitious, involving state-of-the-art 3D graphics, detailed artwork,
49sound, and a flexible and powerful custom-built game engine.
50
51%prep
7245afcd 52%setup -q -n %{name}-%{version}-alpha
7b21aad0 53
54# force link with libboost_*.so not libboost_*-mt.so
55%{__sed} -i 's,-mt,,g' build/premake/extern_libs.lua
56
57# use wx-gtk2-unicode-config instead of wx-config
58%{__sed} -i 's,wx-config,wx-gtk2-unicode-config,' build/premake/extern_libs.lua
59
60%build
61export CFLAGS="%{rpmcflags}"
62export CPPFLAGS="%{rpmcxxflags}"
63cd build/workspaces
64./update-workspaces.sh \
65 --verbose \
66 --bindir %{_bindir} \
67 --datadir %{_datadir}/%{name} \
68 --libdir %{_libdir}/%{name}
69
70cd gcc
71%{__make} \
72 CONFIG=Release
73
74%install
75rm -rf $RPM_BUILD_ROOT
76install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
77
78# binaries
79cp -a build/resources/0ad.sh $RPM_BUILD_ROOT%{_bindir}/0ad
80cp -a binaries/system/pyrogenesis $RPM_BUILD_ROOT%{_bindir}
81
82# libraries
83cp -a binaries/system/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
84
85# menu icon
86cp -a build/resources/0ad.desktop $RPM_BUILD_ROOT%{_desktopdir}
87cp -a build/resources/0ad.png $RPM_BUILD_ROOT%{_pixmapsdir}
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files
93%defattr(644,root,root,755)
94%doc README.txt
95%attr(755,root,root) %{_bindir}/0ad
96%attr(755,root,root) %{_bindir}/pyrogenesis
97%dir %{_libdir}/0ad
98%{_libdir}/0ad/*.so
99%{_desktopdir}/0ad.desktop
100%{_pixmapsdir}/0ad.png
This page took 0.061795 seconds and 4 git commands to generate.