]> git.pld-linux.org Git - packages/thunderbird.git/blobdiff - thunderbird.spec
conditional BR for clang
[packages/thunderbird.git] / thunderbird.spec
index 5a9b814bc05a1d64f52c8e564c791485e11d3dc2..911c0b0ff382d61674d1a134b7976b7550b55553 100644 (file)
@@ -12,6 +12,7 @@
 # - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
 %bcond_with    shared_js       # shared libmozjs library [broken]
 %bcond_with    system_icu      # build with system ICU (disabled due to crashes with system icu 58.2)
+%bcond_without clang           # build using Clang/LLVM
 
 %if 0%{?_enable_debug_packages} != 1
 %undefine      crashreporter
 Summary:       Thunderbird - email client
 Summary(pl.UTF-8):     Thunderbird - klient poczty
 Name:          thunderbird
-Version:       52.2.1
+Version:       52.3.0
 Release:       1
 License:       MPL v2.0
 Group:         X11/Applications/Mail
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/%{name}-%{version}.source.tar.xz
-# Source0-md5: df6ddc52046acd66503756c094c30e21
+# Source0-md5: 5841ee1a70423b9385110c82b78bef47
 Source1:       %{name}.desktop
 Source2:       %{name}.sh
 Patch0:                prefs.patch
@@ -39,21 +40,19 @@ Patch1:             no-subshell.patch
 Patch2:                enable-addons.patch
 Patch3:                mozilla-1245783.patch
 URL:           http://www.mozilla.org/projects/thunderbird/
-BuildRequires: GConf2-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
-BuildRequires: automake
+BuildRequires: autoconf2_13 >= 2.13
 BuildRequires: bzip2-devel
 BuildRequires: cairo-devel >= 1.10
+%{?with_clang:BuildRequires:   clang}
 BuildRequires: dbus-glib-devel >= 0.60
 BuildRequires: fontconfig-devel >= 2.7.0
 BuildRequires: freetype-devel >= 1:2.1.8
-BuildRequires: glib2-devel >= 1:2.20
-BuildRequires: gstreamer0.10-devel
-BuildRequires: gstreamer0.10-plugins-base-devel
+BuildRequires: glib2-devel >= 1:2.22
 %{!?with_gtk3:BuildRequires:   gtk+2-devel >= 2:2.18.0}
 %{?with_gtk3:BuildRequires:    gtk+3-devel >= 3.4.0}
 BuildRequires: hunspell-devel
-BuildRequires: libIDL-devel >= 0.8.0
+BuildRequires: libatomic-devel
 BuildRequires: libevent-devel
 BuildRequires: libffi-devel > 3.0.9
 %{?with_system_icu:BuildRequires:      libicu-devel >= 58.1}
@@ -61,7 +60,7 @@ BuildRequires:        libiw-devel
 # requires libjpeg-turbo implementing at least libjpeg 6b API
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libjpeg-turbo-devel
-BuildRequires: libpng-devel >= 1.4.1
+BuildRequires: libpng-devel >= 2:1.6.25
 BuildRequires: libstdc++-devel
 BuildRequires: libvpx-devel >= 1.5.0
 BuildRequires: mozldap-devel
@@ -71,27 +70,36 @@ BuildRequires:      pango-devel >= 1:1.22.0
 BuildRequires: perl-base >= 1:5.6
 BuildRequires: pixman-devel >= 0.19.2
 BuildRequires: pkgconfig
-BuildRequires: python >= 1:2.5
+BuildRequires: python >= 1:2.7
 BuildRequires: python-virtualenv
 BuildRequires: sed >= 4.0
 BuildRequires: sqlite3-devel >= 3.17.0
 BuildRequires: startup-notification-devel >= 0.8
 BuildRequires: virtualenv
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXcomposite-devel
+BuildRequires: xorg-lib-libXdamage-devel
 BuildRequires: xorg-lib-libXext-devel
-BuildRequires: xorg-lib-libXinerama-devel
+BuildRequires: xorg-lib-libXfixes-devel
 BuildRequires: xorg-lib-libXt-devel
-BuildRequires: yasm
+%ifarch %{ix86} %{x8664}
+BuildRequires: yasm >= 1.0.1
+%endif
 BuildRequires: zip
-Requires:      glib2 >= 1:2.20
+BuildRequires: zlib-devel >= 1.2.3
+Requires(post):        mktemp >= 1.5-18
+Requires:      dbus-glib >= 0.60
+Requires:      glib2 >= 1:2.22
 %{!?with_gtk3:Requires:        gtk+2 >= 2:2.18.0}
 %{?with_gtk3:Requires: gtk+3 >= 3.4.0}
+Requires:      libpng >= 2:1.6.25
 Requires:      libvpx >= 1.5.0
 Requires:      myspell-common
 Requires:      nspr >= 1:%{nspr_ver}
 Requires:      nss >= 1:%{nss_ver}
 Requires:      pango >= 1:1.22.0
 Requires:      sqlite3 >= %{sqlite_build_version}
-Requires(post):        mktemp >= 1.5-18
+Requires:      startup-notification >= 0.8
 Requires:      libjpeg-turbo
 Obsoletes:     icedove
 Obsoletes:     mozilla-thunderbird
@@ -101,6 +109,10 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
 
+%if %{with clang}
+%define                filterout               -fvar-tracking-assignments
+%endif
+
 # firefox/thunderbird/seamonkey provide their own versions
 %define                _noautoprovfiles        %{_libdir}/%{name}/components
 
@@ -145,6 +157,16 @@ funkcjonalność kalendarza.
 cat << EOF > .mozconfig
 mk_add_options MOZ_OBJDIR=%{objdir}
 
+%if %{with clang}
+export CC="clang"
+export CXX="clang++"
+%else
+export CC="%{__cc}"
+export CXX="%{__cxx}"
+%endif
+export CFLAGS="%{rpmcflags} -D_FILE_OFFSET_BITS=64"
+export CXXFLAGS="%{rpmcxxflags} -D_FILE_OFFSET_BITS=64"
+
 %if %{with crashreporter}
 export MOZ_DEBUG_SYMBOLS=1
 %endif
@@ -185,16 +207,17 @@ ac_add_options --disable-gnomeui
 ac_add_options --disable-necko-wifi
 ac_add_options --disable-updater
 ac_add_options --enable-alsa
-ac_add_options --enable-chrome-format=omni
 ac_add_options --enable-application=mail
+ac_add_options --enable-chrome-format=omni
 ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
 ac_add_options --enable-gio
-ac_add_options --enable-readline
 %if %{with ldap}
 ac_add_options --enable-ldap
 %else
 ac_add_options --disable-ldap
 %endif
+%{?with_official:ac_add_options --enable-official-branding}
+ac_add_options --enable-readline
 %{?with_shared_js:ac_add_options --enable-shared-js}
 ac_add_options --enable-startup-notification
 ac_add_options --enable-system-cairo
@@ -202,7 +225,6 @@ ac_add_options --enable-system-ffi
 ac_add_options --enable-system-hunspell
 ac_add_options --enable-system-sqlite
 ac_add_options --enable-url-classifier
-%{?with_official:ac_add_options --enable-official-branding}
 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
 ac_add_options --with-distribution-id=org.pld-linux
 ac_add_options --with-pthreads
This page took 0.085289 seconds and 4 git commands to generate.