]> git.pld-linux.org Git - packages/python3-aiohttp.git/blobdiff - python3-aiohttp.spec
- updated to 3.8.3
[packages/python3-aiohttp.git] / python3-aiohttp.spec
index a7ee4b4d6a4ad95592ded4ebc8a5c632bb63e61e..c6be8cd637b270275f13f39918ab0769bd6ecfcf 100644 (file)
@@ -3,43 +3,53 @@
 %bcond_without doc     # API documentation
 %bcond_without tests   # unit tests
 
-%define        module  template
+%define                module  template
 Summary:       Async http client/server framework
 Summary(pl.UTF-8):     Szkielet asynchronicznego klienta/serwera http
 Name:          python3-aiohttp
-Version:       3.7.3
+Version:       3.8.3
 Release:       1
 License:       Apache v2.0
 Group:         Libraries/Python
-#Source0Download: https://pypi.org/simple/aiohttp/
 Source0:       https://files.pythonhosted.org/packages/source/a/aiohttp/aiohttp-%{version}.tar.gz
-# Source0-md5: a66039c12f33dd093a2c260f5c459632
-# adjusted from https://github.com/aio-libs/aiohttp/commit/9afc44b052643213da15c9583ecbd643ca999601.patch
-Patch0:                %{name}-brotli.patch
+# Source0-md5: 642653db642be1508e50fcdeafe0f928
+Patch0:                disable-towncrier.patch
 URL:           https://pypi.org/project/aiohttp/
 BuildRequires: python3-devel >= 1:3.6
 BuildRequires: python3-setuptools
 %if %{with tests}
-BuildRequires: python3-async_timeout >= 3.0
+#BuildRequires:        python3-aiodns >= 1.1
+BuildRequires: python3-aiosignal >= 1.1.2
+BuildRequires: python3-async_timeout >= 4.0
+BuildRequires: python3-async_timeout < 5
+%if "%{ver_lt '%{py3_ver}' '3.8'}" == "1"
+BuildRequires: python3-asynctest = 0.13.0
+%endif
 BuildRequires: python3-attrs >= 17.3.0
 BuildRequires: python3-brotli
-BuildRequires: python3-chardet >= 2.0
+BuildRequires: python3-charset_normalizer >= 2.0
+BuildRequires: python3-charset_normalizer < 3
+BuildRequires: python3-cchardet
+BuildRequires: python3-freezegun
+BuildRequires: python3-frozenlist >= 1.1.1
 BuildRequires: python3-gunicorn
-%if "%{py3_ver}" < "3.7"
-BuildRequires: python3-idna-ssl
+%if "%{py3_ver}" == "3.6"
+BuildRequires: python3-idna-ssl >= 1.0
 %endif
 BuildRequires: python3-multidict >= 4.5
+BuildRequires: python3-multidict < 7
 BuildRequires: python3-pytest >= 3.8.2
 BuildRequires: python3-pytest-cov
 BuildRequires: python3-pytest-mock
 BuildRequires: python3-re_assert
+%if "%{ver_lt '%{py3_ver}' '3.8'}" == "1"
 BuildRequires: python3-typing_extensions >= 3.6.5
+%endif
 BuildRequires: python3-yarl >= 1.0
+BuildRequires: python3-yarl < 2
 %endif
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.714
-# if using noarchpackage, replace with:
-#BuildRequires:        rpmbuild(macros) >= 1.752
+BuildRequires: rpmbuild(macros) >= 1.749
 BuildRequires: sed >= 4.0
 %if %{with doc}
 BuildRequires: python3-aiohttp_theme
@@ -47,7 +57,6 @@ BuildRequires:        python3-sphinxcontrib-asyncio
 BuildRequires: python3-sphinxcontrib-blockdiag
 BuildRequires: sphinx-pdg-3
 %endif
-# replace with other requires if defined in setup.py
 Requires:      python3-modules >= 1:3.6
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -61,7 +70,7 @@ Szkielet asynchronicznego klienta/serwera http.
 Summary:       aiohttp API documentation
 Summary(pl.UTF-8):     Dokumentacja API aiohttp
 Group:         Documentation
-%{?noarchpackage}
+BuildArch:     noarch
 
 %description apidocs
 API documentation for aiohttp.
@@ -73,28 +82,30 @@ Dokumentacja API aiohttp.
 %setup -q -n aiohttp-%{version}
 %patch0 -p1
 
-%{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' examples/*.py examples/legacy/*.py
+%{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' examples/*.py
 
 # adjust for python 3.7+
 %{__sed} -i -e '/^from async_generator/d; /^ *@async_generator/d; s/await yield_/yield/' tests/*.py
 
-# until we have pytest >= 6:
-%{__sed} -i -e '/assert_outcomes/ s/errors=/error=/' tests/test_pytest_plugin.py
-
 %build
 %py3_build
 
 %if %{with tests}
-# test_data_stream_exc_chain uses network, fails
-# test_async_iterable_payload_default_content_type, test_async_iterable_payload_explicit_content_type fail with TypeError (need update?)
+# test_data_stream_exc_chain uses network
+# test_mark_formdata_as_processed requires network
+# test_client_session_timeout_zero fails on builders
+# test_requote_redirect_url_default uses network
+# test_unsupported_upgrade is marked as xfail, but succeeds
+%{__mv} tests/test_proxy_functional.py{,.disabled} # needs proxy_py binary
 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
 PYTEST_PLUGINS="pytest_cov.plugin,pytest_mock" \
-%{__python3} -m pytest tests -k 'not (test_data_stream_exc_chain or test_async_iterable_payload_default_content_type or test_async_iterable_payload_explicit_content_type)'
+%{__python3} -m pytest tests -k 'not (test_data_stream_exc_chain or test_mark_formdata_as_processed or test_client_session_timeout_zero or test_requote_redirect_url_default or test_c_parser_loaded or test_unsupported_upgrade)'
 %endif
 
 %if %{with doc}
 %{__make} -C docs html \
-       SPHINXBUILD=sphinx-build-3
+       SPHINXBUILD=sphinx-build-3 \
+       SPHINXOPTS="-n"
 %endif
 
 %install
@@ -103,7 +114,7 @@ rm -rf $RPM_BUILD_ROOT
 %py3_install
 
 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitedir}/aiohttp/.hash
-%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/aiohttp/*.{c,h,pxd,pxi,pyx}
+%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/aiohttp/*.{pxd,pxi,pyx}
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
This page took 0.083142 seconds and 4 git commands to generate.