]> git.pld-linux.org Git - packages/python3-aiohttp.git/blobdiff - python3-aiohttp.spec
- updated to 3.8.3
[packages/python3-aiohttp.git] / python3-aiohttp.spec
index 6bda2cb7ab25f8e9d497a582fa6c5e1ae846f8ae..c6be8cd637b270275f13f39918ab0769bd6ecfcf 100644 (file)
@@ -7,37 +7,49 @@
 Summary:       Async http client/server framework
 Summary(pl.UTF-8):     Szkielet asynchronicznego klienta/serwera http
 Name:          python3-aiohttp
-Version:       3.8.1
+Version:       3.8.3
 Release:       1
 License:       Apache v2.0
 Group:         Libraries/Python
 Source0:       https://files.pythonhosted.org/packages/source/a/aiohttp/aiohttp-%{version}.tar.gz
-# Source0-md5: faf7726dc65a940272874c0f441e8ec6
+# Source0-md5: 642653db642be1508e50fcdeafe0f928
 Patch0:                disable-towncrier.patch
 URL:           https://pypi.org/project/aiohttp/
 BuildRequires: python3-devel >= 1:3.6
 BuildRequires: python3-setuptools
 %if %{with tests}
-BuildRequires: python3-aiosignal
+#BuildRequires:        python3-aiodns >= 1.1
+BuildRequires: python3-aiosignal >= 1.1.2
 BuildRequires: python3-async_timeout >= 4.0
+BuildRequires: python3-async_timeout < 5
+%if "%{ver_lt '%{py3_ver}' '3.8'}" == "1"
+BuildRequires: python3-asynctest = 0.13.0
+%endif
 BuildRequires: python3-attrs >= 17.3.0
 BuildRequires: python3-brotli
-BuildRequires: python3-chardet >= 2.0
+BuildRequires: python3-charset_normalizer >= 2.0
+BuildRequires: python3-charset_normalizer < 3
+BuildRequires: python3-cchardet
 BuildRequires: python3-freezegun
+BuildRequires: python3-frozenlist >= 1.1.1
 BuildRequires: python3-gunicorn
-%if "%{py3_ver}" < "3.7"
-BuildRequires: python3-idna-ssl
+%if "%{py3_ver}" == "3.6"
+BuildRequires: python3-idna-ssl >= 1.0
 %endif
 BuildRequires: python3-multidict >= 4.5
+BuildRequires: python3-multidict < 7
 BuildRequires: python3-pytest >= 3.8.2
 BuildRequires: python3-pytest-cov
 BuildRequires: python3-pytest-mock
 BuildRequires: python3-re_assert
+%if "%{ver_lt '%{py3_ver}' '3.8'}" == "1"
 BuildRequires: python3-typing_extensions >= 3.6.5
+%endif
 BuildRequires: python3-yarl >= 1.0
+BuildRequires: python3-yarl < 2
 %endif
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.714
+BuildRequires: rpmbuild(macros) >= 1.749
 BuildRequires: sed >= 4.0
 %if %{with doc}
 BuildRequires: python3-aiohttp_theme
@@ -75,27 +87,25 @@ Dokumentacja API aiohttp.
 # adjust for python 3.7+
 %{__sed} -i -e '/^from async_generator/d; /^ *@async_generator/d; s/await yield_/yield/' tests/*.py
 
-# until we have pytest >= 6:
-%{__sed} -i -e '/assert_outcomes/ s/errors=/error=/' tests/test_pytest_plugin.py
-
 %build
 %py3_build
 
 %if %{with tests}
-# test_data_stream_exc_chain uses network, fails
-# test_async_iterable_payload_default_content_type, test_async_iterable_payload_explicit_content_type fail with TypeError (need update?)
+# test_data_stream_exc_chain uses network
 # test_mark_formdata_as_processed requires network
 # test_client_session_timeout_zero fails on builders
-# test_requote_redirect_url_default uses network, fails
+# test_requote_redirect_url_default uses network
+# test_unsupported_upgrade is marked as xfail, but succeeds
 %{__mv} tests/test_proxy_functional.py{,.disabled} # needs proxy_py binary
 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
 PYTEST_PLUGINS="pytest_cov.plugin,pytest_mock" \
-%{__python3} -m pytest tests -k 'not (test_data_stream_exc_chain or test_async_iterable_payload_default_content_type or test_async_iterable_payload_explicit_content_type or test_mark_formdata_as_processed or test_c_parser_loaded or test_aiohttp_plugin_async_fixture or test_client_session_timeout_zero or test_requote_redirect_url_default)'
+%{__python3} -m pytest tests -k 'not (test_data_stream_exc_chain or test_mark_formdata_as_processed or test_client_session_timeout_zero or test_requote_redirect_url_default or test_c_parser_loaded or test_unsupported_upgrade)'
 %endif
 
 %if %{with doc}
 %{__make} -C docs html \
-       SPHINXBUILD=sphinx-build-3
+       SPHINXBUILD=sphinx-build-3 \
+       SPHINXOPTS="-n"
 %endif
 
 %install
@@ -104,7 +114,7 @@ rm -rf $RPM_BUILD_ROOT
 %py3_install
 
 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitedir}/aiohttp/.hash
-%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/aiohttp/*.{c,h,pxd,pxi,pyx}
+%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/aiohttp/*.{pxd,pxi,pyx}
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
This page took 0.098937 seconds and 4 git commands to generate.