]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- resolve ambiguity of exit()/die() aliases, we want exit code not exit message
[packages/php.git] / php.spec
index 5592fe713a21159ae9c58de5f6d94539bac97d6b..8027b386480cfe904b0fea5e8c0207eda99c759f 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -39,7 +39,7 @@
 %bcond_without ldap            # without LDAP extension module
 %bcond_without mhash           # without mhash extension module
 %bcond_without mime_magic      # without mime-magic module
-%bcond_without ming            # without ming extension module
+%bcond_with    ming            # with ming extension module
 %bcond_without mm              # without mm support for session storage
 %bcond_without mssql           # without MS SQL extension module
 %bcond_without mysqli          # without mysqli support (Requires mysql > 4.1)
@@ -112,7 +112,7 @@ Summary(ru.UTF-8):  PHP Версии 5 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          php
 Version:       5.2.13
-Release:       4
+Release:       10
 Epoch:         4
 License:       PHP
 Group:         Libraries
@@ -184,6 +184,8 @@ Patch49:    %{name}-m4-divert.patch
 Patch50:       extension-shared-optional-dep.patch
 Patch51:       spl-shared.patch
 Patch52:       %{name}-libpng.patch
+Patch53:       %{name}-gmp.patch
+Patch54:       %{name}-bug-51192.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -1835,6 +1837,8 @@ done
 %patch50 -p1
 %patch51 -p1
 %patch52 -p1
+%patch53 -p1
+%patch54 -p1
 
 # conflict seems to be resolved by recode patches
 rm -f ext/recode/config9.m4
@@ -2105,6 +2109,9 @@ cp -af php_config.h.cli main/php_config.h
 %{__make} sapi/cli/php -f Makefile.cli
 [ "$(echo '<?=php_sapi_name();' | ./sapi/cli/php -n)" = cli ] || exit 1
 
+# check for stupid xml parse breakage where &lt; and &gt; just get lost in parse result
+./sapi/cli/php -n -dextension_dir=modules -dextension=xml.so -r '$p = xml_parser_create(); xml_parse_into_struct($p, "<x>&lt;</x>", $vals, $index); exit((int )empty($vals[0]["value"]));'
+
 # Generate stub .ini files for each extension
 rm -rf conf.d
 install -d conf.d
This page took 0.026418 seconds and 4 git commands to generate.