]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
up to 6.9.4
[packages/nodejs.git] / nodejs.spec
index ada3b23290995b5134fa0f0161fa27c7a5f88aa0..ac0ceb805e33ccea854255327a3f9c1b74f21592 100644 (file)
@@ -1,38 +1,62 @@
+# TODO
+# - unpackaged files
+#   /usr/share/doc/node/gdbinit
+#   /usr/share/systemtap/tapset/node.stp
+
+# Conditional build:
+%bcond_without system_uv       # system uv
+%bcond_with    shared  # build libnode.so shared library
+
+# NOTES:
+# - https://nodejs.org/en/download/releases/
+
+# NODE_MODULE_VERSION refers to the ABI (application binary interface) version
+# number of Node.js, used to determine which versions of Node.js compiled C++
+# add-on binaries can be loaded in to without needing to be re-compiled. It
+# used to be stored as hex value in earlier versions, but is now represented as
+# an integer.
+%define                node_module_version     48
 Summary:       Asynchronous JavaScript Engine
 Name:          nodejs
-Version:       0.10.15
+# 6.9 is LTS, Active LTS: 2018-04-18, EOL: 2019-04-18
+# https://github.com/nodejs/LTS
+Version:       6.9.4
 Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
-Source0:       http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 59f295b0a30dc8dbdb46407c2d9b2923
+Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
+# Source0-md5: 3795199b5950b25179248847b1a5fc86
 Patch1:                %{name}-shared.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
+Patch4:                %{name}-use-system-certs.patch
 Patch5:                uv-fpic.patch
-URL:           http://www.nodejs.org/
-BuildRequires: c-ares-devel
+URL:           https://nodejs.org/
 BuildRequires: gcc >= 5:4.0
-BuildRequires: http-parser-devel >= 2.0
+BuildRequires: http-parser-devel >= 2.7.0
 BuildRequires: libstdc++-devel
-BuildRequires: libuv-devel >= 0.10
-BuildRequires: openssl-devel
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.6.0}
+BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: pkgconfig
-BuildRequires: python >= 1:2.5.2
+BuildRequires: python >= 1:2.7
 BuildRequires: python-jsmin
+BuildRequires: python-modules
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sed >= 4.0
-BuildRequires: v8-devel >= 3.15.11.10
 BuildRequires: zlib-devel
-BuildConflicts:        eio
+Requires:      ca-certificates
+Provides:      nodejs(engine) = %{version}
+Provides:      nodejs(module-version) = %{node_module_version}
 Obsoletes:     nodejs-waf
 ExclusiveArch: %{ix86} %{x8664} arm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                sover   %(echo %{version} | cut -d. -f2)
+# add macro, so adapter won't replace it back literal
+%define                doc_ver %{version}
 
 %description
 Node.js is a platform built on Chrome's JavaScript runtime for easily
@@ -45,13 +69,11 @@ across distributed devices.
 Summary:       Development headers for nodejs
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      c-ares-devel
 Requires:      gcc
-Requires:      http-parser-devel
+Requires:      http-parser-devel >= 2.5.0
 Requires:      libstdc++-devel
-Requires:      libuv-devel
+%{?with_system_uv:Requires:    libuv-devel >= 1.6.0}
 Requires:      openssl-devel
-Requires:      v8-devel
 Requires:      zlib-devel
 
 %description devel
@@ -60,6 +82,10 @@ Development headers for nodejs.
 %package doc
 Summary:       Evented I/O for V8 JavaScript - documentation
 Group:         Documentation
+URL:           https://nodejs.org/dist/v%{doc_ver}/docs/api
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description doc
 Node.js is a server-side JavaScript environment that uses an
@@ -70,27 +96,38 @@ This package contains the documentation for nodejs.
 
 %prep
 %setup -q -n node-v%{version}
-%patch1 -p1
+%{?with_shared:%patch1 -p1}
+#%patch1 -p1
 %if %{_lib} == "lib64"
 %patch3 -p1
 %else
 %patch2 -p1
 %endif
-%patch5 -p1
+%patch4 -p1
+rm src/node_root_certs.h
+#%{?with_system_uv:%patch5 -p1}
 
 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
 
+rm -r deps/npm
+rm -r deps/http_parser
+rm -r deps/openssl
+%{?with_system_uv:rm -r deps/uv}
+rm -r deps/zlib
+
 %build
+ver=$(awk '/#define NODE_MODULE_VERSION/{print $3}' src/node_version.h)
+test "$ver" = "%{node_module_version}"
+
 # CC used only to detect if CC is clang, not used for compiling
 CC="%{__cc}" \
 CXX="%{__cxx}" \
 GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
-       --shared-v8 \
        --shared-zlib \
        --shared-openssl \
-       --shared-cares \
-       --shared-libuv \
+       %{?0:--shared-cares} \
+       %{?with_system_uv:--shared-libuv} \
        --shared-http-parser \
        --without-npm \
        --without-dtrace \
@@ -104,16 +141,13 @@ LDFLAGS="%{rpmldflags}" \
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} justinstall \
-       DESTDIR=$RPM_BUILD_ROOT \
-       LIBDIR=%{_lib}
-
-# no dtrace on linux
-%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/lib/dtrace/node.d
+%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
 
+%if %{with shared}
 lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*.*)
 ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
 ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so
+%endif
 
 echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
 
@@ -151,22 +185,26 @@ EOF
 # install documentation
 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
 cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
-rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.markdown
+rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.md
 rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with shared}
 %post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
+%endif
 
 %files
 %defattr(644,root,root,755)
-%doc README.md AUTHORS ChangeLog LICENSE
+%doc README.md AUTHORS CHANGELOG.md ROADMAP.md LICENSE
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
+%if %{with shared}
 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
 %ghost %{_libdir}/libnode.so.10
+%endif
 %if "%{_lib}" != "lib"
 %dir %{_libdir}/node
 %endif
@@ -177,7 +215,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
+%if %{with shared}
 %{_libdir}/libnode.so
+%endif
 %{_includedir}/node
 %{_pkgconfigdir}/nodejs.pc
 %{_usrsrc}/%{name}
This page took 0.030808 seconds and 4 git commands to generate.