]> git.pld-linux.org Git - packages/compat-ncurses5.git/blobdiff - ncurses.spec
- ugly workaround to fix broken directory deps:
[packages/compat-ncurses5.git] / ncurses.spec
index f3f49549e62cb7e61902ad805ea94379f02e7dde..f024919d896e8f9b2ce459e1446f81cf153f00eb 100644 (file)
@@ -16,14 +16,26 @@ Summary(tr.UTF-8):  Terminal kontrol kitaplığı
 Summary(uk.UTF-8):     ncurses - нова бібліотека керування терміналами
 Name:          ncurses
 Version:       5.6
-Release:       2
+Release:       5
 License:       distributable
 Group:         Libraries
 Source0:       ftp://dickey.his.com/ncurses/%{name}-%{version}.tar.gz
 # Source0-md5: b6593abe1089d6aab1551c105c9300e3
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 3b05ee835dc20c306e9af2a9d3fbf1f1
-Patch0:                ftp://dickey.his.com/ncurses/5.6/%{name}-5.6-20061223.patch.gz
+
+# source: ftp://dickey.his.com/ncurses/5.6/
+Patch0:                %{name}-5.6-20061223.patch.gz
+Patch1:                %{name}-5.6-20061230.patch.gz
+Patch2:                %{name}-5.6-20070106.patch.gz
+Patch3:                %{name}-5.6-20070113.patch.gz
+Patch4:                %{name}-5.6-20070120.patch.gz
+Patch5:                %{name}-5.6-20070127.patch.gz
+Patch6:                %{name}-5.6-20070128.patch.gz
+Patch7:                %{name}-5.6-20070203.patch.gz
+Patch8:                %{name}-5.6-20070210.patch.gz
+Patch9:                %{name}-5.6-20070217.patch.gz
+
 Patch100:      %{name}-screen_hpa_fix.patch
 Patch101:      %{name}-xterm_hpa_fix.patch
 Patch102:      %{name}-meta.patch
@@ -287,6 +299,7 @@ Summary:    Header files for develop Ada95 ncurses based application
 Summary(pl.UTF-8):     Pliki nagłówkowe do biblioteki Ada95 ncurses
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
+%requires_eq   gcc-ada
 
 %description ada-devel
 This package includes the header files and libraries necessary to
@@ -299,6 +312,15 @@ tworzenia aplikacji używających ncurses w języku Ada95.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
 %patch100 -p1
 %patch101 -p1
 %patch102 -p1
@@ -311,6 +333,8 @@ tworzenia aplikacji używających ncurses w języku Ada95.
 
 %build
 unset TERMINFO || :
+gcc_target=$(gcc -dumpmachine)
+gcc_version=$(gcc -dumpversion)
 CFLAGS="%{rpmcflags} -DPURE_TERMINFO -D_FILE_OFFSET_BITS=64"
 cp -f /usr/share/automake/config.sub .
 for t in narrowc widec; do
@@ -334,9 +358,10 @@ cd obj-$t
        --with-manpage-aliases \
        --with-manpage-format=normal \
        --without-manpage-symlinks \
-       --with-ada-include=%{_libdir}/ada/adainclude/ \
-       --with-ada-objects=%{_libdir}/ada/adalib/ \
-       `[ "$t" = "widec" ] && echo --enable-widec --includedir=%{_includedir}w`
+       --with-ada-include=%{_libdir}/gcc/$gcc_target/$gcc_version/adainclude/ \
+       --with-ada-objects=%{_libdir}/gcc/$gcc_target/$gcc_version/adalib/ \
+       `[ "$t" != "widec" ] && echo --with-termlib=tinfo` \
+       `[ "$t" = "widec" ] && echo --with-termlib=tinfow --enable-widec --includedir=%{_includedir}w`
 %{__make} \
        CC="%{__cc}"
 cd ..
@@ -364,11 +389,11 @@ bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
-%post   ext -p /sbin/ldconfig
-%postun ext -p /sbin/ldconfig
+%post  ext -p /sbin/ldconfig
+%postun        ext -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
@@ -440,18 +465,24 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_includedir}
 %{_includedir}/curses.h
 %{_includedir}/eti.h
+%{_includedir}/nc_tparm.h
 %{_includedir}/ncurses.h
 %{_includedir}/ncurses_dll.h
 %{_includedir}/term.h
+%{_includedir}/term_entry.h
 %{_includedir}/termcap.h
+%{_includedir}/tic.h
 %{_includedir}/unctrl.h
 %dir %{_includedir}w
 %{_includedir}w/curses.h
 %{_includedir}w/eti.h
+%{_includedir}w/nc_tparm.h
 %{_includedir}w/ncurses.h
 %{_includedir}w/ncurses_dll.h
 %{_includedir}w/term.h
+%{_includedir}w/term_entry.h
 %{_includedir}w/termcap.h
+%{_includedir}w/tic.h
 %{_includedir}w/unctrl.h
 %{_mandir}/man3/*
 %exclude %{_mandir}/man3/form*
@@ -531,6 +562,6 @@ rm -rf $RPM_BUILD_ROOT
 %files ada-devel
 %defattr(644,root,root,755)
 %doc Ada95/{README,TODO}
-%{_libdir}/ada/adainclude/*
-%{_libdir}/ada/adalib/*
+%{_libdir}/gcc/*/*/adainclude/*
+%{_libdir}/gcc/*/*/adalib/*
 %endif
This page took 0.05446 seconds and 4 git commands to generate.