]> git.pld-linux.org Git - packages/thunderbird.git/blobdiff - icedove.spec
- rel 3
[packages/thunderbird.git] / icedove.spec
index 1c561ecd8262834ceb01bc47ae46136477b1fb98..f2b7e48aff77b4f514712abb4422ada9467c2d9b 100644 (file)
 %undefine      crashreporter
 %endif
 
-%define                enigmail_ver    1.4
+%define                enigmail_ver    1.4.2
 %define                nspr_ver        4.9
 %define                nss_ver         3.13.3
 
-# convert thunderbird release number to platform version: 11.0.x -> 11.0.x
-%define                xulrunner_main  11.0
-%define                xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#11.0})
+%define                xulrunner_ver   2:13.0
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       11.0
-Release:       2
+Version:       13.0
+Release:       3
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 1d7127a3282e62d95eb9b59d47291b70
+# Source0-md5: 0134c67c30e8598f2a64ea004d5bc4bc
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
-# Source1-md5: 5cf3d9720ed1cda1b22eabe5457772c2
+# Source1-md5: ed608e1cd4cd20b96f7f5afdbf081141
 Source2:       %{name}-branding.tar.bz2
 # Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
 Source3:       %{name}-rm_nonfree.sh
@@ -57,7 +55,7 @@ Patch5:               %{name}-hunspell.patch
 Patch6:                %{name}-prefs.patch
 Patch7:                system-mozldap.patch
 Patch8:                %{name}-makefile.patch
-
+Patch9:                system-cairo.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
 Patch12:       no-subshell.patch
@@ -83,7 +81,7 @@ BuildRequires:        libpng-devel >= 1.4.1
 BuildRequires: libstdc++-devel
 BuildRequires: nspr-devel >= 1:%{nspr_ver}
 BuildRequires: nss-devel >= 1:%{nss_ver}
-BuildRequires: pango-devel >= 1:1.1.0
+BuildRequires: pango-devel >= 1:1.14.0
 BuildRequires: perl-base >= 1:5.6
 BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5
@@ -96,7 +94,7 @@ BuildRequires:        xorg-lib-libXt-devel
 BuildRequires: yasm
 BuildRequires: zip
 %if %{with xulrunner}
-BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
+BuildRequires: xulrunner-devel >= %{xulrunner_ver}
 %else
 Requires:      myspell-common
 Requires:      nspr >= 1:%{nspr_ver}
@@ -109,16 +107,19 @@ Requires(post):   mktemp >= 1.5-18
 %endif
 Obsoletes:     mozilla-thunderbird
 Obsoletes:     mozilla-thunderbird-dictionary-en-US
+Conflicts:     icedove-lang-resources < %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
 
 # iceweasel/icedove/iceape provide their own versions
 %define                _noautoprovfiles        %{_libdir}/%{name}/components
-# we don't want these to satisfy xulrunner-devel
-%define                _noautoprov             libmozjs.so libxpcom.so libxul.so
+%if %{without xulrunner}
+# we don't want these to satisfy packages depending on xulrunner
+%define                _noautoprov             libmozalloc.so libxpcom.so libxul.so
 # and as we don't provide them, don't require either
-%define                _noautoreq              libmozjs.so libxpcom.so libxul.so
+%define                _noautoreq              libmozalloc.so libxpcom.so libxul.so
+%endif
 
 %define                topdir          %{_builddir}/%{name}-%{version}
 %define                objdir          %{topdir}/obj-%{_target_cpu}
@@ -196,6 +197,7 @@ cd mozilla
 %patch6 -p1
 %patch7 -p1
 %patch8 -p2
+%patch9 -p1
 %patch10 -p2
 %patch11 -p2
 %patch12 -p1
@@ -389,6 +391,10 @@ ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
 %endif
 
+%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
+        -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
+       %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
+
 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
@@ -435,6 +441,8 @@ cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ex
 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
 # mozldap
 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
+# testpilot quiz
+%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.040493 seconds and 4 git commands to generate.