]> git.pld-linux.org Git - packages/icedove.git/blobdiff - icedove.spec
- up to 10.0.1
[packages/icedove.git] / icedove.spec
index 7f1f3e74fd76ec67bb52a30a47ed3744e9a6a591..cd4adff3039941043faaedb44ede2de917a554b1 100644 (file)
@@ -1,30 +1,32 @@
 # TODO:
 # - separate spec for enigmail
-# - fix icedove (building) and installing nss/nspr libs!
 # - build with system mozldap
+# - enigmail - new version needed
 #
 # Conditional builds
 %bcond_without enigmail        # don't build enigmail - GPG/PGP support
 %bcond_without gnomeui         # disable gnomeui support
-%bcond_without gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
-%bcond_without gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
+%bcond_without gnome           # alias for gnomeui
 %bcond_without ldap            # disable e-mail address lookups in LDAP directories
-%bcond_without  lightning      # disable sunbird calendar
+%bcond_without lightning       # disable Sunbird/Lightning calendar
 %bcond_without xulrunner       # build with xulrunner
 %bcond_with    crashreporter   # report crashes to crash-stats.mozilla.com
 
 %if %{without gnome}
 %undefine      with_gnomeui
-%undefine      with_gnomevfs
 %endif
 
 %if 0%{?_enable_debug_packages} != 1
 %undefine      crashreporter
 %endif
 
-%define                enigmail_ver    1.1.2
-%define                nspr_ver                4.8.8
-%define                nss_ver                 3.12.10
+%define                enigmail_ver    1.3.5
+%define                nspr_ver        4.8.8
+%define                nss_ver         3.12.10
+
+# convert firefox release number to platform version: 9.0.x -> 9.0.x
+%define                xulrunner_main  10.0
+%define                xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#10.0})
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       6.0
-Release:       0.1
+Version:       10.0.1
+Release:       1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 9ac741d238e95790cdeb5222e9b23ae8
+# Source0-md5: 623c32d9deae370383e1422b1ea48061
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
-# Source1-md5: 7d329d5e8afbbb28214ca1995beb09c9
+# Source1-md5: 1b008b0d106e238c11e4bead08126bc0
 Source2:       %{name}-branding.tar.bz2
 # Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
 Source3:       %{name}-rm_nonfree.sh
@@ -56,47 +58,56 @@ Patch5:             %{name}-hunspell.patch
 Patch6:                %{name}-prefs.patch
 Patch7:                system-mozldap.patch
 Patch8:                %{name}-makefile.patch
+#Patch9:               %{name}-libpng.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
 Patch12:       no-subshell.patch
 URL:           http://www.pld-linux.org/Packages/Icedove
-%{?with_gnomevfs:BuildRequires:        GConf2-devel >= 1.2.1}
+BuildRequires: GConf2-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 BuildRequires: automake
 BuildRequires: bzip2-devel
+BuildRequires: cairo-devel >= 1.10
+BuildRequires: dbus-glib-devel >= 0.60
 BuildRequires: freetype-devel >= 1:2.1.8
-%{?with_gnomevfs:BuildRequires:        gnome-vfs2-devel >= 2.0}
-BuildRequires: gtk+2-devel >= 1:2.0.0
+BuildRequires: glib2-devel >= 2.0
+BuildRequires: gtk+2-devel >= 2:2.10.0
 BuildRequires: hunspell-devel
 BuildRequires: libIDL-devel >= 0.8.0
-%{?with_gnomevfs:BuildRequires:        libgnome-devel >= 2.0}
+%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
 %{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
 %{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
 BuildRequires: libiw-devel
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libnotify-devel >= 0.4
-BuildRequires: libpng-devel >= 1.2.0
+BuildRequires: libpng-devel >= 1.4.1
 BuildRequires: libstdc++-devel
 BuildRequires: nspr-devel >= 1:%{nspr_ver}
 BuildRequires: nss-devel >= 1:%{nss_ver}
 BuildRequires: pango-devel >= 1:1.1.0
+BuildRequires: perl-base >= 1:5.6
 BuildRequires: pkgconfig
+BuildRequires: python >= 1:2.5
 BuildRequires: sed >= 4.0
 BuildRequires: sqlite3-devel >= 3.7.4
 BuildRequires: startup-notification-devel >= 0.8
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXt-devel
+BuildRequires: yasm
 BuildRequires: zip
-Requires(post):        mktemp >= 1.5-18
 %if %{with xulrunner}
-BuildRequires: xulrunner-devel
+BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
 %else
 Requires:      myspell-common
 Requires:      nspr >= 1:%{nspr_ver}
 Requires:      nss >= 1:%{nss_ver}
 Requires:      sqlite3 >= %{sqlite_build_version}
 %endif
+Requires(post):        mktemp >= 1.5-18
+%if %{with xulrunner}
+%requires_eq_to        xulrunner xulrunner-devel
+%endif
 Obsoletes:     mozilla-thunderbird
 Obsoletes:     mozilla-thunderbird-dictionary-en-US
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -115,10 +126,11 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                objdir          %{topdir}/obj-%{_target_cpu}
 
 %description
-Icedove is an open-source,fast and portable email client.
+Icedove is an open-source, fast and portable email client.
 
 %description -l pl.UTF-8
-Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
+Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
+poczty.
 
 %package addon-lightning
 Summary:       An integrated calendar for Icedove
@@ -183,10 +195,10 @@ cd mozilla
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p2
+#%patch9 -p1
 %patch10 -p2
 %patch11 -p2
 %patch12 -p1
@@ -203,8 +215,8 @@ ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
 cat << EOF > .mozconfig
 mk_add_options MOZ_OBJDIR=%{objdir}
 
-export CFLAGS="%{rpmcflags} -fpermissive"
-export CXXFLAGS="%{rpmcflags} -fpermissive"
+export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
+export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
 
 %if %{with crashreporter}
 export MOZ_DEBUG_SYMBOLS=1
@@ -243,16 +255,13 @@ ac_add_options --enable-tests
 %else
 ac_add_options --disable-tests
 %endif
+ac_add_options --enable-gio
 %if %{with gnomeui}
 ac_add_options --enable-gnomeui
 %else
 ac_add_options --disable-gnomeui
 %endif
-%if %{with gnomevfs}
-ac_add_options --enable-gnomevfs
-%else
 ac_add_options --disable-gnomevfs
-%endif
 %if %{with ldap}
 ac_add_options --enable-ldap
 ac_add_options --with-system-ldap
@@ -340,7 +349,7 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_
 cd %{objdir}
 %{__make} -C mail/installer stage-package \
        DESTDIR=$RPM_BUILD_ROOT \
-       MOZ_PKG_APPDIR=%{_libdir}/%{name} \
+       MOZ_PKG_DIR=%{_libdir}/%{name} \
        PKG_SKIP_STRIP=1
 
 # Enable crash reporter for Firefox application
@@ -360,13 +369,11 @@ cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
 # move arch independant ones to datadir
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
-ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
@@ -379,6 +386,9 @@ install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
 
+%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
+ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
+
 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
@@ -406,8 +416,8 @@ chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
 install -d $ext_dir/{chrome,components,defaults/preferences}
 cd mozilla/dist/bin
-cp -rfLp chrome/enigmail.jar $ext_dir/chrome
-cp -rfLp chrome/enigmime.jar $ext_dir/chrome
+#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
+#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
 cp -rfLp components/enig* $ext_dir/components
 cp -rfLp components/libenigmime.so $ext_dir/components
 cp -rfLp components/libipc.so $ext_dir/components
@@ -419,9 +429,9 @@ cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ex
 %endif
 
 # remove unecessary stuff
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
+#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
+#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
+#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
 
 # never package these. always remove
 # nss
@@ -438,7 +448,7 @@ rm -rf $RPM_BUILD_ROOT
 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
        mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
 fi
-for d in chrome defaults greprefs icons isp modules res; do
+for d in chrome defaults icons isp modules res; do
        if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
                install -d %{_datadir}/%{name}
                mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
@@ -457,24 +467,30 @@ exit 0
 %dir %{_libdir}/%{name}
 %{_libdir}/%{name}/application.ini
 %{_libdir}/%{name}/platform.ini
+%{_libdir}/%{name}/blocklist.xml
+%{_libdir}/%{name}/chrome.manifest
+%{_libdir}/%{name}/greprefs.js
 %dir %{_libdir}/%{name}/components
 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
 %{_libdir}/%{name}/components/*.js
 %{_libdir}/%{name}/components/*.xpt
-%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
+%{_libdir}/%{name}/components/components.manifest
+%{_libdir}/%{name}/components/interfaces.manifest
+%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
-%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
+%attr(755,root,root) %{_libdir}/%{name}/libxul.so
 %attr(755,root,root) %{_libdir}/%{name}/*.sh
 %attr(755,root,root) %{_libdir}/%{name}/*-bin
 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
 %attr(755,root,root) %{_libdir}/%{name}/icedove
+%attr(755,root,root) %{_libdir}/%{name}/plugin-container
 %attr(755,root,root) %{_libdir}/%{name}/register
 
 # symlinks
 %{_libdir}/%{name}/chrome
 %{_libdir}/%{name}/defaults
 %{_libdir}/%{name}/dictionaries
-%{_libdir}/%{name}/greprefs
+%{_libdir}/%{name}/hyphenation
 %{_libdir}/%{name}/isp
 %{_libdir}/%{name}/modules
 %{_libdir}/%{name}/res
@@ -485,7 +501,7 @@ exit 0
 %dir %{_datadir}/%{name}
 %{_datadir}/%{name}/chrome
 %{_datadir}/%{name}/defaults
-%{_datadir}/%{name}/greprefs
+#%%{_datadir}/%{name}/greprefs
 %{_datadir}/%{name}/isp
 %{_datadir}/%{name}/modules
 %{_datadir}/%{name}/res
@@ -508,18 +524,19 @@ exit 0
 %files addon-lightning
 %defattr(644,root,root,755)
 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
+%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
+%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
+%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
+%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
-
 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
 %endif
 
This page took 0.091838 seconds and 4 git commands to generate.