]> git.pld-linux.org Git - packages/gettext.git/blobdiff - gettext.spec
- fix for new autoconf
[packages/gettext.git] / gettext.spec
index 286999d084ba26617f566f65b3439fab433448ae..e7382a920aa782ad34091577301856d4a3ffbd3c 100644 (file)
@@ -1,13 +1,18 @@
 #
-# TODO: C# (pnet or mono must be chosen)
-#
 # Conditional build:
 %bcond_without asprintf        # without libasprintf C++ library
 %bcond_without xemacs          # without po-mode for xemacs
-%bcond_with    gcj             # with Java support by gcj requires gcj 3.x, but not 3.0.4+ (broken for now))
+%bcond_without gcj             # with Java support by gcj (preferred over javac)
 %bcond_with    javac           # with Java support by some javac
+%bcond_without dotnet          # without .NET support
 #
 
+%include       /usr/lib/rpm/macros.mono
+
+%ifnarch %{ix86} %{x8664} arm hppa ppc s390 s390x
+%undefine with_dotnet
+%endif
+
 %undefine with_xemacs
 
 %define build_java     %{?with_gcj:1}%{!?with_gcj:%{?with_javac:1}%{!?with_javac:0}}
@@ -22,23 +27,25 @@ Summary(ru):        
 Summary(tr):   Desteði için kitaplýk ve araçlar
 Summary(uk):   â¦Â̦ÏÔÅËÉ ÔÁ ÕÔÉ̦ÔÉ ÄÌѠЦÄÔÒÉÍËÉ ÎÁæÏÎÁÌØÎÉÈ ÍÏ×
 Name:          gettext
-Version:       0.14.3
+Version:       0.15
 Release:       1
 License:       LGPL (runtime), GPL (tools)
 Group:         Development/Tools
 Source0:       ftp://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.gz
-# Source0-md5: 14c2644c2f3b0eb67d5db7ee389547de
+# Source0-md5: 16bc6e4d37ac3d07495f737a2349a22b
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-killkillkill.patch
-Patch2:                %{name}-no_docs.patch
+Patch2:                %{name}-pl.po-update.patch
+Patch3:                %{name}-no_docs.patch
 URL:           http://www.gnu.org/software/gettext/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake >= 1:1.7.5
 %{?with_gcj:BuildRequires:     gcj >= 3.0}
-%{?with_gcj:BuildRequires:     gcj < 3.0.4}
 %{?with_javac:BuildRequires:   jdk >= 1.1}
 %{?with_asprintf:BuildRequires:        libstdc++-devel}
 BuildRequires: libtool >= 1:1.4.2-9
+%{?with_dotnet:BuildRequires:  mono-csharp}
+BuildRequires: sed >= 4.0
 BuildRequires: texinfo
 %{?with_xemacs:BuildRequires:  xemacs}
 Obsoletes:     gettext-base
@@ -270,42 +277,56 @@ postaci AM_GNU_GETTEXT_VERSION(VERSION) w pliku configure.in lub
 configure.ac i kopiuje do pakietu pliki infrastruktury nale¿±ce do tej
 wersji.
 
+%package -n dotnet-gettext
+Summary:       GNU gettext for C#
+Summary(pl):   GNU gettext dla C#
+Group:         Development/Tools
+
+%description -n dotnet-gettext
+GNU gettext for C#.
+
+%description -n dotnet-gettext -l pl
+GNU gettext dla C#.
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
-# patch2 not finished yet
-#%patch2 -p1
+%patch2 -p1
+# patch not finished yet
+#%patch3 -p1
+sed -i '/docdir/a\AC_SUBST(docdir)' gettext-tools/configure.ac
 
 %{__perl} -pi -e 's/ no / nb /' gettext-runtime/po/LINGUAS gettext-tools/po/LINGUAS
 mv -f gettext-runtime/po/{no,nb}.po
 mv -f gettext-runtime/po/{no,nb}.gmo
 mv -f gettext-tools/po/{no,nb}.po
 mv -f gettext-tools/po/{no,nb}.gmo
+rm -f gettext-tools/po/stamp-po
 
 %build
 # it's m4_included somewhere
-install %{_aclocaldir}/libtool.m4 config/m4/libtool.m4
+install %{_aclocaldir}/libtool.m4 m4/libtool.m4
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__automake}
 cd autoconf-lib-link
-%{__aclocal} -I m4 -I ../config/m4
+%{__aclocal} -I m4 -I ../m4
 %{__autoconf}
 %{__automake}
 cd ../gettext-runtime
-%{__aclocal} -I m4 -I ../autoconf-lib-link/m4 -I ../gettext-tools/m4 -I ../config/m4
+%{__aclocal} -I m4 -I ../autoconf-lib-link/m4 -I ../gettext-tools/m4 -I ../m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 cd libasprintf
-%{__aclocal} -I ../m4 -I ../../config/m4
+%{__aclocal} -I ../m4 -I ../../m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 cd ../../gettext-tools
-%{__aclocal} -I m4 -I ../gettext-runtime/m4 -I ../autoconf-lib-link/m4 -I ../config/m4
+%{__aclocal} -I m4 -I ../gettext-runtime/m4 -I ../autoconf-lib-link/m4 -I ../m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
@@ -313,7 +334,8 @@ cd ..
 %configure \
        %{?with_xemacs:--with-lispdir=%{_datadir}/xemacs-packages/lisp/po-mode} \
        --enable-nls \
-       --disable-csharp \
+       %{!?with_dotnet:--disable-csharp} \
+       %{?with_dotnet:--enable-csharp=mono} \
        --without-included-gettext
 %{__make}
 
@@ -341,6 +363,8 @@ mv -f $RPM_BUILD_ROOT%{_bindir}/{,n}gettext $RPM_BUILD_ROOT/bin
 install gettext-tools/lib/.libs/libgettextlib.a \
        gettext-tools/src/.libs/libgettextsrc.a $RPM_BUILD_ROOT%{_libdir}
 
+rm -r $RPM_BUILD_ROOT%{_docdir}/gettext
+
 %find_lang %{name}-runtime
 %find_lang %{name}-tools
 
@@ -371,6 +395,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/envsubst.1*
 %{_mandir}/man1/gettext.1*
 %{_mandir}/man1/ngettext.1*
+%dir %{_libdir}/gettext
 %dir %{_datadir}/gettext
 
 %files devel -f %{name}-tools.lang
@@ -384,7 +409,6 @@ rm -rf $RPM_BUILD_ROOT
 # libgettextpo is for other programs, not used by gettext tools themselves
 %attr(755,root,root) %{_libdir}/libgettextpo.so.*.*.*
 %attr(755,root,root) %{_libdir}/preloadable_libintl.so
-%dir %{_libdir}/gettext
 %attr(755,root,root) %{_libdir}/gettext/hostname
 %attr(755,root,root) %{_libdir}/gettext/project-id
 %attr(755,root,root) %{_libdir}/gettext/urlget
@@ -404,7 +428,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/gettext/intl/[!c]*
 %attr(755,root,root) %{_datadir}/gettext/intl/config.charset
 %{_datadir}/gettext/msgunfmt.tcl
-%attr(755,root,root) %{_datadir}/gettext/mkinstalldirs
 %{_datadir}/gettext/po
 %dir %{_datadir}/gettext/projects
 %{_datadir}/gettext/projects/index
@@ -454,7 +477,6 @@ rm -rf $RPM_BUILD_ROOT
 %doc gettext-runtime/intl-java/javadoc2
 %attr(755,root,root) %{_libdir}/gettext/gnu.gettext.DumpResource
 %attr(755,root,root) %{_libdir}/gettext/gnu.gettext.GetURL
-%{_datadir}/gettext/gettext.jar
 %endif
 
 %if %{with xemacs}
@@ -469,3 +491,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/autopoint
 %{_datadir}/gettext/archive.tar.gz
 %{_mandir}/man1/autopoint.1*
+
+%if %{with dotnet}
+%files -n dotnet-gettext
+%defattr(644,root,root,755)
+%{_libdir}/GNU.Gettext.dll
+%{_libdir}/gettext/msgfmt.net.exe
+%{_libdir}/gettext/msgunfmt.net.exe
+%endif
This page took 0.05094 seconds and 4 git commands to generate.