]> git.pld-linux.org Git - packages/gettext.git/blobdiff - gettext.spec
- obsolete
[packages/gettext.git] / gettext.spec
index 56ad62ecb9d294f59466ca5c5395c4355d41cb93..1cb91f587343fc44e7bd676aa03fa1aa95f499ba 100644 (file)
@@ -2,12 +2,12 @@
 # Conditional build:
 %bcond_without asprintf        # without libasprintf C++ library
 %bcond_without xemacs          # without po-mode for xemacs
-%bcond_with    gcj             # with Java support by gcj requires gcj 3.x, but not 3.0.4+ (broken for now))
+%bcond_without gcj             # with Java support by gcj (preferred over javac)
 %bcond_with    javac           # with Java support by some javac
 %bcond_without dotnet          # without .NET support
 #
 
-%include       /usr/lib/rpm/macros.mono
+%{?with_dotnet:%include        /usr/lib/rpm/macros.mono}
 
 %ifnarch %{ix86} %{x8664} arm hppa ppc s390 s390x
 %undefine with_dotnet
@@ -27,20 +27,24 @@ Summary(ru):        
 Summary(tr):   Desteði için kitaplýk ve araçlar
 Summary(uk):   â¦Â̦ÏÔÅËÉ ÔÁ ÕÔÉ̦ÔÉ ÄÌѠЦÄÔÒÉÍËÉ ÎÁæÏÎÁÌØÎÉÈ ÍÏ×
 Name:          gettext
-Version:       0.14.5
+Version:       0.16
 Release:       2
 License:       LGPL (runtime), GPL (tools)
 Group:         Development/Tools
 Source0:       ftp://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.gz
-# Source0-md5: e2f6581626a22a0de66dce1d81d00de3
+# Source0-md5: 1560a460c2c4e05b6ff53acb12860750
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-killkillkill.patch
-Patch2:                %{name}-no_docs.patch
+Patch2:                %{name}-pl.po-update.patch
+Patch3:                %{name}-no_docs.patch
+Patch4:                %{name}-ac.patch
+Patch5:                %{name}-gettext.m4-fix.patch
 URL:           http://www.gnu.org/software/gettext/
-BuildRequires: autoconf >= 2.57
-BuildRequires: automake >= 1:1.7.5
+BuildRequires: autoconf >= 2.59
+# after dropping -ac.patch:
+#BuildRequires:        autoconf >= 2.60
+BuildRequires: automake >= 1:1.10
 %{?with_gcj:BuildRequires:     gcj >= 3.0}
-%{?with_gcj:BuildRequires:     gcj < 3.0.4}
 %{?with_javac:BuildRequires:   jdk >= 1.1}
 %{?with_asprintf:BuildRequires:        libstdc++-devel}
 BuildRequires: libtool >= 1:1.4.2-9
@@ -132,7 +136,7 @@ Group:              Development/Tools
 Requires(post,postun): /sbin/ldconfig
 Requires:      %{name} = %{version}-%{release}
 Requires:      iconv
-Conflicts:     autoconf < 2.50
+Conflicts:     autoconf < 2.52
 
 %description devel
 The gettext library provides an easy to use library and tools for
@@ -291,28 +295,27 @@ GNU gettext dla C#.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-# patch2 not finished yet
-#%patch2 -p1
+%patch2 -p1
+# patch not finished yet
+#%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %{__perl} -pi -e 's/ no / nb /' gettext-runtime/po/LINGUAS gettext-tools/po/LINGUAS
 mv -f gettext-runtime/po/{no,nb}.po
 mv -f gettext-runtime/po/{no,nb}.gmo
 mv -f gettext-tools/po/{no,nb}.po
 mv -f gettext-tools/po/{no,nb}.gmo
+rm -f gettext-tools/po/stamp-po
 
 %build
-# it's m4_included somewhere
-install %{_aclocaldir}/libtool.m4 m4/libtool.m4
 %{__libtoolize}
-%{__aclocal}
-%{__autoconf}
-%{__automake}
 cd autoconf-lib-link
 %{__aclocal} -I m4 -I ../m4
 %{__autoconf}
 %{__automake}
 cd ../gettext-runtime
-%{__aclocal} -I m4 -I ../autoconf-lib-link/m4 -I ../gettext-tools/m4 -I ../m4
+%{__aclocal} -I m4 -I gnulib-m4 -I ../autoconf-lib-link/m4 -I ../m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
@@ -322,11 +325,14 @@ cd libasprintf
 %{__autoheader}
 %{__automake}
 cd ../../gettext-tools
-%{__aclocal} -I m4 -I ../gettext-runtime/m4 -I ../autoconf-lib-link/m4 -I ../m4
+%{__aclocal} -I m4 -I gnulib-m4 -I libgettextpo/gnulib-m4 -I ../autoconf-lib-link/m4 -I ../gettext-runtime/m4 -I ../m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 cd ..
+%{__aclocal}
+%{__autoconf}
+%{__automake}
 %configure \
        %{?with_xemacs:--with-lispdir=%{_datadir}/xemacs-packages/lisp/po-mode} \
        --enable-nls \
@@ -356,9 +362,11 @@ install -d $RPM_BUILD_ROOT/bin
 mv -f $RPM_BUILD_ROOT%{_bindir}/{,n}gettext $RPM_BUILD_ROOT/bin
 
 # these static libs are removed in install-exec-clean
-install gettext-tools/lib/.libs/libgettextlib.a \
+install gettext-tools/gnulib-lib/.libs/libgettextlib.a \
        gettext-tools/src/.libs/libgettextsrc.a $RPM_BUILD_ROOT%{_libdir}
 
+rm -r $RPM_BUILD_ROOT%{_docdir}/gettext
+
 %find_lang %{name}-runtime
 %find_lang %{name}-tools
 
@@ -422,7 +430,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/gettext/intl/[!c]*
 %attr(755,root,root) %{_datadir}/gettext/intl/config.charset
 %{_datadir}/gettext/msgunfmt.tcl
-%attr(755,root,root) %{_datadir}/gettext/mkinstalldirs
 %{_datadir}/gettext/po
 %dir %{_datadir}/gettext/projects
 %{_datadir}/gettext/projects/index
This page took 0.093596 seconds and 4 git commands to generate.