]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- rel 3; from archlinux - patch that fixes finding ar binary in call like '/usr/bin...
[packages/gcc.git] / gcc.spec
index 5d88a9e77244e94716cd120418449154c804fbb7..f8096db8af7037a3a551214dd4b7d57ca03aeda5 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
 # For PLD we usually use gcc when minor_ver >= 2.0 (first bugfix release or later)
 %define                major_ver       7
 %define                minor_ver       2.0
-%define                ecj_ver         4.9
-# class data version seen with file(1) that this jvm is able to load
-%define                _classdataversion 50.0
-%define                gcj_soname_ver  17
 
 Summary:       GNU Compiler Collection: the C compiler and shared files
 Summary(es.UTF-8):     Colección de compiladores GNU: el compilador C y ficheros compartidos
@@ -109,7 +105,7 @@ Summary(pl.UTF-8):  Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       1
+Release:       3
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
@@ -121,11 +117,12 @@ Source3:  libffi.pc.in
 Source4:       branch.sh
 # use branch.sh to update glibc-branch.diff
 Patch100:      %{name}-branch.diff
-# Patch100-md5:        d7963ef23d8b759940dc91797b3f53d5
+# Patch100-md5:        56d9c81f367fa224d59a6025ee5cf808
 Patch0:                %{name}-info.patch
 Patch2:                %{name}-nodebug.patch
 Patch3:                %{name}-ada-link.patch
 Patch4:                %{name}-ada-x32.patch
+Patch5:                Revert-eeb6872bf.patch
 
 Patch10:       %{name}-moresparcs.patch
 Patch11:       %{name}-install-libffi.patch
@@ -232,7 +229,6 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %endif
 %endif
 %define                gcclibdir       %{_libdir}/gcc/%{_target_platform}/%{version}
-%define                gcjdbexecdir    gcj-%{version}-%{gcj_soname_ver}
 
 %define                filterout       -fwrapv -fno-strict-aliasing -fsigned-char
 %define                filterout_ld    -Wl,--as-needed
@@ -241,7 +237,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # receiving non constant format strings
 %define                Werror_cflags   %{nil}
 
-%define                skip_post_check_so      '.*(libcc1plugin|libcp1plugin|libgo|libxmlj|lib-gnu-awt-xlib|libmpxwrappers)\.so.*'
+%define                skip_post_check_so      '.*(libasan|libcc1plugin|libcp1plugin|libgo|libxmlj|libubsan|lib-gnu-awt-xlib|libmpxwrappers)\.so.*'
 # private symbols
 %define                _noautoreq              .*\(GLIBC_PRIVATE\)
 
@@ -1082,21 +1078,6 @@ libstdc++ types/containers.
 Ten pakiet zawiera skrypty Pythona dla GDB służące do ładnego
 wypisywania typów i kontenerów libstdc++.
 
-%package -n libstdc++-apidocs
-Summary:       C++ standard library API documentation
-Summary(pl.UTF-8):     Dokumentacja API biblioteki standardowej C++
-License:       FDL v1.3 (mainly), GPL v3+ (doxygen generated parts)
-Group:         Documentation
-%if "%{_rpmversion}" >= "5"
-BuildArch:     noarch
-%endif
-
-%description -n libstdc++-apidocs
-API and internal documentation for C++ standard library.
-
-%description -n libstdc++-apidocs -l pl.UTF-8
-Dokumentacja API i wewnętrzna biblioteki standardowej C++.
-
 %package fortran
 Summary:       Fortran 95 language support for GCC
 Summary(es.UTF-8):     Soporte de Fortran 95 para GCC
@@ -2821,6 +2802,7 @@ Extensions dla języka C.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %patch10 -p1
 %if %{with gcc_libffi}
@@ -2937,7 +2919,6 @@ all := $(filter-out all Makefile,$(MAKECMDGOALS))
 all $(all):
        $(MAKE) -C builddir $(MAKE_OPTS) $(all) \
                %{?with_bootstrap:%{?with_profiling:profiledbootstrap}} \
-               GCJFLAGS="%{rpmcflags}" \
                BOOT_CFLAGS="%{rpmcflags}" \
                STAGE1_CFLAGS="%{rpmcflags} -O1 -g0" \
                GNATLIBCFLAGS="%{rpmcflags}" \
@@ -3114,9 +3095,6 @@ do
        file="$RPM_BUILD_ROOT%{_libdir}/$f"
        %{__perl} %{SOURCE1} "$file" %{_libdir} >"${file}.fixed"
        %{__mv} "${file}.fixed" "$file"
-
-       # normalize /lib/../lib/ path (libjawt.la)
-       sed -i -e 's#/%{_lib}/\.\./%{_lib}/#/%{_lib}/#g' "$file"
 done
 %if %{with multilib}
 for f in libitm.la libssp.la libssp_nonshared.la \
@@ -3966,11 +3944,6 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %endif
 
-%if %{with apidocs}
-%files -n libstdc++-apidocs
-%defattr(644,root,root,755)
-%doc libstdc++-v3/doc/html/*
-%endif
 %endif
 
 %if %{with fortran}
This page took 0.04395 seconds and 4 git commands to generate.