]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
more updates in %%files
[packages/gcc.git] / gcc.spec
index 94d9b1dfd57fb9eb3cf7af44baa698a88dea332c..edd8d163faa26b09ad4f3e3970f332d297ac2a01 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -1,50 +1,19 @@
-%define                STDC_VERSION 2.10.0
+%define                STDC_VERSION 3.0.0
+%define                ver 3.0
 Summary:       GNU Compiler Collection
 Summary(pl):   Kolekcja kompilatorów GNU
 Name:          gcc
-Version:       2.95.3
-Release:       14
+Version:       %{ver}
+Release:       20010305
 License:       GPL
 Group:         Development/Languages
 Group(de):     Entwicklung/Sprachen
 Group(pl):     Programowanie/Jêzyki
-Source0:       ftp://ftp.gnu.org/pub/gnu/gcc/%{name}-2.95.2.tar.gz
-Source1:       gcov.1
-Patch0:                %{name}-info.patch
-Patch1:                %{name}-pld-linux.patch
-Patch2:                %{name}-libstdc++.patch
-Patch3:                %{name}-bootstrap.patch
-Patch4:                %{name}-cpp-macro-doc.patch
-Patch5:                %{name}-default-arch.patch
-Patch6:                %{name}-cvs-updates-20000220.patch.gz
-Patch7:                %{name}-libstdc++-out-of-mem.patch
-Patch8:                %{name}-libstdc++-wstring.patch
-Patch9:                %{name}-libstdc++-wall3.patch
-Patch10:       %{name}-libstdc++-bastring.patch
-Patch11:       %{name}-manpage.patch
-Patch12:       %{name}-cpp-dos-newlines.patch
-Patch13:       %{name}-g++-is-tree.patch
-Patch14:       %{name}-gpc.patch
-Patch15:       %{name}-arm-config.patch
-Patch16:       %{name}-m68k-pic.patch
-Patch17:       %{name}-sparc32-rfi.patch
-Patch18:       %{name}-builtin-apply.patch
-Patch19:       %{name}-gcj-backport.patch
-Patch20:       %{name}-ppc-ice.patch
-Patch21:       %{name}-ppc-descriptions.patch
-Patch22:       %{name}-ppc-andrew-dwarf-eh.patch
-
-Patch23:       %{name}-alpha-complex-float.patch
-Patch24:       %{name}-emit-rtl.patch
-Patch25:       %{name}-empty-struct-init.patch
-Patch26:       %{name}-gcj-vs-iconv.patch
-Patch27:       %{name}-libobjc.patch
-Patch28:       %{name}-pointer-arith.patch
-
-Patch29:       %{name}-glibc-2.2.patch
-Patch30:       %{name}-O2-bug.patch
-
+Source0:       ftp://gcc.gnu.org/pub/gcc/snapshots/%{release}/%{name}-%{release}.tar.gz
 BuildRequires: bison
+BuildRequires: texinfo
+BuildRequires: zlib-devel
+BuildRequires: fileutils >= 4.0.41
 Requires:      binutils >= 2.9.1.0.25
 Requires:      cpp = %{version}
 URL:           http://gcc.gnu.org/
@@ -313,81 +282,52 @@ Preprocesor C umo
   odpowiada fragment pliku wynikowego.
 
 %prep
-%setup -q -n %{name}-2.95.2
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p0
-%patch5 -p0
-%patch6 -p1
-%patch7 -p0
-%patch8 -p0
-%patch9 -p0
-%patch10 -p0
-%patch11 -p0
-%patch12 -p0
-%patch13 -p1
-%patch14 -p1
-%ifarch arm
-%patch15 -p0
-%endif
-%ifarch m68k
-%patch16 -p0
-%endif
-%ifarch sparc sparc32
-%patch17 -p0
-%patch18 -p0
-%patch19 -p1
-%endif
-%ifarch ppc
-%patch20 -p0
-%patch21 -p0
-%patch22 -p0
-%endif
-%ifarch alpha
-%patch23 -p1
-%endif
-%patch24 -p0
-%patch25 -p0
-%patch26 -p0
-%patch27 -p0
-%patch28 -p0
-%patch29 -p1
-%patch30 -p1
+%setup -q -n %{name}-%{release}
 
 %build
-(cd gcc; autoconf)
-rm -rf obj-%{_target_platform}
-install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
+rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
 
-CFLAGS="%{!?debug:$RPM_OPT_FLAGS}%{?debug:-O -g}"
-CXXFLAGS="%{!?debug:$RPM_OPT_FLAGS}%{?debug:-O -g}" 
+CFLAGS="%{?debug:-O0 -g}%{!?debug:$RPM_OPT_FLAGS}" \
+CXXFLAGS="%{?debug:-O0 -g}%{!?debug:$RPM_OPT_FLAGS}" \
 TEXCONFIG=false ../configure \
        --prefix=%{_prefix} \
        --infodir=%{_infodir} \
+       --mandir=%{_mandir} \
        --enable-shared \
+%ifarch sparc
+       --with-cpu=sparc \
+%endif
+%ifarch sparc64
+       --with-cpu=ultrasparc \
+%endif
 %ifnarch sparc sparc64
-       --enable-threads \
+       --enable-threads=posix \
        --enable-haifa \
 %endif
        --with-gnu-as \
        --with-gnu-ld \
-       --with-gxx-include-dir="\$\{prefix\}/include/g++" \
+       --with-gxx-include-dir="%{_includedir}/g++" \
+       --disable-objc-gc \
+       --enable-java-gc \
+       --enable-chill-gc \
+       --enable-long-long \
+       --enable-cshadow-headers \
+       --enable-namespaces \
+       --without-x \
+       --disable-nls \
        %{_target_platform}
 
 PATH=$PATH:/sbin:%{_sbindir}
-touch  ../gcc/c-gperf.h
 
 cd ..
-%{__make} -C obj-%{_target_platform} bootstrap \
+%{__make} -C obj-%{_target_platform} bootstrap-lean \
        LDFLAGS_FOR_TARGET="%{!?debug:-s}" \
        mandir=%{_mandir} \
        infodir=%{_infodir}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_datadir}
+install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
 
 cd obj-%{_target_platform}
 PATH=$PATH:/sbin:%{_sbindir}
@@ -397,24 +337,16 @@ PATH=$PATH:/sbin:%{_sbindir}
        mandir=$RPM_BUILD_ROOT%{_mandir} \
        infodir=$RPM_BUILD_ROOT%{_infodir}
 
-%{__make} install \
-       prefix=$RPM_BUILD_ROOT%{_prefix} \
-       mandir=$RPM_BUILD_ROOT%{_mandir} \
-       infodir=$RPM_BUILD_ROOT%{_infodir} -C texinfo
-
 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
 
 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
 echo .so cccp.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cpp.1
-install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1/
 
 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
 
 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libstdc++.so)
 
-install -d $RPM_BUILD_ROOT/lib
-(cd $RPM_BUILD_ROOT; \
-ln -sf ../`dirname usr/lib/gcc-lib/%{_target_cpu}*/*/cpp`/cpp $RPM_BUILD_ROOT/lib/cpp)
+ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
 
 gzip -9nf ../READ* ../ChangeLog ../gcc/ch/chill.brochure
 
@@ -459,6 +391,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
 %attr(755,root,root) %{_bindir}/gcc
+%attr(755,root,root) %{_bindir}/gccbug
 %attr(755,root,root) %{_bindir}/gcov
 %attr(755,root,root) %{_bindir}/protoize
 %attr(755,root,root) %{_bindir}/unprotoize
@@ -468,17 +401,16 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/gcov.1*
 %{_infodir}/gcc*
 
-%{_libdir}/gcc-lib/%{_target_cpu}*/*/SYSCALLS.c.X
-%attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
-%{_libdir}/gcc-lib/%{_target_cpu}*/*/lib*.map
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
 
 %ifnarch alpha
 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
 %endif
 
+%attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
+%attr(755,root,root) %{_libdir}/gcc-lib/libgcc_s.so.*
 
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
@@ -488,7 +420,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
-%{_libdir}/gcc-lib/%{_target_cpu}*/*/include/va-*.h
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
 
 %files c++
@@ -501,17 +432,15 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/c++filt
 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
 
-%{_libdir}/gcc-lib/%{_target_cpu}*/*/include/exception
-%{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new
-%{_libdir}/gcc-lib/%{_target_cpu}*/*/include/typeinfo
-%{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new.h
-
 %files objc
 %defattr(644,root,root,755)
 
 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
 
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
+%attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.so*
+%attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.la
+
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
 
 %files g77
@@ -569,9 +498,10 @@ rm -rf $RPM_BUILD_ROOT
 %files -n cpp
 %defattr(644,root,root,755)
 %attr(755,root,root) /lib/cpp
+%attr(755,root,root) %{_bindir}/cpp
+%attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
+%attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
 
 %{_mandir}/man1/cpp.1*
 %{_mandir}/man1/cccp.1*
 %{_infodir}/cpp.info*.gz
-
-%attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp
This page took 0.040506 seconds and 4 git commands to generate.