]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- updated to glic 2.1.94
[packages/gcc.git] / gcc.spec
index e85c066d534c2f2bc4275e068a1237829ae2f469..e5ae1b0adde13182a4099c35eae9ecf7a234e8a8 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -1,23 +1,50 @@
 %define                STDC_VERSION 2.10.0
-%define                GCJ_VERSION 2.95
-Summary:       GNU C Compiler
-Summary(pl):   Kompilator GNU
+Summary:       GNU Compiler Collection
+Summary(pl):   Kolekcja kompilatorów GNU
 Name:          gcc
-Version:       2.95.1
-Release:       1
-Copyright:     GPL
+Version:       2.95.2
+Release:       9
+License:       GPL
 Group:         Development/Languages
 Group(pl):     Programowanie/Jêzyki
-Source0:       ftp://ftp.gnu.org/pub/gnu/gcc/%{name}-%{version}.tar.bz2
-Source1:       ftp://sourceware.cygnus.com/pub/java/libgcj-%{GCJ_VERSION}.tar.gz
-Patch0:                gcc-info.patch
-Patch1:                gcc-libgcj-config.patch
-Patch2:                gcc-pld-linux.patch
-Patch3:                gcc-libstdc++.patch
+Source0:       ftp://ftp.gnu.org/pub/gnu/gcc/%{name}-%{version}.tar.gz
+Source1:       gcov.1
+Patch0:                %{name}-info.patch
+Patch1:                %{name}-pld-linux.patch
+Patch2:                %{name}-libstdc++.patch
+Patch3:                %{name}-bootstrap.patch
+Patch4:                %{name}-cpp-macro-doc.patch
+Patch5:                %{name}-default-arch.patch
+Patch6:                %{name}-cvs-updates-20000220.patch.gz
+Patch7:                %{name}-libstdc++-out-of-mem.patch
+Patch8:                %{name}-libstdc++-wstring.patch
+Patch9:                %{name}-libstdc++-wall3.patch
+Patch10:       %{name}-libstdc++-bastring.patch
+Patch11:       %{name}-manpage.patch
+Patch12:       %{name}-cpp-dos-newlines.patch
+Patch13:       %{name}-g++-is-tree.patch
+Patch14:       %{name}-gpc.patch
+Patch15:       %{name}-arm-config.patch
+Patch16:       %{name}-m68k-pic.patch
+Patch17:       %{name}-sparc32-rfi.patch
+Patch18:       %{name}-builtin-apply.patch
+Patch19:       %{name}-gcj-backport.patch
+Patch20:       %{name}-ppc-ice.patch
+Patch21:       %{name}-ppc-descriptions.patch
+Patch22:       %{name}-ppc-andrew-dwarf-eh.patch
+
+Patch23:       %{name}-alpha-complex-float.patch
+Patch24:       %{name}-emit-rtl.patch
+Patch25:       %{name}-empty-struct-init.patch
+Patch26:       %{name}-gcj-vs-iconv.patch
+Patch27:       %{name}-libobjc.patch
+Patch28:       %{name}-pointer-arith.patch
+
+Patch100:      %{name}-glibc-2.2.patch
 Requires:      binutils >= 2.9.1.0.25
-Requires:      cpp 
-URL:           http://www.gnu.org/
-BuildRoot:     /tmp/%{name}-%{version}-root
+Requires:      cpp = %{version}
+URL:           http://gcc.gnu.org/
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 A compiler aimed at integrating all the optimizations and features
@@ -29,40 +56,41 @@ wyprodukowania szybkiego i stablinego kodu wynikowego.
 
 %package c++
 Summary:       C++ support for gcc
-Summary(fr):   Support C++ pour le compilateur gcc.
+Summary(fr):   Support C++ pour le compilateur gcc
 Summary(pl):   Wspomaganie C++ dla kompilatora gcc
 Summary(tr):   gcc için C++ desteði
 Group:         Development/Languages
 Group(pl):     Programowanie/Jêzyki
 Obsoletes:     egcc-c++
+Obsoletes:     egcs-c++
 
 %description c++
-This package adds C++ support to the GNU C compiler. It includes support
-for most of the current C++ specification, including templates and
-exception handling. It does not include a standard C++ library, which
-is available separately.
+This package adds C++ support to the GNU C compiler. It includes
+support for most of the current C++ specification, including templates
+and exception handling. It does not include a standard C++ library,
+which is available separately.
 
 %description -l de c++
 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
-Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten - sie ist
-getrennt erhältlich.
+Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
+sie ist getrennt erhältlich.
 
 %description -l fr c++
 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
-support pour la plupart des spécifications actuelles de C++, dont les 
-modéles et la gestion des exceptions. Il ne comprend pas une bibliothéque
-C++ standard, qui est disponible séparément.
+support pour la plupart des spécifications actuelles de C++, dont les
+modéles et la gestion des exceptions. Il ne comprend pas une
+bibliothéque C++ standard, qui est disponible séparément.
 
 %description -l pl c++
-Programy z tego pakietu zapewniaj± wsparcie do C++ do GNU C kompilatora.
-Posiada wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
+Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
+wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
 
 %description -l tr c++
-Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve aykýrý durum
-iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart C++ kitaplýðý bu
-pakette yer almaz.
+Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
+aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
+C++ kitaplýðý bu pakette yer almaz.
 
 %package objc
 Summary:       Objective C support for gcc
@@ -73,49 +101,50 @@ Summary(tr):       gcc i
 Group:         Development/Languages
 Group(pl):     Programowanie/Jêzyki
 Obsoletes:     egcc-objc
+Obsoletes:     egcs-objc
 
 %description objc
-This package adds Objective C support to the GNU C compiler. Objective C is
-a object oriented derivative of the C language, mainly used on systems
-running NeXTSTEP. This package does not include the standard objective C
-object library.
+This package adds Objective C support to the GNU C compiler. Objective
+C is a object oriented derivative of the C language, mainly used on
+systems running NeXTSTEP. This package does not include the standard
+objective C object library.
 
 %description -l de objc
-Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support. Objective
-C ist ein objektorientiertes Derivat von C, das zur Hauptsache auf Systemen
-mit NeXTSTEP zum Einsatz kommt. Die Standard-Objective-C-Objekt-Library ist
-nicht Teil des Pakets.
+Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
+Objective C ist ein objektorientiertes Derivat von C, das zur
+Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
+Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
 
 %description -l fr objc
-Ce package ajoute un support Objective C au compilateur C GNU. L'Objective C
-est un langage orienté objetdérivé du langage C, principalement utilisé sur
-les systèmes NeXTSTEP. Ce package n'inclue pas la bibliothéque Objective C
-standard.
+Ce package ajoute un support Objective C au compilateur C GNU.
+L'Objective C est un langage orienté objetdérivé du langage C,
+principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
+pas la bibliothéque Objective C standard.
 
 %description -l pl objc
-Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc.  W pakiecie nie
-ma jeszcze bibliotek C-obj.
+Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
+pakiecie nie ma jeszcze bibliotek C-obj.
 
 %description -l tr objc
-Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C, C
-dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan sistemlerde
-yaygýn olarak kullanýlýr. Standart Objective C nesne kitaplýðý bu pakette
-yer almaz.
+Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
+C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
+sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
+kitaplýðý bu pakette yer almaz.
 
 %package g77
 Summary:       Fortran 77 support for gcc
 Summary(pl):   Wspomaganie Fortran 77 dla gcc
 Group:         Development/Languages
 Group(pl):     Programowanie/Jêzyki
-Prereq:                /sbin/install-info
+Obsoletes:     egcs-g77
 
 %description g77
-This apckage adds support for compiling Fortran 77 programs with the GNU
-compiler.
+This apckage adds support for compiling Fortran 77 programs with the
+GNU compiler.
 
 %description -l pl g77
-Ten pakiet jest wspomaganiem Fortran 77 dla kompilatora gcc.
-Jest u¿yteczny kompilowania programów pisanych w jêzyku Fortran 77.
+Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
+potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
 
 %package chill
 Summary:       CHILL support for gcc
@@ -123,18 +152,17 @@ Summary(pl):      Wspomoganie CHILL dla gcc
 Group:         Development/Languages
 Group(pl):     Programowanie/Jêzyki
 Requires:      %{name} = %{version}
-Prereq:                /sbin/install-info
 
 %description chill
 This package adds support for compiling CHILL programs with the GNU
 compiler.
 
-Chill is the "CCITT High-Level Language", where CCITT is the old
-name for what is now ITU, the International Telecommunications Union.
-It is is language in the Modula2 family, and targets many of the
-same applications as Ada (especially large embedded systems).
-Chill was never used much in the United States, but is still
-being used in Europe, Brazil, Korea, and other places.
+Chill is the "CCITT High-Level Language", where CCITT is the old name
+for what is now ITU, the International Telecommunications Union. It is
+is language in the Modula2 family, and targets many of the same
+applications as Ada (especially large embedded systems). Chill was
+never used much in the United States, but is still being used in
+Europe, Brazil, Korea, and other places.
 
 %package java
 Summary:       Java support for gcc
@@ -142,60 +170,41 @@ Summary(pl):      Wspomoganie Java dla gcc
 Group:         Development/Languages
 Group(pl):     Programowanie/Jêzyki
 Requires:      %{name} = %{version}
-Requires:      %{name}-libgcj = %{version}
+Requires:      libgcj >= 2.95.1
 
 %description java
-This package adds experimental support for compiling Java(tm) programs and
-bytecode into native code. To use this you will also need the gcc-libgcj
-package.
-
-%package libgcj
-Summary:       Java runtime library for gcc
-Group:         Libraries
-URL:           http://sourceware.cygnus.com/java/
-Requires:      zip >= 2.1
-
-%description libgcj
-The Java runtime library. You will need this package to compile your Java
-programs using the gcc Java compiler (gcj).
-
-%package libgcj-static
-Summary:       Static java runtime library for gcc
-Group:         Development/Libraries
-URL:           http://sourceware.cygnus.com/java/
-Requires:      %{name}-libgcj = %{version}
-
-%description libgcj-static
-The static java runtime library. You will need this package to staticly
-compile your Java programs using the gcc Java compiler (gcj).
+This package adds experimental support for compiling Java(tm) programs
+and bytecode into native code. To use this you will also need the
+libgcj package.
 
 %package -n libstdc++
 Summary:       GNU c++ library
 Summary(pl):   Biblioteki GNU C++ 
 Group:         Libraries
 Group(pl):     Biblioteki
+Group(fr):     Development/Librairies
 Version:       %{STDC_VERSION}
 Obsoletes:     libg++
 
 %description -n libstdc++
-This is the GNU implementation of the standard C++ libraries, along with
-additional GNU tools. This package includes the shared libraries
+This is the GNU implementation of the standard C++ libraries, along
+with additional GNU tools. This package includes the shared libraries
 necessary to run C++ applications.
 
 %description -l de -n libstdc++
-Dies ist die GNU-Implementierung der Standard-C++-Libraries mit weiteren
-GNU-Tools. Dieses Paket enthält die zum Ausführen von C++-Anwendungen
-erforderlichen gemeinsam genutzten Libraries.
+Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
+weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
+C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
 
 %description -l fr -n libstdc++
-Ceci est l'implémentation GNU des librairies C++ standard, ainsi que des
-outils GNU supplémentaires. Ce package comprend les librairies partagées
-nécessaires à l'exécution d'application C++.
+Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
+des outils GNU supplémentaires. Ce package comprend les librairies
+partagées nécessaires à l'exécution d'application C++.
 
 %description -l pl -n libstdc++  
-Pakiet ten zawiera biblioteki bêd±ce inplementacj± standardowych bibliotek
-C++, znajduj± siê w nim biblioteki dynamiczne niezbêdne do uruchomienia
-aplikacji C++.
+Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
+bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
+uruchomienia aplikacji napisanych w C++.
 
 %description -l tr -n libstdc++
 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
@@ -208,24 +217,28 @@ Summary(fr):      Fichiers d'en-t
 Summary(tr):   C++ ile program geliþtirmek için gerekli dosyalar
 Group:         Development/Libraries
 Group(pl):     Programowanie/Biblioteki
+Group(fr):     Development/Librairies
 Version:       %{STDC_VERSION}
 Requires:      libstdc++ = %{STDC_VERSION}
+Requires:      %{name}-c++
 Obsoletes:     libg++-devel
 
 %description -n libstdc++-devel
-This is the GNU implementation of the standard C++ libraries.  This package
-includes the header files and libraries needed for C++ development.
+This is the GNU implementation of the standard C++ libraries. This
+package includes the header files and libraries needed for C++
+development.
 
 %description -l pl -n libstdc++-devel
-Pakiet ten zawiera biblioteki bêd±ce inplementacj± standardowych bibliotek
-C++, znajduj± siê w nim biblioteki i pliki nag³ówków wykorzystywane do
-programowania w jêzyku C++.
+Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
+bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
+programowaniu w jêzyku C++.
 
 %package -n libstdc++-static
 Summary:       Static c++ standard library
 Summary(pl):   Biblioeka statyczna c++
 Group:         Development/Libraries
 Group(pl):     Programowanie/Biblioteki
+Group(fr):     Development/Librairies
 Version:       %{STDC_VERSION}
 Requires:      libstdc++-devel = %{STDC_VERSION}
 
@@ -233,71 +246,105 @@ Requires:        libstdc++-devel = %{STDC_VERSION}
 Static c++ standard library.
 
 %description -l pl -n libstdc++-static
-Biblioeka statyczna c++.
+Biblioteka statyczna C++.
 
 %package -n cpp
 Summary:       The C Pre Processor
 Summary(pl):   Preprocesor C
 Group:         Development/Languages
 Group(pl):     Programowanie/Jêzyki
-Prereq:                /sbin/install-info
 Obsoletes:     egcs-cpp
 
 %description -n cpp
-The C preprocessor is a "macro processor" that is used automatically by the
-C compiler to transform your program before actual compilation. It is called
-a macro processor because it allows you to define "macros", which are brief
-abbreviations for longer constructs.
-
-The C preprocessor provides four separate facilities that you can use as you
-see fit:
-
-* Inclusion of header files.  These are files of declarations that
-  can be substituted into your program.
-* Macro expansion.  You can define "macros", which are abbreviations for
-  arbitrary fragments of C code, and then the C preprocessor will replace
-  the macros with their definitions throughout the program.
-* Conditional compilation.  Using special preprocessing directives,
-  you can include or exclude parts of the program according to various
+The C preprocessor is a "macro processor" that is used automatically
+by the C compiler to transform your program before actual compilation.
+It is called a macro processor because it allows you to define
+"macros", which are brief abbreviations for longer constructs.
+
+The C preprocessor provides four separate facilities that you can use
+as you see fit:
+
+- Inclusion of header files. These are files of declarations that can
+  be substituted into your program.
+- Macro expansion. You can define "macros", which are abbreviations
+  for arbitrary fragments of C code, and then the C preprocessor will
+  replace the macros with their definitions throughout the program.
+- Conditional compilation. Using special preprocessing directives, you
+  can include or exclude parts of the program according to various
   conditions.
-* Line control.  If you use a program to combine or rearrange source
-  files into an intermediate file which is then compiled, you can use line
-  control to inform the compiler of where each source line originally came
-  from.
+- Line control. If you use a program to combine or rearrange source
+  files into an intermediate file which is then compiled, you can use
+  line control to inform the compiler of where each source line
+  originally came from.
 
 %description -l pl -n cpp
-Przeprocesor C jest "makro procesorem" który jest automatycznie u¿ywaney
-przez kompilator C do obróbki kompilowanego programu przed w³a¶ciw±
-kompilacj±. Jest on nazywany makroprocesorem poniewa¿ poniewa¿ umo¿liwia
-definiowanie i rozwijanie makr umo¿liwiaj±cych kracanie d³ugich konstrukcji
-w jêzyku C.
+Przeprocesor C jest "makro procesorem" który jest automatycznie
+u¿ywany przez kompilator C do obróbki kompilowanego programu przed
+w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
+umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
+d³ugich konstrukcji w jêzyku C.
 
-Preprocesor C umo¿liwia wykonywanie czterech róznych typow operacji:
+Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
 
-* Inkluzja (do³aczenie) plików (np. nag³ówkowych). W³±cza pliki w miejscu
-  deklaracji polecenia do³±czenia inefgo pliku.
-* Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
+- Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
+  deklaracji polecenia do³±czenia innego pliku.
+- Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
-* Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
-  ¶rodowisku preprocesora s± w³±czane warunkowo b±æ nie pewne fragmenty
-  obrabianego strumienia tekstów.
-* Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom podlega
-  wynikowy strumieñ danych w wyniku rozwijania makr i inkluzji s±
-  zapamiêtywane informacje o tym z której linii pliku ¼ród³owego
-  odpowiada fragment czy liniia pliku wynikowego.
+- Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
+  ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
+  fragmenty obrabianego strumienia tekstów.
+- Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
+  podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
+  s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
+  odpowiada fragment pliku wynikowego.
 
 %prep
 %setup -q
-%setup -q -a1 -D -T
-mv libgcj-%{GCJ_VERSION} libgcj
-mv libgcj/boehm-gc libgcj/libjava libgcj/zlib libgcj/zip .
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p0
+%patch5 -p0
+%patch6 -p1
+%patch7 -p0
+%patch8 -p0
+%patch9 -p0
+%patch10 -p0
+%patch11 -p0
+%patch12 -p0
+%patch13 -p1
+%patch14 -p1
+%ifarch arm
+%patch15 -p0
+%endif
+%ifarch m68k
+%patch16 -p0
+%endif
+%ifarch sparc sparc32
+%patch17 -p0
+%patch18 -p0
+%patch19 -p1
+%endif
+%ifarch ppc
+%patch20 -p0
+%patch21 -p0
+%patch22 -p0
+%endif
+%ifarch alpha
+%patch23 -p1
+%endif
+%patch24 -p0
+%patch25 -p0
+%patch26 -p0
+%patch27 -p0
+%patch28 -p0
+
+%{?glibc22:%patch100 -p1}
 
 %build
+(cd gcc; autoconf)
 rm -rf obj-%{_target_platform}
 install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
 
@@ -306,8 +353,10 @@ CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
        --prefix=%{_prefix} \
        --infodir=%{_infodir} \
        --enable-shared \
+%ifnarch sparc sparc64
        --enable-threads \
        --enable-haifa \
+%endif
        --with-gnu-as \
        --with-gnu-ld \
        --with-gxx-include-dir="\$\{prefix\}/include/g++" \
@@ -316,8 +365,7 @@ CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
 PATH=$PATH:/sbin:%{_sbindir}
 touch  ../gcc/c-gperf.h
 
-make LDFLAGS_FOR_TARGET="-s" \
-       bootstrap-lean \
+%{__make} LDFLAGS_FOR_TARGET="-s" \
        mandir=%{_mandir} \
        infodir=%{_infodir}
 
@@ -328,12 +376,12 @@ install -d $RPM_BUILD_ROOT%{_datadir}
 cd obj-%{_target_platform}
 PATH=$PATH:/sbin:%{_sbindir}
 
-make install \
+%{__make} install \
        prefix=$RPM_BUILD_ROOT%{_prefix} \
        mandir=$RPM_BUILD_ROOT%{_mandir} \
        infodir=$RPM_BUILD_ROOT%{_infodir}
 
-make install \
+%{__make} install \
        prefix=$RPM_BUILD_ROOT%{_prefix} \
        mandir=$RPM_BUILD_ROOT%{_mandir} \
        infodir=$RPM_BUILD_ROOT%{_infodir} -C texinfo
@@ -341,12 +389,13 @@ make install \
 strip $RPM_BUILD_ROOT%{_bindir}/* || :
 
 strip $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/{cc1,cc1chill,cc1obj,cc1plus,cpp,f771,collect2,jc1,jvgenmain}
-strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/libstdc++.so.*.*.*
+strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so*
 
 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
 
 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
 echo .so cccp.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cpp.1
+install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1/
 
 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
 
@@ -360,38 +409,28 @@ gzip -9nf $RPM_BUILD_ROOT%{_datadir}/{info/*.info*,man/man1/*} \
          ../READ* ../ChangeLog ../gcc/ch/chill.brochure
 
 %post
-/sbin/install-info %{_infodir}/gcc.info.gz /etc/info-dir
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
-%preun
-if [ "$1" = "0" ]; then
-       /sbin/install-info %{_infodir}/gcc.info.gz /etc/info-dir
-fi
+%postun
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
 %post g77
-/sbin/install-info %{_infodir}/g77.info.gz /etc/info-dir
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
-%preun g77
-if [ "$1" = "0" ]; then
-       /sbin/install-info %{_infodir}/g77.info.gz /etc/info-dir
-fi
+%postun g77
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
 %post chill
-/sbin/install-info %{_infodir}/chill.info.gz /etc/info-dir
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
-%preun chill
-if [ "$1" = "0" ]; then
-       /sbin/install-info %{_infodir}/chill.info.gz /etc/info-dir
-fi
+%postun chill
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
 %post -n cpp
-/sbin/install-info %{_infodir}/cpp.info.gz /etc/info-dir
-
-%preun -n cpp
-if [ "$1" = "0" ]; then
-       /sbin/install-info %{_infodir}/cpp.info.gz /etc/info-dir
-fi
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
-%post libgcj  -p /sbin/ldconfig
+%postun -n cpp
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
 %post   -p /sbin/ldconfig -n libstdc++
 %postun -p /sbin/ldconfig -n libstdc++
@@ -416,6 +455,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/cc
 
 %{_mandir}/man1/gcc.1*
+%{_mandir}/man1/gcov.1*
 %{_infodir}/gcc*
 
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/SYSCALLS.c.X
@@ -498,35 +538,22 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/gcj
 %attr(755,root,root) %{_bindir}/gcjh
 %attr(755,root,root) %{_bindir}/jcf-dump
-%attr(755,root,root) %{_bindir}/jv-convert
 %attr(755,root,root) %{_bindir}/jv-scan
 
-%{_libdir}/*.spec
-
 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
 
-%files libgcj
-%defattr(644,root,root,755)
-
-%attr(755,root,root) %{_libdir}/lib*gcj*.so
-%attr(755,root,root) %{_libdir}/lib*gcj*.so.*.*.*
-
-%files libgcj-static
-%defattr(644,root,root,755)
-
-%{_libdir}/lib*gcj*.a
-%{_libdir}/lib*gcj*.la
-
 %files -n libstdc++
+%defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
 
 %files -n libstdc++-devel
-%defattr(644,root,root,755) 
+%defattr(644,root,root,755)
 %{_includedir}/g++
 %attr(755,root,root) %{_libdir}/libstdc++.so
 
 %files -n libstdc++-static
+%defattr(644,root,root,755)
 %attr(644,root,root) %{_libdir}/libstdc++.a
 
 %files -n cpp
This page took 0.097074 seconds and 4 git commands to generate.