]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- remove ugly hack from `make check`.
[packages/gcc.git] / gcc.spec
index 5c27a93349dbcb6e05d61d450e1ea354990451d6..ca7862bb1be934b54773972928f4f9e7f5877afd 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -1,27 +1,26 @@
 #
-# TODO:
-#              - http://gcc.gnu.org/PR11203 (inline-asm)
-#              - http://gcc.gnu.org/PR20128 (ice with mudflap + profile generate)
-#
 # Conditional build:
 %bcond_without ada             # build without ADA support
+%bcond_without cxx             # build without C++ support
 %bcond_without fortran         # build without Fortran support
 %bcond_without java            # build without Java support
 %bcond_without objc            # build without Objective-C support
 %bcond_without objcxx          # build without Objective-C++ support
 %bcond_with    multilib        # build with multilib support (it needs glibc[32&64]-devel)
-%bcond_without profiling       # build without profiling
+%bcond_with    profiling       # build with profiling
 %bcond_without bootstrap       # omit 3-stage bootstrap
 %bcond_with    tests           # torture gcc
 
-# debuginfo not needed for devel snaps.
-%define                _enable_debug_packages  0
-
 %if %{with multilib}
 # the latest chrpath(64) can't handle 32-bit binaries :/
 %define                _noautochrpath  .*/lib/.*\\.so.*
 %endif
 
+%if %{without cxx}
+%undefine      with_java
+%undefine      with_objcxx
+%endif
+
 %if %{without objc}
 %undefine      with_objcxx
 %endif
@@ -40,7 +39,7 @@ Summary(pl):  Kolekcja kompilator
 Summary(pt_BR):        Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       4.1.0
-%define                _snap   20050716T0555UTC
+%define                _snap   20050915T1259UTC
 Release:       0.%{_snap}.1
 Epoch:         5
 License:       GPL v2+
@@ -48,7 +47,7 @@ Group:                Development/Languages
 #Source0:      ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.bz2
 #Source0:      ftp://gcc.gnu.org/pub/gcc/snapshots/4.1-%{_snap}/gcc-4.1-%{_snap}.tar.bz2
 Source0:       gcc-4.1-%{_snap}.tar.bz2
-# Source0-md5: 033f933cf8d2cc1b3b52bfdd6c0da8cc
+# Source0-md5: 7798c7c1ae8a9bbe49020f8dc8788e5b
 Source1:       %{name}-optimize-la.pl
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-nolocalefiles.patch
@@ -56,20 +55,21 @@ Patch2:             %{name}-nodebug.patch
 Patch3:                %{name}-ada-link-new-libgnat.patch
 Patch4:                %{name}-ada-link.patch
 Patch5:                %{name}-alpha-ada_fix.patch
-Patch6:                %{name}-ada-fwrapv.patch
+Patch6:                %{name}-keep-volatile-sematics.patch
 # PRs
 Patch10:       %{name}-pr7776.patch
 Patch11:       %{name}-pr20297.patch
-
-Patch14:       %{name}-pr22037.patch
-Patch15:       %{name}-pr19055.patch
+Patch12:       %{name}-pr23128.patch
+Patch13:       %{name}-pr22533.patch
+Patch14:       %{name}-x87-mmx-switch.patch
+Patch15:       %{name}-x87-mmx-eh.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf
 %{?with_tests:BuildRequires:   autogen}
 BuildRequires: automake
 BuildRequires: binutils >= 2:2.15.94.0.1
 BuildRequires: bison
-%{?with_java:BuildRequires:    cairo-devel}
+%{?with_java:BuildRequires:    cairo-devel >= 0.5.0}
 %{?with_tests:BuildRequires:   dejagnu}
 BuildRequires: fileutils >= 4.0.41
 BuildRequires: flex
@@ -726,7 +726,8 @@ Statyczne biblioteki Obiektowego C.
 # PRs
 %patch10 -p1
 %patch11 -p1
-
+%patch12 -p1
+%patch13 -p1
 %patch14 -p1
 %patch15 -p1
 
@@ -758,7 +759,7 @@ TEXCONFIG=false \
        --enable-shared \
        --enable-threads=posix \
        --enable-__cxa_atexit \
-       --enable-languages="c,c++%{?with_fortran:,f95}%{?with_objc:,objc}%{?with_objcxx:,obj-c++}%{?with_ada:,ada}%{?with_java:,java}" \
+       --enable-languages="c%{?with_cxx:,c++}%{?with_fortran:,f95}%{?with_objc:,objc}%{?with_objcxx:,obj-c++}%{?with_ada:,ada}%{?with_java:,java}" \
        --enable-c99 \
        --enable-long-long \
        --%{?with_multilib:en}%{!?with_multilib:dis}able-multilib \
@@ -790,7 +791,7 @@ cd ..
        mandir=%{_mandir} \
        infodir=%{_infodir}
 
-%{?with_tests:%{__make} -k -C obj-%{_target_platform} check}
+%{?with_tests:%{__make} -k -C obj-%{_target_platform} check 2>&1 ||:}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -814,13 +815,13 @@ ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
 echo ".so gcc.1" > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
 
-libssp=%(basename `echo $RPM_BUILD_ROOT%{_libdir}/libssp.so.*.*.*`)
+libssp=$(cd $RPM_BUILD_ROOT%{_libdir}; echo libssp.so.*.*.*)
 mv $RPM_BUILD_ROOT{%{_libdir}/$libssp,%{_slibdir}}
-ln -sf %{_slibdir}/$libssp $RPM_BUILD_ROOT%{_libdir}/$libssp
+ln -sf %{_slibdir}/$libssp $RPM_BUILD_ROOT%{_libdir}/libssp.so
 %if %{with multilib}
-libssp=%(basename `echo $RPM_BUILD_ROOT%{_libdir32}/libssp.so.*.*.*`)
+libssp=$($RPM_BUILD_ROOT%{_libdir32}; echo libssp.so.*.*.*`)
 mv $RPM_BUILD_ROOT{%{_libdir32}/$libssp,%{_slibdir32}}
-ln -sf %{_slibdir32}/$libssp $RPM_BUILD_ROOT%{_libdir32}/$libssp
+ln -sf %{_slibdir32}/$libssp $RPM_BUILD_ROOT%{_libdir32}/libssp.so
 %endif
 
 %if %{with fortran}
@@ -856,7 +857,8 @@ cp -f       libobjc/README gcc/objc/README.libobjc
 
 # avoid -L poisoning in *.la - there should be only -L%{_libdir}/gcc/*/%{version}
 # normalize libdir, to avoid propagation of unnecessary RPATHs by libtool
-for f in libmudflap.la libmudflapth.la libssp.la libstdc++.la libsupc++.la \
+for f in libmudflap.la libmudflapth.la libssp.la \
+       %{?with_cxx:libstdc++.la libsupc++.la} \
        %{?with_fortran:libgfortran.la libgfortranbegin.la} \
        %{?with_java:libgcj.la libffi.la} \
        %{?with_objc:libobjc.la};
@@ -889,7 +891,7 @@ ln -sf      %{_slibdir32}/libgcc_s.so.1     $gccdir/32/libgcc_s.so
 ln -sf %{_slibdir}/libgcc_s.so.1       $gccdir/libgcc_s.so
 
 %find_lang gcc
-%find_lang libstdc\+\+
+%{?with_cxx:%find_lang libstdc\+\+}
 
 # cvs snap doesn't contain (release does) below files,
 # so let's create dummy entries to satisfy %%files.
@@ -973,7 +975,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_slibdir}/lib*.so
 %{_libdir}/libssp.la
 %attr(755,root,root) %{_libdir}/libssp.a
-#{_libdir}/libssp_nonshared.*
+%attr(755,root,root) %{_libdir}/libssp.so
+%{_libdir}/libssp_nonshared.a
+%{_libdir}/libssp_nonshared.la
 %if %{with multilib}
 %dir %{_libdir}/gcc/*/*/32
 %{_libdir}/gcc/*/*/32/libgcov.a
@@ -982,7 +986,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/gcc/*/*/32/libgcc_s.so
 %{_libdir32}/libssp.la
 %attr(755,root,root) %{_libdir32}/libssp.a
-#{_libdir32}/libssp_nonshared.*
+%attr(755,root,root) %{_libdir32}/libssp.so
+%{_libdir32}/libssp_nonshared.a
+%{_libdir32}/libssp_nonshared.la
 %endif
 %{_libdir}/gcc/*/*/libgcov.a
 %{_libdir}/gcc/*/*/libgcc.a
@@ -1002,10 +1008,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %if %{with multilib}
 %attr(755,root,root) %{_slibdir32}/lib*.so.*
-%attr(755,root,root) %{_libdir32}/libssp.so.*
 %endif
 %attr(755,root,root) %{_slibdir}/lib*.so.*
-%attr(755,root,root) %{_libdir}/libssp.so.*
 
 %files -n libmudflap
 %defattr(644,root,root,755)
@@ -1061,6 +1065,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/gcc/*/*/adalib/libgnat.a
 %endif
 
+%if %{with cxx}
 %files c++
 %defattr(644,root,root,755)
 %doc gcc/cp/{ChangeLog,NEWS}
@@ -1112,6 +1117,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir32}/libstdc++.a
 %endif
 %{_libdir}/libstdc++.a
+%endif
 
 %if %{with fortran}
 %files fortran
This page took 0.052878 seconds and 4 git commands to generate.