]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- remove ugly hack from `make check`.
[packages/gcc.git] / gcc.spec
index 0e5ab6706cecaac7806291dbf4fef6b2e7e1ddf9..ca7862bb1be934b54773972928f4f9e7f5877afd 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -1,8 +1,4 @@
 #
-# TODO:
-#              - http://gcc.gnu.org/PR11203 (inline-asm)
-#              - http://gcc.gnu.org/PR20128 (ice with mudflap + profile generate)
-#
 # Conditional build:
 %bcond_without ada             # build without ADA support
 %bcond_without cxx             # build without C++ support
 %bcond_without objc            # build without Objective-C support
 %bcond_without objcxx          # build without Objective-C++ support
 %bcond_with    multilib        # build with multilib support (it needs glibc[32&64]-devel)
-%bcond_without profiling       # build without profiling
+%bcond_with    profiling       # build with profiling
 %bcond_without bootstrap       # omit 3-stage bootstrap
 %bcond_with    tests           # torture gcc
 
-# debuginfo not needed for devel snaps.
-%define                _enable_debug_packages  0
-
 %if %{with multilib}
 # the latest chrpath(64) can't handle 32-bit binaries :/
 %define                _noautochrpath  .*/lib/.*\\.so.*
@@ -46,15 +39,15 @@ Summary(pl):        Kolekcja kompilator
 Summary(pt_BR):        Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       4.1.0
-%define                _snap   20050724T0642UTC
-Release:       0.%{_snap}.0.1
+%define                _snap   20050915T1259UTC
+Release:       0.%{_snap}.1
 Epoch:         5
 License:       GPL v2+
 Group:         Development/Languages
 #Source0:      ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.bz2
 #Source0:      ftp://gcc.gnu.org/pub/gcc/snapshots/4.1-%{_snap}/gcc-4.1-%{_snap}.tar.bz2
 Source0:       gcc-4.1-%{_snap}.tar.bz2
-# Source0-md5: 3d9b5c5a60b7b6bb3f5f00ef7727b355
+# Source0-md5: 7798c7c1ae8a9bbe49020f8dc8788e5b
 Source1:       %{name}-optimize-la.pl
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-nolocalefiles.patch
@@ -66,11 +59,10 @@ Patch6:             %{name}-keep-volatile-sematics.patch
 # PRs
 Patch10:       %{name}-pr7776.patch
 Patch11:       %{name}-pr20297.patch
-Patch12:       %{name}-pr22484.patch
-Patch13:       %{name}-pr22493.patch
-Patch14:       %{name}-pr22037.patch
-Patch15:       %{name}-pr22533.patch
-#Patch16:      %{name}-mmx-x87-fpu-mode-switching-and-mmx-vectorizer.patch     NEEDS UPDATE
+Patch12:       %{name}-pr23128.patch
+Patch13:       %{name}-pr22533.patch
+Patch14:       %{name}-x87-mmx-switch.patch
+Patch15:       %{name}-x87-mmx-eh.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf
 %{?with_tests:BuildRequires:   autogen}
@@ -121,11 +113,6 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _libdir32       /usr/lib
 %endif
 
-%ifarch i686
-# workaround PR wrong-code/22584
-%define                optflags        -march=i486 -O2
-%endif
-
 %description
 A compiler aimed at integrating all the optimizations and features
 necessary for a high-performance and stable development environment.
@@ -743,7 +730,6 @@ Statyczne biblioteki Obiektowego C.
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
-#patch16 -p1   NEEDS UPDATE
 
 # because we distribute modified version of gcc...
 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
@@ -805,7 +791,7 @@ cd ..
        mandir=%{_mandir} \
        infodir=%{_infodir}
 
-%{?with_tests:%{__make} -k -C obj-%{_target_platform} check}
+%{?with_tests:%{__make} -k -C obj-%{_target_platform} check 2>&1 ||:}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -990,7 +976,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libssp.la
 %attr(755,root,root) %{_libdir}/libssp.a
 %attr(755,root,root) %{_libdir}/libssp.so
-#{_libdir}/libssp_nonshared.*
+%{_libdir}/libssp_nonshared.a
+%{_libdir}/libssp_nonshared.la
 %if %{with multilib}
 %dir %{_libdir}/gcc/*/*/32
 %{_libdir}/gcc/*/*/32/libgcov.a
@@ -1000,7 +987,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir32}/libssp.la
 %attr(755,root,root) %{_libdir32}/libssp.a
 %attr(755,root,root) %{_libdir32}/libssp.so
-#{_libdir32}/libssp_nonshared.*
+%{_libdir32}/libssp_nonshared.a
+%{_libdir32}/libssp_nonshared.la
 %endif
 %{_libdir}/gcc/*/*/libgcov.a
 %{_libdir}/gcc/*/*/libgcc.a
@@ -1184,8 +1172,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/gcc/*/*/jvgenmain
 %{_infodir}/fastjar*
 %{_infodir}/gcj*
-%{_infodir}/hacking*
-%{_infodir}/vmintegration*
 %{_mandir}/man1/fastjar*
 %{_mandir}/man1/gcj*
 %{_mandir}/man1/gjnih*
This page took 0.043693 seconds and 4 git commands to generate.