]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- no html subdir
[packages/gcc.git] / gcc.spec
index 81e5a5f8726b52a52a4536d8ecc3b5a0f27b864c..c5f1bf37ea836b30a795f39ab11471bd2e7b0a54 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -22,6 +22,7 @@
 %bcond_without alsa            # don't build libgcj ALSA MIDI interface
 %bcond_without dssi            # don't build libgcj DSSI MIDI interface
 %bcond_without gtk             # don't build libgcj GTK peer
+%bcond_without apidocs         # do not build and package API docs
 %bcond_with    mozilla         # don't build libgcjwebplugin (needs fix for new xulrunner)
 %bcond_with    qt              # build libgcj Qt peer (currently doesn't build with libtool-2.x)
 %bcond_without x               # don't build libgcj Xlib-dependent AWTs (incl. GTK/Qt)
@@ -70,7 +71,7 @@ Summary(pl.UTF-8):    Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       2
+Release:       4
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
@@ -93,6 +94,7 @@ Patch9:               %{name}-hash-style-gnu.patch
 Patch10:       %{name}-moresparcs.patch
 Patch11:       %{name}-build-id.patch
 Patch12:       %{name}-plugin-decl-hook.patch
+Patch13:       %{name}-python-pretty-printer-bool-vector.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf
 %{?with_tests:BuildRequires:   autogen}
@@ -188,6 +190,8 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                filterout       -fwrapv -fno-strict-aliasing -fsigned-char
 %define                filterout_ld    -Wl,--as-needed
 
+%define                skip_post_check_so      '.*(libmudflap|libmudflapth|libxmlj|lib-gnu-awt-xlib)\.so.*'
+
 %description
 A compiler aimed at integrating all the optimizations and features
 necessary for a high-performance and stable development environment.
@@ -777,6 +781,13 @@ Static C++ standard library - 32-bit version.
 %description -n libstdc++-multilib-static -l pl.UTF-8
 Statyczna biblioteka standardowa C++ - wersja 32-bitowa.
 
+%package -n libstdc++-apidocs
+Summary:       C++ standard library API documentation
+Group:         Documentation
+
+%description apidocs
+API and internal documentation for C++ standard library.
+
 %package fortran
 Summary:       Fortran 95 support for gcc
 Summary(es.UTF-8):     Soporte de Fortran 95 para gcc
@@ -1227,6 +1238,7 @@ Statyczna biblioteki Obiektowego C - wersja 32-bitowa.
 %patch10 -p0
 %patch11 -p0
 %patch12 -p0
+%patch13 -p0
 
 mv ChangeLog ChangeLog.general
 
@@ -1914,7 +1926,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n libstdc++-devel
 %defattr(644,root,root,755)
-%doc libstdc++-v3/doc/html
 %attr(755,root,root) %{_libdir}/libstdc++.so
 %{_libdir}/libstdc++.la
 %dir %{_includedir}/c++
@@ -1931,6 +1942,12 @@ rm -rf $RPM_BUILD_ROOT
 %exclude %{_includedir}/c++/%{version}/sun
 %endif
 
+%if %{with apidocs}
+%files libstdc++-apidocs
+%defattr(644,root,root,755)
+%doc libstdc++-v3/doc/html/*
+%endif
+
 %if %{with multilib}
 %files -n libstdc++-multilib-devel
 %defattr(644,root,root,755)
This page took 0.042576 seconds and 4 git commands to generate.