]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- speedup bootstrap stage1 build.
[packages/gcc.git] / gcc.spec
index 08bbb59830086609a0b460e395632cb4822c04fb..a2a2718e572ba9d1e7b53ecebc9fdc1ffb9a2476 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -2,7 +2,7 @@
 # TODO:
 # - gconf peer? (but libgcj needs split anyway)
 # - package?
-#   /usr/bin/aot-compile                                                                                                                                    
+#   /usr/bin/aot-compile
 #   /usr/bin/gjdoc
 #   /usr/share/man/man1/aot-compile.1.gz
 #   /usr/share/man/man1/gjdoc.1.gz
@@ -21,7 +21,7 @@
 %bcond_without alsa            # don't build libgcj ALSA MIDI interface
 %bcond_without dssi            # don't build libgcj DSSI MIDI interface
 %bcond_without gtk             # don't build libgcj GTK peer
-%bcond_without mozilla         # don't build libgcjwebplugin
+%bcond_with    mozilla         # don't build libgcjwebplugin (needs fix for new xulrunner)
 %bcond_with    qt              # build libgcj Qt peer (currently doesn't build with libtool-2.x)
 %bcond_without x               # don't build libgcj Xlib-dependent AWTs (incl. GTK/Qt)
 %bcond_without multilib        # build without multilib support (it needs glibc[32&64]-devel)
@@ -56,7 +56,7 @@
 %endif
 
 %define                major_ver       4.4
-%define                minor_ver       1
+%define                minor_ver       3
 # class data version seen with file(1) that this jvm is able to load
 %define                _classdataversion 50.0
 
@@ -66,17 +66,17 @@ Summary(pl.UTF-8):  Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       3
+Release:       5
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
 Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 927eaac3d44b22f31f9c83df82f26436
+# Source0-md5: fe1ca818fc6d2caeffc9051fe67ff103
 Source1:       %{name}-optimize-la.pl
 #Source2:      ftp://sourceware.org/pub/java/ecj-%{major_ver}.jar
 Source2:       ftp://sourceware.org/pub/java/ecj-latest.jar
 # Source2-md5: fd299f26c02268878b5d6c0e86f57c43
-# svn diff svn://gcc.gnu.org/svn/gcc//tags/gcc_4_4_1_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_4-branch > gcc-branch.diff
+# svn diff svn://gcc.gnu.org/svn/gcc//tags/gcc_4_4_3_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_4-branch > gcc-branch.diff
 Patch100:      %{name}-branch.diff
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-nolocalefiles.patch
@@ -129,7 +129,7 @@ BuildRequires:      zlib-devel
 %if %{with java}
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 %if %{with dssi}
-BuildRequires: dssi
+BuildRequires: dssi-devel
 BuildRequires: jack-audio-connection-kit-devel
 %endif
 BuildRequires: libxml2-devel >= 1:2.6.8
@@ -144,6 +144,7 @@ BuildRequires:      cairo-devel >= 0.5.0
 BuildRequires: gtk+2-devel >= 2:2.4.0
 BuildRequires: libart_lgpl-devel
 BuildRequires: pango-devel
+BuildRequires: xorg-lib-libXt-devel
 BuildRequires: xorg-lib-libXtst-devel
 %endif
 %if %{with qt}
@@ -152,7 +153,7 @@ BuildRequires:      qt4-build >= 4.0.1
 %endif
 %{?with_mozilla:BuildRequires: xulrunner-devel >= 1.8.1.3-1.20070321.5}
 %endif
-Requires:      binutils >= 2:2.17.50.0.9-1
+Requires:      binutils >= 2:2.20.51.0.2
 Requires:      libgcc = %{epoch}:%{version}-%{release}
 Provides:      cpp = %{epoch}:%{version}-%{release}
 %{?with_ada:Provides:  gcc(ada)}
@@ -215,7 +216,7 @@ License:    GPL v3+
 Group:         Development/Languages
 Requires:      %{name}
 Requires:      libgcc-multilib = %{epoch}:%{version}-%{release}
-%{?with_multilib:Provides:      gcc(multilib)}
+%{?with_multilib:Provides:     gcc(multilib)}
 Obsoletes:     libgcc32
 %ifarch %{x8664}
 Requires:      glibc-devel(i686)
@@ -1493,15 +1494,22 @@ TEXCONFIG=false \
 
 cd ..
 
-%{__make} -C builddir \
-       %{?with_bootstrap:%{?with_profiling:profiledbootstrap}} \
-       GCJFLAGS="%{rpmcflags}" \
-       BOOT_CFLAGS="%{rpmcflags}" \
-       STAGE1_CFLAGS="%{rpmcflags} -O0 -g0" \
-       GNATLIBCFLAGS="%{rpmcflags}" \
-       LDFLAGS_FOR_TARGET="%{rpmldflags}" \
-       mandir=%{_mandir} \
-       infodir=%{_infodir}
+cat << 'EOF' > Makefile
+all := $(filter-out all Makefile,$(MAKECMDGOALS))
+
+all $(all):
+       $(MAKE) -C builddir $(MAKE_OPTS) $(all) \
+               %{?with_bootstrap:%{?with_profiling:profiledbootstrap}} \
+               GCJFLAGS="%{rpmcflags}" \
+               BOOT_CFLAGS="%{rpmcflags}" \
+               STAGE1_CFLAGS="%{rpmcflags} -O0" \
+               GNATLIBCFLAGS="%{rpmcflags}" \
+               LDFLAGS_FOR_TARGET="%{rpmldflags}" \
+               mandir=%{_mandir} \
+               infodir=%{_infodir}
+EOF
+
+%{__make}
 
 %if %{with tests}
 if [ ! -r /dev/pts/0 ]; then
This page took 0.028103 seconds and 4 git commands to generate.