]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- another java bcond fix
[packages/gcc.git] / gcc.spec
index 98ed9bfd350c5ade5b15df4f453de35286083be1..9fe754e35d2b53da14bb994580ac9e304f5f4c7f 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -21,7 +21,7 @@
 %bcond_without gomp            # build without OpenMP support
 %bcond_without mudflap         # build without Mudflap pointer debugging support
 %bcond_without multilib        # build without multilib support (it needs glibc[32&64]-devel)
-%bcond_with    profiling       # build with profiling
+%bcond_without profiling       # build without profiling
 %bcond_without python          # build without libstdc++ printers for gdb and aot-compile for java
 # - libgcj options:
 %bcond_without alsa            # don't build libgcj ALSA MIDI interface
@@ -93,7 +93,7 @@ Summary(pl.UTF-8):    Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       4
+Release:       9
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
@@ -104,8 +104,9 @@ Source2:    ftp://sourceware.org/pub/java/ecj-%{major_ecj_ver}.jar
 # Source2-md5: d7cd6a27c8801e66cbaa964a039ecfdb
 # check libffi version with libffi/configure.ac
 Source3:       libffi.pc.in
-# svn diff -x --ignore-eol-style svn://gcc.gnu.org/svn/gcc/tags/gcc_4_7_2_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_7-branch > gcc-branch.diff
+# svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_4_7_2_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_7-branch > gcc-branch.diff
 Patch100:      %{name}-branch.diff
+# Patch100-md5:        34d2f91a58f942cf98a15e73614625c9
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-cloog.patch
 Patch2:                %{name}-nodebug.patch
@@ -148,7 +149,7 @@ BuildRequires:      glibc-devel >= 6:2.4-1
 %if %{with multilib}
 BuildRequires: gcc(multilib)
 %ifarch %{x8664}
-BuildRequires: glibc-devel(i686)
+BuildRequires: glibc-devel(ix86)
 %endif
 %ifarch ppc64
 BuildRequires: glibc-devel(ppc)
@@ -274,7 +275,7 @@ Requires:   libgcc-multilib = %{epoch}:%{version}-%{release}
 %{?with_multilib:Provides:     gcc(multilib)}
 Obsoletes:     libgcc32
 %ifarch %{x8664}
-Requires:      glibc-devel(i686)
+Requires:      glibc-devel(ix86)
 %endif
 %ifarch ppc64
 Requires:      glibc-devel(ppc)
@@ -1639,7 +1640,7 @@ all $(all):
                %{?with_bootstrap:%{?with_profiling:profiledbootstrap}} \
                GCJFLAGS="%{rpmcflags}" \
                BOOT_CFLAGS="%{rpmcflags}" \
-               STAGE1_CFLAGS="%{rpmcflags} -O0" \
+               STAGE1_CFLAGS="%{rpmcflags} -O1 -g0" \
                GNATLIBCFLAGS="%{rpmcflags}" \
                LDFLAGS_FOR_TARGET="%{rpmldflags}" \
                mandir=%{_mandir} \
@@ -1752,6 +1753,7 @@ cd ..
 install -d java-doc
 cp -f libjava/READ* java-doc
 ln -sf libgcj-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/libgcj.jar
+%endif
 
 # still not installed by gcc?
 [ ! -f $RPM_BUILD_ROOT%{_pkgconfigdir}/libffi.pc ] || exit 1
@@ -1767,7 +1769,6 @@ sed -e 's,@prefix@,%{_prefix},
        s,@libdir@,%{_libdir32},
        s,@gcclibdir@,%{gcclibdir},' %{SOURCE3} >$RPM_BUILD_ROOT%{_pkgconfigdir32}/libffi.pc
 %endif
-%endif
 
 %if %{with objc}
 cp -f libobjc/README gcc/objc/README.libobjc
@@ -2576,6 +2577,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libgij.a
 %{?with_x:%{_libdir}/lib-gnu-awt-xlib.a}
 %{_libdir}/%{gcjdbexecdir}/libjvm.a
+%endif
 
 %files -n libffi
 %defattr(644,root,root,755)
@@ -2616,7 +2618,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir32}/libffi.a
 %endif
-%endif
 
 %if %{with objc}
 %files objc
This page took 0.042286 seconds and 4 git commands to generate.