]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- added temporary hack for alpha
[packages/gcc.git] / gcc.spec
index f1d1a81980edbcee7d2dca2139ef07af5fd208bb..9c74f3da4e88d80f7ee400e328cdf966d161736a 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -4,25 +4,24 @@
 %bcond_without java            # build without Java support
 %bcond_without objc            # build without objc support
 %bcond_with    bootstrap       # don't BR gcc(ada) (temporary for Ac upgrade bootstrap)
-%bcond_with    pp              # build with ProPolice
 #
 %define                DASHED_SNAP     %{nil}
 %define                SNAP            %(echo %{DASHED_SNAP} | sed -e "s#-##g")
-%define                GCC_VERSION     3.3.3
+%define                GCC_VERSION     3.3.4
 %define                KSI_VERSION     1.1.0.1567
 
 Summary:       GNU Compiler Collection: the C compiler and shared files
 Summary(es):   Colección de compiladores GNU: el compilador C y ficheros compartidos
-Summary(pl):   Kolekcja Kompilatorów GNU: kompilator C i pliki wspó³dzielone
+Summary(pl):   Kolekcja kompilatorów GNU: kompilator C i pliki wspó³dzielone
 Summary(pt_BR):        Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{GCC_VERSION}
-Release:       2
+Release:       1
 Epoch:         5
 License:       GPL
 Group:         Development/Languages
 Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
-# Source0-md5: 3c6cfd9fcd180481063b4058cf6faff2
+# Source0-md5: a1c267b34f05c8660b24251865614d8b
 Source1:       ftp://ftp.pld-linux.org/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
 # Source1-md5: 66f07491b44f06928fd95b0e65bb8cd3
 Source2:       http://ep09.pld-linux.org/~djrzulf/gcc33/%{name}-non-english-man-pages.tar.bz2
@@ -32,6 +31,8 @@ Patch1:               %{name}-paths.patch
 Patch2:                %{name}-nolocalefiles.patch
 Patch3:                %{name}-ada-link-new-libgnat.patch
 Patch4:                %{name}-nodebug.patch
+Patch5:                %{name}-cse-find_best_addr.patch
+Patch6:                %{name}-alpha-regno-mode.patch
 # -- stolen patches from RH --
 Patch10:       gcc32-ada-link.patch
 Patch11:       gcc32-boehm-gc-libs.patch
@@ -48,10 +49,9 @@ Patch21:     gcc32-inline-label.patch
 Patch22:       gcc32-java-no-rpath.patch
 Patch23:       gcc32-test-rh65771.patch
 Patch24:       gcc32-test-rotate.patch
-Patch25:       %{name}-3.3.1-propolice.patch
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: binutils >= 2.14
+BuildRequires: binutils >= 2.15.90.0.3
 BuildRequires: bison
 BuildRequires: fileutils >= 4.0.41
 %{?with_ada:%{!?with_bootstrap:BuildRequires:  gcc(ada)}}
@@ -61,7 +61,7 @@ BuildRequires:        glibc-devel >= 2.2.5-20
 BuildRequires: perl-devel
 BuildRequires: texinfo >= 4.1
 BuildRequires: zlib-devel
-Requires:      binutils >= 2.14
+Requires:      binutils >= 2.15.90.0.3
 Requires:      cpp = %{epoch}:%{GCC_VERSION}
 Requires:      libgcc = %{epoch}:%{GCC_VERSION}
 %{?with_ada:Provides: gcc(ada)}
@@ -756,6 +756,10 @@ mv ksi-%{KSI_VERSION} gcc/ksi
 %patch2 -p1
 %patch3 -p1
 %{!?debug:%patch4 -p1}
+%patch5 -p1
+%ifarch alpha
+%patch6 -p1
+%endif
 
 %patch10 -p1
 %patch11
@@ -773,7 +777,6 @@ mv ksi-%{KSI_VERSION} gcc/ksi
 %patch22
 %patch23
 %patch24
-%{?with_pp:%patch25 -p1}
 
 # because we distribute modified version of gcc...
 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
@@ -823,10 +826,12 @@ cd ..
        infodir=%{_infodir}
 
 %if %{with ada}
-%{__make} -C obj-%{_target_platform}/gcc gnatlib gnattools gnatlib-shared \
+for tgt in gnatlib gnattools gnatlib-shared; do
+%{__make} -C obj-%{_target_platform}/gcc $tgt \
        LDFLAGS_FOR_TARGET="%{rpmldflags}" \
        mandir=%{_mandir} \
        infodir=%{_infodir}
+done
 %endif
 
 %install
This page took 0.487544 seconds and 4 git commands to generate.