]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- added two isl0.15 patches (isl 0.15 compatibility)
[packages/gcc.git] / gcc.spec
index 0d71016c0e2ae441be9f86652344ae656ffe31ff..9a209b431e19a4823cee10448c35f8df0e7d7958 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -18,7 +18,7 @@
 # - features:
 %bcond_without gomp            # build without OpenMP support
 %bcond_without multilib        # build without multilib support (which needs glibc[32&64]-devel)
-%bcond_with    multilibx32     # build with x32 multilib support on x86_64 (needs x32 glibc-devel)
+%bcond_without multilibx32     # build with x32 multilib support on x86_64 (needs x32 glibc-devel)
 %bcond_without profiling       # build without profiling
 %bcond_without python          # build without libstdc++ printers for gdb and aot-compile for java
 %bcond_with    gcc_libffi      # packaging gcc libffi for system usage
 %endif
 
 %define                major_ver       4.9
-%define                minor_ver       2
-%define                major_ecj_ver   4.9
+%define                minor_ver       3
+%define                ecj_ver         4.9
 # class data version seen with file(1) that this jvm is able to load
 %define                _classdataversion 50.0
 %define                gcj_soname_ver  15
@@ -121,22 +121,19 @@ Summary(pl.UTF-8):        Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       5
+Release:       1
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
 Source0:       https://ftp.gnu.org/pub/gnu/gcc/gcc-%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 4df8ee253b7f3863ad0b86359cd39c43
+# Source0-md5: 6f831b4d251872736e8e9cc09746f327
 Source1:       %{name}-optimize-la.pl
-Source2:       ftp://sourceware.org/pub/java/ecj-%{major_ecj_ver}.jar
-# Source2-md5: 7339f199ba11c941890031fd9981d7be
 # check libffi version with libffi/configure.ac
 Source3:       libffi.pc.in
-# svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_4_9_2_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_9-branch > gcc-branch.diff
+# svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_4_9_3_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_9-branch > gcc-branch.diff
 Patch100:      %{name}-branch.diff
-# Patch100-md5:        1f1a11566ddf413cca96fbb04fd790d4
+# Patch100-md5:        253cbf4cc2f71d9c9362f4a3be25bb17
 Patch0:                %{name}-info.patch
-Patch1:                %{name}-cloog.patch
 Patch2:                %{name}-nodebug.patch
 Patch3:                %{name}-ada-link.patch
 Patch4:                %{name}-ada-x32.patch
@@ -146,6 +143,8 @@ Patch7:             %{name}-libjava-multilib.patch
 Patch8:                %{name}-enable-java-awt-qt.patch
 Patch10:       %{name}-moresparcs.patch
 Patch11:       %{name}-install-libffi.patch
+Patch12:       %{name}-isl0.15-1.patch
+Patch13:       %{name}-isl0.15-2.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf >= 2.64
 %{?with_tests:BuildRequires:   autogen}
@@ -197,6 +196,7 @@ BuildRequires:      glibc-devel(sparcv9)
 BuildRequires: gmp-c++-devel >= 4.1
 BuildRequires: gmp-devel >= 4.1
 BuildRequires: isl-devel >= 0.13
+BuildRequires: java-ecj >= %{ecj_ver}
 BuildRequires: libmpc-devel
 BuildRequires: mpfr-devel >= 2.3.0
 %if %{with python}
@@ -1438,10 +1438,10 @@ Summary(es.UTF-8):      Soporte de Java para GCC
 Summary(pl.UTF-8):     Obsługa języka Java dla GCC
 Group:         Development/Languages/Java
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      java-ecj >= %{ecj_ver}
 Requires:      libgcj-devel = %{epoch}:%{version}-%{release}
 Provides:      gcc-java-tools
 Provides:      gcj = %{epoch}:%{version}-%{release}
-Obsoletes:     eclipse-ecj
 Obsoletes:     gcc-java-tools
 Obsoletes:     java-gnu-classpath-tools
 
@@ -2777,7 +2777,6 @@ Ten pakiet zawiera wersję %{m2_desc} statycznej biblioteki GNU Atomic.
 %setup -q
 %patch100 -p0
 %patch0 -p1
-%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
@@ -2791,14 +2790,11 @@ Ten pakiet zawiera wersję %{m2_desc} statycznej biblioteki GNU Atomic.
 %if %{with gcc_libffi}
 %patch11 -p0
 %endif
+%patch12 -p1
+%patch13 -p1
 
 mv ChangeLog ChangeLog.general
 
-%if %{with java}
-# see contrib/download_ecj
-cp -p %{SOURCE2} ecj.jar
-%endif
-
 # override snapshot version.
 echo %{version} > gcc/BASE-VER
 echo "release" > gcc/DEV-PHASE
@@ -2844,6 +2840,7 @@ TEXCONFIG=false \
        --enable-gnu-unique-object \
        --enable-gnu-indirect-function \
        --enable-initfini-array \
+       --disable-isl-version-check \
        --enable-languages="c%{?with_cxx:,c++}%{?with_fortran:,fortran}%{?with_objc:,objc}%{?with_objcxx:,obj-c++}%{?with_ada:,ada}%{?with_java:,java}%{?with_go:,go}" \
        --%{?with_gomp:en}%{!?with_gomp:dis}able-libgomp \
        --enable-libitm \
@@ -2871,6 +2868,7 @@ TEXCONFIG=false \
        --with-cpu=ultrasparc \
 %endif
        --with-demangler-in-ld \
+       --with-ecj-jar=%{_javadir}/ecj.jar \
        --with-gnu-as \
        --with-gnu-ld \
        --with-linker-hash-style=gnu \
@@ -3267,6 +3265,12 @@ rm -rf $RPM_BUILD_ROOT
 %postun        -n libffi-devel -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
+%post  -n libgomp-devel -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%postun        -n libgomp-devel -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
 %post   -p /sbin/ldconfig -n libcilkrts
 %postun -p /sbin/ldconfig -n libcilkrts
 %post   -p /sbin/ldconfig -n libcilkrts-multilib-32
@@ -4093,7 +4097,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{gcjdbexecdir}/libxmlj.so*
 %{_libdir}/logging.properties
 %{_javadir}/libgcj*.jar
-%{_javadir}/ecj.jar
 %{_mandir}/man1/gij.1*
 
 %files -n libgcj-devel
This page took 0.034145 seconds and 4 git commands to generate.