]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- gcc r: libgcc = %%{version} (libgcc_s.so is needed to build shared
[packages/gcc.git] / gcc.spec
index b126c7c27aacae995a3f999e926f0d05b1dc8657..99a081a24be4d281e4b4687d288e89689ee4bb68 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -1,4 +1,4 @@
-%define                DASHED_SNAP     2002-03-11
+%define                DASHED_SNAP     %{nil}
 %define                SNAP            %(echo %{DASHED_SNAP} | sed -e "s#-##g")
 %define                GCC_VERSION     3.1
 %define                STDC_VERSION    4.0.0
@@ -9,10 +9,10 @@ Summary:      GNU Compiler Collection
 Summary(pl):   Kolekcja kompilatorów GNU
 Name:          gcc
 Version:       %{GCC_VERSION}
-Release:       0.%{SNAP}.2
+Release:       1
 License:       GPL
 Group:         Development/Languages
-Source0:       ftp://gcc.gnu.org/pub/gcc/snapshots/%{DASHED_SNAP}/%{name}-%{SNAP}.tar.bz2
+Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
 Source1:       ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
 Patch0:                %{name}-slibdir.patch
 Patch1:                %{name}-paths.patch
@@ -26,8 +26,9 @@ BuildRequires:        autoconf
 BuildRequires: gcc
 BuildRequires: gcc-ada
 BuildRequires: perl-devel
-Requires:      binutils >= 2.9.1.0.25
+Requires:      binutils >= 2.12.90.0.4
 Requires:      cpp = %{version}
+Requires:      libgcc = %{version}
 URL:           http://gcc.gnu.org/
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -185,24 +186,6 @@ Static Fortran 77 Libraries
 %description -l pl -n libg2c-static
 Statyczne Fortranu 77
 
-%package chill
-Summary:       CHILL support for gcc
-Summary(pl):   Wspomoganie CHILL dla gcc
-Group:         Development/Languages
-Version:        %{GCC_VERSION}
-Requires:      %{name} = %{version}
-
-%description chill
-This package adds support for compiling CHILL programs with the GNU
-compiler.
-
-Chill is the "CCITT High-Level Language", where CCITT is the old name
-for what is now ITU, the International Telecommunications Union. It is
-is language in the Modula2 family, and targets many of the same
-applications as Ada (especially large embedded systems). Chill was
-never used much in the United States, but is still being used in
-Europe, Brazil, Korea, and other places.
-
 %package java
 Summary:       Java support for gcc
 Summary(pl):   Wspomoganie Java dla gcc
@@ -459,7 +442,7 @@ Ten pakiet zawiera biblioteki statyczne potrzebne do uruchamiania
 programów napisanych w Adzie.
 
 %prep
-%setup -q -a1 -n %{name}-%{SNAP}
+%setup -q -a1 -n %{name}-%{GCC_VERSION}
 mv ksi-%{KSI_VERSION} gcc/ksi
 %patch0 -p1
 %patch1 -p1
@@ -497,7 +480,7 @@ sed -e 's/srcdir=\$(fsrcdir)/srcdir=\$(fsrcdir) VPATH=\$(fsrcdir)/' \
 mv -f makefile.tmp gcc/ada/Makefile
 
 cd ..
-%{__make} -C obj-%{_target_platform} bootstrap \
+%{__make} -C obj-%{_target_platform} bootstrap-lean \
        LDFLAGS_FOR_TARGET="%{rpmldflags}" \
        mandir=%{_mandir} \
        infodir=%{_infodir}
@@ -508,10 +491,7 @@ cd ..
        infodir=%{_infodir}
 
 # make Gnat Reference Manual
-cd gcc/ada
-ln -s ../doc/include/fdl.texi gfdl.texi
-makeinfo gnat_rm.texi
-cd ../..
+%{__make} -C obj-%{_target_platform}/gcc/ada doc
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -551,12 +531,12 @@ ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
 
 cd ..
 
-install gcc/ada/gnat_rm.info* $RPM_BUILD_ROOT%{_infodir}
+install  obj-%{_target_platform}/gcc/ada/gnat_rm.info* $RPM_BUILD_ROOT%{_infodir}
 
 gzip -9nf READ* ChangeLog
 gzip -9nf gcc/ksi/README gcc/ksi/NEWS gcc/ksi/t/*.{ksi,c,foo}
 
-mkdir java-doc
+install -d java-doc
 mv -f libjava/doc/cni.sgml libjava/READ* java-doc
 mv -f fastjar/README java-doc/README.fastjar
 mv -f libffi/README java-doc/README.libffi
@@ -580,12 +560,6 @@ gzip -9nf gcc/objc/READ*
 %postun g77
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
-%post chill
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-%postun chill
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
 %post java
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
 
@@ -641,9 +615,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc_eh.a
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
-#%ifnarch alpha
 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
-#%endif
 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
 
@@ -718,7 +690,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adainclude
 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.ali
+%ifnarch ppc
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgmem.a
+%endif
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/Makefile.adalib
 %attr(755,root,root) %{_bindir}/gnat*
 %{_infodir}/gnat*
@@ -733,18 +707,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libgna*-*so
 
-%ifarch no_longer_supported_by_gcc_team
-%files chill
-%defattr(644,root,root,755)
-%doc gcc/ch/chill.brochure.gz
-
-%attr(755,root,root) %{_bindir}/chill
-%{_infodir}/chill*
-%attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
-%attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
-%{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
-%endif
-
 %files java
 %defattr(644,root,root,755)
 %doc java-doc/*.gz
@@ -778,7 +740,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/gnu/*
 %{_libdir}/lib*cj.spec
 %{_libdir}/security/*
-%{_datadir}/libgcj.jar
+%dir %{_datadir}/java
+%{_datadir}/java/libgcj*.jar
 %attr(755,root,root) %{_libdir}/lib*cj*.la
 %attr(755,root,root) %{_libdir}/lib*cj*.so
 
This page took 0.043823 seconds and 4 git commands to generate.