]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- updated to 4.1.0-20051121r107281, java-awt/qt4 bind disabled now,
[packages/gcc.git] / gcc.spec
index fabe0955a40007bafec6db0f873ec466b6cb8fd5..79827e29ab91aacdc8cedd781783da6fc17e5a68 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -1,8 +1,4 @@
 #
-# TODO:
-#              - http://gcc.gnu.org/PR11203 (inline-asm)
-#              - http://gcc.gnu.org/PR20128 (ice with mudflap + profile generate)
-#
 # Conditional build:
 %bcond_without ada             # build without ADA support
 %bcond_without cxx             # build without C++ support
 %bcond_without objc            # build without Objective-C support
 %bcond_without objcxx          # build without Objective-C++ support
 %bcond_with    multilib        # build with multilib support (it needs glibc[32&64]-devel)
-%bcond_without profiling       # build without profiling
+%bcond_with    profiling       # build with profiling
 %bcond_without bootstrap       # omit 3-stage bootstrap
 %bcond_with    tests           # torture gcc
 
-# debuginfo not needed for devel snaps.
-%define                _enable_debug_packages  0
-
 %if %{with multilib}
 # the latest chrpath(64) can't handle 32-bit binaries :/
 %define                _noautochrpath  .*/lib/.*\\.so.*
@@ -46,15 +39,15 @@ Summary(pl):        Kolekcja kompilator
 Summary(pt_BR):        Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       4.1.0
-%define                _snap   20050722T2023UTC
-Release:       0.%{_snap}.0.1
+%define                _snap   20051121r107281
+Release:       0.%{_snap}.1
 Epoch:         5
 License:       GPL v2+
 Group:         Development/Languages
 #Source0:      ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.bz2
 #Source0:      ftp://gcc.gnu.org/pub/gcc/snapshots/4.1-%{_snap}/gcc-4.1-%{_snap}.tar.bz2
 Source0:       gcc-4.1-%{_snap}.tar.bz2
-# Source0-md5: 8777b16adae820774fbacee281be783b
+# Source0-md5: b9505ecef44cb3598fda7ee920858602
 Source1:       %{name}-optimize-la.pl
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-nolocalefiles.patch
@@ -62,14 +55,25 @@ Patch2:             %{name}-nodebug.patch
 Patch3:                %{name}-ada-link-new-libgnat.patch
 Patch4:                %{name}-ada-link.patch
 Patch5:                %{name}-alpha-ada_fix.patch
-Patch6:                %{name}-keep-volatile-sematics.patch
+# -fvisibility fixes...
+Patch6:                %{name}-pr19664_gnu_internal.patch
+Patch7:                %{name}-pr19664_libstdc++.patch
+
+#Patch9:               %{name}-enable-java-awt-qt.patch        NEEDS UPDATE
 # PRs
 Patch10:       %{name}-pr7776.patch
 Patch11:       %{name}-pr20297.patch
-Patch12:       %{name}-pr22484.patch
-Patch13:       %{name}-pr22493.patch
-Patch14:       %{name}-pr22037.patch
+Patch12:       %{name}-pr24653.patch
+
+Patch14:       %{name}-x87-mmx-switch.patch
+Patch15:       %{name}-x87-mmx-eh.patch
+Patch16:       %{name}-pr23948.patch
+Patch17:       %{name}-pr19505.patch
+Patch18:       %{name}-pr24419.patch
+Patch19:       %{name}-pr24669.patch
+#Patch20:      %{name}-pr17390.patch           NEEDS UPDATE
 URL:           http://gcc.gnu.org/
+#{?with_java:BuildRequires:    QtGui-devel >= 4.0.1}
 BuildRequires: autoconf
 %{?with_tests:BuildRequires:   autogen}
 BuildRequires: automake
@@ -84,7 +88,23 @@ BuildRequires:       gcc(ada)
 BuildRequires: gcc-ada
 %endif
 BuildRequires: gettext-devel
-BuildRequires: glibc-devel >= %{!?with_multilib:2.2.5-20}%{?with_multilib:6:2.3.4-1.5}
+%if %{with multilib}
+BuildRequires: glibc-devel >= 6:2.3.4-1.5
+%ifarch %{x8664}
+BuildRequires: glibc-devel(i686)
+%endif
+%ifarch ppc64
+BuildRequires: glibc-devel(ppc)
+%endif
+%ifarch s390x
+BuildRequires: glibc-devel(s390)
+%endif
+%ifarch sparc64
+BuildRequires: glibc-devel(sparc)
+%endif
+%else
+BuildRequires: glibc-devel >= 2.2.5-20
+%endif
 %if %{with fortran}
 BuildRequires: gmp-devel
 BuildRequires: libmpfr-devel
@@ -719,7 +739,7 @@ Statyczne biblioteki Obiektowego C.
 
 %prep
 #setup -q -n gcc-%{version}
-%setup -q -n gcc-4.1-%{_snap}
+%setup -q -n gcc
 
 %patch0 -p1
 %patch1 -p1
@@ -727,14 +747,26 @@ Statyczne biblioteki Obiektowego C.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+
+# -fvisbility fixes...
 %patch6 -p1
+%patch7 -p1
 
+#patch9 -p1    NEEDS UPDATE
 # PRs
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
-%patch13 -p1
+
+%ifarch %{ix86} %{x8664}
 %patch14 -p1
+%patch15 -p1
+%endif
+%patch16 -p1
+%patch17 -p1
+%patch18 -p1
+%patch19 -p1
+#patch20 -p1   NEEDS UPDATE
 
 # because we distribute modified version of gcc...
 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
@@ -746,6 +778,9 @@ mv ChangeLog ChangeLog.general
 cd gcc
 %{__autoconf}
 cd ..
+cd libjava/classpath
+%{__autoconf}
+cd ../..
 cp -f /usr/share/automake/config.sub .
 
 rm -rf obj-%{_target_platform}
@@ -782,6 +817,7 @@ TEXCONFIG=false \
        --enable-libgcj-multifile \
        --enable-libgcj-database \
        --enable-gtk-cairo \
+       --enable-java-awt=gtk \
 %endif
        %{_target_platform}
 
@@ -796,7 +832,7 @@ cd ..
        mandir=%{_mandir} \
        infodir=%{_infodir}
 
-%{?with_tests:%{__make} -k -C obj-%{_target_platform} check}
+%{?with_tests:%{__make} -k -C obj-%{_target_platform} check 2>&1 ||:}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -880,20 +916,21 @@ done
 # by fixincludes, we don't want former
 gccdir=$(echo $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/)
 mkdir  $gccdir/tmp
+
 # we have to save these however
-%{?with_java:mv -f $gccdir/include/{gcj,libffi/ffitarget.h,jawt.h,jawt_md.h,jni.h,jvmpi.h} $gccdir/tmp}
-%{?with_objc:mv -f $gccdir/include/objc        $gccdir/tmp}
-mv -f  $gccdir/include/syslimits.h $gccdir/tmp
-rm -rf $gccdir/include
-mv -f  $gccdir/tmp $gccdir/include
-cp -f  $gccdir/install-tools/include/*.h $gccdir/include
+%{?with_java:mv $gccdir/include/{gcj,libffi/ffitarget.h,jawt.h,jawt_md.h,jni.h,jni_md.h,jvmpi.h} $gccdir/tmp}
+%{?with_objc:mv $gccdir/include/objc $gccdir/tmp}
+mv $gccdir/include/syslimits.h $gccdir/tmp
+rm -rf $gccdir/include
+mv $gccdir/tmp $gccdir/include
+cp $gccdir/install-tools/include/*.h $gccdir/include
 # but we don't want anything more from install-tools
-rm -rf $gccdir/install-tools
+rm -rf $gccdir/install-tools
 
 %if %{with multilib}
-ln -sf %{_slibdir32}/libgcc_s.so.1     $gccdir/32/libgcc_s.so
+ln -sf %{_slibdir32}/libgcc_s.so.1     $gccdir/32/libgcc_s.so
 %endif
-ln -sf %{_slibdir}/libgcc_s.so.1       $gccdir/libgcc_s.so
+ln -sf %{_slibdir}/libgcc_s.so.1       $gccdir/libgcc_s.so
 
 %find_lang gcc
 %{?with_cxx:%find_lang libstdc\+\+}
@@ -981,7 +1018,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libssp.la
 %attr(755,root,root) %{_libdir}/libssp.a
 %attr(755,root,root) %{_libdir}/libssp.so
-#{_libdir}/libssp_nonshared.*
+%{_libdir}/libssp_nonshared.a
+%{_libdir}/libssp_nonshared.la
 %if %{with multilib}
 %dir %{_libdir}/gcc/*/*/32
 %{_libdir}/gcc/*/*/32/libgcov.a
@@ -991,7 +1029,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir32}/libssp.la
 %attr(755,root,root) %{_libdir32}/libssp.a
 %attr(755,root,root) %{_libdir32}/libssp.so
-#{_libdir32}/libssp_nonshared.*
+%{_libdir32}/libssp_nonshared.a
+%{_libdir32}/libssp_nonshared.la
 %endif
 %{_libdir}/gcc/*/*/libgcov.a
 %{_libdir}/gcc/*/*/libgcc.a
This page took 0.034381 seconds and 4 git commands to generate.