]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- massive attack: adding Source-md5
[packages/gcc.git] / gcc.spec
index 65dc0341067a6122729ccaf869206d0d816b92b2..735ec6467684db54859f6c1b38dc6226c8b5dc9e 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -1,8 +1,8 @@
 #
 # Conditional build:
-# _without_ada  - build without ADA support
-# _without_java - build without Java support
-# _without_objc - build without objc support
+# _with_ada    - build with ADA support
+# _without_java        - build without Java support
+# _without_objc        - build without objc support
 
 %define                DASHED_SNAP     %{nil}
 %define                SNAP            %(echo %{DASHED_SNAP} | sed -e "s#-##g")
@@ -14,40 +14,41 @@ Summary(pl):        Kompilator C GNU
 Summary(pt_BR):        C Compilador GNU (GCC)
 Name:          gcc
 Version:       %{GCC_VERSION}
-Release:       0.4
+Release:       1
 Epoch:         5
 License:       GPL
 Group:         Development/Languages
 Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
+# Source0-md5: 39147717455d8dba4d43d1b058ea46e2
 Source1:       ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
+# Source1-md5: 66f07491b44f06928fd95b0e65bb8cd3
 Source2:       %{name}-non-english-man-pages.tar.bz2
+# Source2-md5: 4736f3422ddfb808423b745629acc321
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-paths.patch
-Patch4:                %{name}-nolocalefiles.patch
-Patch6:                %{name}-ada-link-new-libgnat.patch
+Patch2:                %{name}-nolocalefiles.patch
+Patch3:                %{name}-ada-link-new-libgnat.patch
 # -- stolen patches from RH --
 Patch10:       gcc32-ada-link.patch
-Patch16:       gcc32-boehm-gc-libs.patch
-Patch17:       gcc32-bogus-inline.patch
-Patch18:       gcc32-c++-nrv-test.patch
-Patch20:       gcc32-c++-tsubst-asm.patch
-Patch22:       gcc32-debug-pr7241.patch
-
-Patch24:       gcc32-duplicate-decl.patch
-Patch25:       gcc32-dwarf2-pr6381.patch
-Patch26:       gcc32-dwarf2-pr6436-test.patch
-Patch27:       gcc32-fde-merge-compat.patch
-
-Patch32:       gcc32-i386-memtest-test.patch
-Patch36:       gcc32-inline-label.patch
-Patch37:       gcc32-java-no-rpath.patch
-Patch40:       gcc32-test-rh65771.patch
-Patch41:       gcc32-test-rotate.patch
+Patch11:       gcc32-boehm-gc-libs.patch
+Patch12:       gcc32-bogus-inline.patch
+Patch13:       gcc32-c++-nrv-test.patch
+Patch14:       gcc32-c++-tsubst-asm.patch
+Patch15:       gcc32-debug-pr7241.patch
+Patch16:       gcc32-duplicate-decl.patch
+Patch17:       gcc32-dwarf2-pr6381.patch
+Patch18:       gcc32-dwarf2-pr6436-test.patch
+Patch19:       gcc32-fde-merge-compat.patch
+Patch20:       gcc32-i386-memtest-test.patch
+Patch21:       gcc32-inline-label.patch
+Patch22:       gcc32-java-no-rpath.patch
+Patch23:       gcc32-test-rh65771.patch
+Patch24:       gcc32-test-rotate.patch
 BuildRequires: autoconf
 BuildRequires: bison
 BuildRequires: fileutils >= 4.0.41
 BuildRequires: gcc
-%{!?_without_ada:BuildRequires:        gcc-ada}
+%{?_with_ada:BuildRequires:    gcc-ada}
 BuildRequires: glibc-devel >= 2.2.5-20
 BuildRequires: perl-devel
 BuildRequires: texinfo >= 4.1
@@ -597,25 +598,25 @@ mv ksi-%{KSI_VERSION} gcc/ksi
 
 %patch0 -p1
 %patch1 -p1
-%patch4 -p1
-%patch6 -p1
+%patch2 -p1
+%patch3 -p1
 
 %patch10 -p1
-#%patch16
-##%%patch17
+#%patch11
+#%patch12
+%patch13
+%patch14
+%patch15
+
+%patch16
+%patch17
 %patch18
+%patch19
 %patch20
+%patch21
 %patch22
-
+%patch23
 %patch24
-%patch25
-%patch26
-%patch27
-%patch32
-%patch36
-%patch37
-%patch40
-%patch41
 
 # because we distribute modified version of gcc...
 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
@@ -635,7 +636,7 @@ TEXCONFIG=false ../configure \
        --enable-shared \
        --enable-threads=posix \
        --enable-__cxa_atexit \
-       --enable-languages="c,c++,f77%{?!_without_objc:,objc}%{!?_without_ada:,ada}%{!?_without_java:,java},ksi" \
+       --enable-languages="c,c++,f77%{?!_without_objc:,objc}%{?_with_ada:,ada}%{!?_without_java:,java},ksi" \
        --enable-c99 \
        --enable-long-long \
        --enable-multilib \
@@ -650,7 +651,7 @@ TEXCONFIG=false ../configure \
 PATH=$PATH:/sbin:%{_sbindir}
 
 # this dirty hack is relict of setting, where objdir is subdir of srcdir
-%if %{!?_without_ada:1}%{?_without_ada:0}
+%if 0%{?_with_ada:1}
 sed -e 's/srcdir=\$(fsrcdir)/srcdir=\$(fsrcdir) VPATH=\$(fsrcdir)/' \
        gcc/ada/Makefile > makefile.tmp
 mv -f makefile.tmp gcc/ada/Makefile
@@ -662,7 +663,7 @@ cd ..
        mandir=%{_mandir} \
        infodir=%{_infodir}
 
-%if %{!?_without_ada:1}%{?_without_ada:0}
+%if 0%{?_with_ada:1}
 %{__make} -C obj-%{_target_platform}/gcc gnatlib gnattools gnatlib-shared \
        LDFLAGS_FOR_TARGET="%{rpmldflags}" \
        mandir=%{_mandir} \
@@ -685,7 +686,7 @@ echo ".so gcc.1" > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
 echo ".so g77.1" > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
 
-%if %{!?_without_ada:1}%{?_without_ada:0}
+%if 0%{?_with_ada:1}
 # move ada shared libraries to proper place...
 mv $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.so.1 \
        $RPM_BUILD_ROOT%{_libdir}/
@@ -810,6 +811,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(ja) %{_mandir}/ja/man1/gcc.1*
 %{_infodir}/gcc*
 
+%attr(755,root,root) %{_slibdir}/lib*.so
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc_eh.a
 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
@@ -828,7 +830,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n libgcc
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_slibdir}/lib*.so*
+%attr(755,root,root) %{_slibdir}/lib*.so.*
 
 %files c++
 %defattr(644,root,root,755)
@@ -964,8 +966,8 @@ rm -rf $RPM_BUILD_ROOT
 %files -n libgcj
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/addr2name.awk
-%attr(755,root,root) %{_libdir}/lib*cj*.so.*
-%attr(755,root,root) %{_libdir}/lib-org*.so.*
+%attr(755,root,root) %{_libdir}/lib*cj*.so.*.*.*
+%attr(755,root,root) %{_libdir}/lib-org*.so.*.*.*
 %ifarch ppc
 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so.*
 %endif
@@ -1016,7 +1018,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libffi.a
 %endif
 
-%if %{!?_without_ada:1}%{?_without_ada:0}
+%if 0%{?_with_ada:1}
 %files ada
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/gnat1
@@ -1051,8 +1053,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_slibdir}/cpp
 %attr(755,root,root) %{_bindir}/cpp
-#%%attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
-#%%attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
 %{_mandir}/man1/cpp.1*
 %lang(ja) %{_mandir}/ja/man1/cpp.1*
 %{_infodir}/cpp*
This page took 0.044104 seconds and 4 git commands to generate.