]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
- updated to 4.1.0-20050815T0803UTC.
[packages/gcc.git] / gcc.spec
index 0ba901b76f23f9c3796e46e8da5657714845ecec..1406daba68cfc6b52aedbd77e2444bbad1901eb0 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
 %bcond_without objc            # build without Objective-C support
 %bcond_without objcxx          # build without Objective-C++ support
 %bcond_with    multilib        # build with multilib support (it needs glibc[32&64]-devel)
-%bcond_without profiling       # build without profiling
+%bcond_with    profiling       # build with profiling
 %bcond_without bootstrap       # omit 3-stage bootstrap
 %bcond_with    tests           # torture gcc
 
-# debuginfo not needed for devel snaps.
-%define                _enable_debug_packages  0
-
 %if %{with multilib}
 # the latest chrpath(64) can't handle 32-bit binaries :/
 %define                _noautochrpath  .*/lib/.*\\.so.*
@@ -46,7 +43,7 @@ Summary(pl):  Kolekcja kompilator
 Summary(pt_BR):        Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       4.1.0
-%define                _snap   20050722T2023UTC
+%define                _snap   20050815T0803UTC
 Release:       0.%{_snap}.1
 Epoch:         5
 License:       GPL v2+
@@ -54,7 +51,7 @@ Group:                Development/Languages
 #Source0:      ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/%{name}-%{version}.tar.bz2
 #Source0:      ftp://gcc.gnu.org/pub/gcc/snapshots/4.1-%{_snap}/gcc-4.1-%{_snap}.tar.bz2
 Source0:       gcc-4.1-%{_snap}.tar.bz2
-# Source0-md5: 8777b16adae820774fbacee281be783b
+# Source0-md5: ecb28f45b0109a097a17b88a129c66cd
 Source1:       %{name}-optimize-la.pl
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-nolocalefiles.patch
@@ -66,9 +63,8 @@ Patch6:               %{name}-keep-volatile-sematics.patch
 # PRs
 Patch10:       %{name}-pr7776.patch
 Patch11:       %{name}-pr20297.patch
-Patch12:       %{name}-pr22484.patch
-Patch13:       %{name}-pr22493.patch
-Patch14:       %{name}-pr22037.patch
+Patch12:       %{name}-pr23128.patch
+Patch13:       %{name}-pr22533.patch
 URL:           http://gcc.gnu.org/
 BuildRequires: autoconf
 %{?with_tests:BuildRequires:   autogen}
@@ -119,11 +115,6 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _libdir32       /usr/lib
 %endif
 
-%ifarch i686
-# workaround PR wrong-code/22584
-%define                optflags        -march=i486 -O2
-%endif
-
 %description
 A compiler aimed at integrating all the optimizations and features
 necessary for a high-performance and stable development environment.
@@ -739,7 +730,6 @@ Statyczne biblioteki Obiektowego C.
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-%patch14 -p1
 
 # because we distribute modified version of gcc...
 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
@@ -801,7 +791,7 @@ cd ..
        mandir=%{_mandir} \
        infodir=%{_infodir}
 
-%{?with_tests:%{__make} -k -C obj-%{_target_platform} check}
+%{?with_tests:%{__make} -k -C obj-%{_target_platform} check 2>&1 | cat}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -886,7 +876,7 @@ done
 gccdir=$(echo $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/)
 mkdir  $gccdir/tmp
 # we have to save these however
-%{?with_java:mv -f $gccdir/include/{gcj,libffi/ffitarget.h,jawt.h,jawt_md.h,jvmpi.h} $gccdir/tmp}
+%{?with_java:mv -f $gccdir/include/{gcj,libffi/ffitarget.h,jawt.h,jawt_md.h,jni.h,jvmpi.h} $gccdir/tmp}
 %{?with_objc:mv -f $gccdir/include/objc        $gccdir/tmp}
 mv -f  $gccdir/include/syslimits.h $gccdir/tmp
 rm -rf $gccdir/include
@@ -986,7 +976,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libssp.la
 %attr(755,root,root) %{_libdir}/libssp.a
 %attr(755,root,root) %{_libdir}/libssp.so
-#{_libdir}/libssp_nonshared.*
+%{_libdir}/libssp_nonshared.a
+%{_libdir}/libssp_nonshared.la
 %if %{with multilib}
 %dir %{_libdir}/gcc/*/*/32
 %{_libdir}/gcc/*/*/32/libgcov.a
@@ -996,7 +987,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir32}/libssp.la
 %attr(755,root,root) %{_libdir32}/libssp.a
 %attr(755,root,root) %{_libdir32}/libssp.so
-#{_libdir32}/libssp_nonshared.*
+%{_libdir32}/libssp_nonshared.a
+%{_libdir32}/libssp_nonshared.la
 %endif
 %{_libdir}/gcc/*/*/libgcov.a
 %{_libdir}/gcc/*/*/libgcc.a
@@ -1212,6 +1204,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/gcc/*/*/include/gcj
 %{_libdir}/gcc/*/*/include/jawt.h
 %{_libdir}/gcc/*/*/include/jawt_md.h
+%{_libdir}/gcc/*/*/include/jni.h
 %{_libdir}/gcc/*/*/include/jvmpi.h
 %dir %{_libdir}/security
 %{_libdir}/security/*
This page took 0.318358 seconds and 4 git commands to generate.