]> git.pld-linux.org Git - packages/freeciv.git/blobdiff - freeciv.spec
- server is required by client to play
[packages/freeciv.git] / freeciv.spec
index 9b14f2f8d3b07a6ae1905565cd7f66406332312e..87dbc9b3fc4977bddd60d780a450ac9f3400f171 100644 (file)
@@ -1,35 +1,46 @@
+#
 # TODO
 # - dozen of unpackaged files
+#
+# Conditional build:
+%bcond_without gtk             # do not build gtk client
+%bcond_without  ggz_client     # build without ggz client
+%bcond_without  ggz_server     # build without ggz server
+#
 Summary:       FREE CIVilization clone
-Summary(es.UTF-8):   Clon del juego Civilization
-Summary(pl.UTF-8):   Niekomercyjny klon CIVilization
-Summary(pt_BR.UTF-8):   Clone do jogo Civilization
+Summary(es.UTF-8):     Clon del juego Civilization
+Summary(pl.UTF-8):     Niekomercyjny klon CIVilization
+Summary(pt_BR.UTF-8):  Clone do jogo Civilization
 Name:          freeciv
-Version:       2.1.0
+Version:       2.1.3
 Release:       0.1
 License:       GPL v2+
 Group:         X11/Applications/Games/Strategy
 Source0:       http://dl.sourceforge.net/freeciv/%{name}-%{version}.tar.bz2
-# Source0-md5: f640aa48abca0a235220d6df22b9bc82
-Source1:       %{name}-client.desktop
-Source2:       %{name}-server.desktop
-Source3:       %{name}.png
-Source4:       ftp://ftp.freeciv.org/pub/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz
-# Source4-md5: 77215914712f2f351092918f5e41e39e
-Source5:       ftp://ftp.freeciv.org/pub/freeciv/contrib/tilesets/freeland/freeland-normal-2.0.0.tar.gz
-# Source5-md5: c9f061fca82aa50a19fbbc89c06ff81d
+# Source0-md5: 2b5e96c6464212273150f8d3ec0bf7f7
+Source1:       ftp://ftp.freeciv.org/pub/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz
+# Source1-md5: 77215914712f2f351092918f5e41e39e
+Source2:       ftp://ftp.freeciv.org/pub/freeciv/contrib/tilesets/freeland/freeland-normal-2.0.0.tar.gz
+# Source2-md5: c9f061fca82aa50a19fbbc89c06ff81d
+Patch0:                %{name}-link.patch
+Patch1:                %{name}-desktop.patch
 URL:           http://www.freeciv.org/
 BuildRequires: SDL_mixer-devel
+BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: esound-devel
-BuildRequires: gtk+2-devel
+%{?with_gtk:BuildRequires:     gtk+2-devel}
+%{?with_ggz_client:BuildRequires:      ggz-gtk-client-devel}
+%{?with_ggz_server:BuildRequires:      ggz-server-devel}
+BuildRequires: libggz-devel
+BuildRequires: pkgconfig
 BuildRequires: readline-devel
 BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Free clone of Sid Meier's Civilization. Free Civilization clone for
-unix and X. This is multiplayer strategic game and you can also play
+Unix and X. This is multiplayer strategic game and you can also play
 against computer-AI players.
 
 %description -l es.UTF-8
@@ -47,9 +58,10 @@ Window.
 
 %package client
 Summary:       Freeciv game client
-Summary(pl.UTF-8):   Klient gry Freeciv
+Summary(pl.UTF-8):     Klient gry Freeciv
 Group:         X11/Applications/Games/Strategy
 Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-server = %{version}-%{release}
 Requires:      SDL_mixer
 Requires:      esound
 
@@ -59,10 +71,9 @@ This package contains Freeciv game client.
 %description client -l pl.UTF-8
 Ten pakiet zawiera klienta gry Freeciv.
 
-
 %package server
 Summary:       Freeciv game server
-Summary(pl.UTF-8):   Serwer gry Freeciv
+Summary(pl.UTF-8):     Serwer gry Freeciv
 Group:         X11/Applications/Games/Strategy
 Requires:      %{name} = %{version}-%{release}
 
@@ -73,26 +84,38 @@ This package contans Freeciv game server.
 Ten pakiet zawiera server gry Freeciv.
 
 %prep
-%setup -q -a 4 -a 5
+%setup -q -a1 -a2
+%patch0 -p1
+%patch1 -p1
 
 %build
-cp -f %{_datadir}/automake/config.sub bootstrap
-%configure2_13 
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+%configure \
+%{?with_gtk:   --enable-client=gtk}
+%{!?with_ggz_client:   --without-ggz-client}
+%{!?with_ggz_server:   --without-ggz-server}
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults \
-       $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
-install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
+cp -f client/%{name}.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}-client.desktop
+cp -f server/%{name}-server.desktop $RPM_BUILD_ROOT%{_desktopdir}
+cp -f data/icons/32x32/*.png $RPM_BUILD_ROOT%{_pixmapsdir}
+cp -rf data/stdsounds{,.soundspec} $RPM_BUILD_ROOT%{_datadir}/%{name}
 cp -f freeland.tilespec $RPM_BUILD_ROOT%{_datadir}/%{name}
 cp -rf freeland $RPM_BUILD_ROOT%{_datadir}/%{name}
 
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
+
 %find_lang %{name}
 
 %clean
@@ -128,8 +151,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/%{name}/isophex
 %{_datadir}/%{name}/isotrident
 %{_datadir}/%{name}/misc
-%{_datadir}/%{name}/stdsounds
 %{_datadir}/%{name}/trident
 %{_datadir}/%{name}/flags
 %{_datadir}/%{name}/*.*spec
+%{_datadir}/%{name}/stdsounds
 %{_mandir}/man6/civclient.6*
This page took 0.230187 seconds and 4 git commands to generate.