]> git.pld-linux.org Git - packages/freeciv.git/blobdiff - freeciv.spec
added BR: gtk+3-devel for gtk3 client
[packages/freeciv.git] / freeciv.spec
index c8adc8e7c6490e3a141ca85efc19ad46d1913910..6287862ddef824375d60eef68f6fc193f110e244 100644 (file)
@@ -1,5 +1,9 @@
 #
-# TODO: try to create bconds for supported clients
+# TODO: - try to create bconds for supported clients
+#      - separate desktop files for all clients
+#      - gtk3 client is broken:
+#              GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
+#      - work on authentication and Freeciv database support (fcdb)
 #
 # Conditional build:
 %bcond_without  ggz_client     # build without ggz client
@@ -10,12 +14,12 @@ Summary(es.UTF-8):  Clon del juego Civilization
 Summary(pl.UTF-8):     Niekomercyjny klon CIVilization
 Summary(pt_BR.UTF-8):  Clone do jogo Civilization
 Name:          freeciv
-Version:       2.3.0
-Release:       1
+Version:       2.4.4
+Release:       0.2
 License:       GPL v2+
 Group:         X11/Applications/Games/Strategy
 Source0:       http://downloads.sourceforge.net/freeciv/%{name}-%{version}.tar.bz2
-# Source0-md5: 70fd4285f2da7d41bdadac43458e62c9
+# Source0-md5: 038c53184497fcf31bcd268418dbe4f6
 # NOTE: current version of freeland tiles does not work with newest freeciv version
 #Source1:      http://download.gna.org/freeciv/contrib/tilesets/freeland/freeland-normal-2.0.0.tar.gz
 Patch0:                %{name}-link.patch
@@ -23,16 +27,20 @@ Patch1:             %{name}-desktop.patch
 Patch2:                %{name}-ggz.patch
 URL:           http://freeciv.wikia.com/
 BuildRequires: SDL_mixer-devel
+BuildRequires: SDL_image-devel
 BuildRequires: autoconf >= 2.52
-BuildRequires: automake
-BuildRequires: gettext-devel
+BuildRequires: automake >= 1:1.9
+BuildRequires: curl-devel
+BuildRequires: gettext-tools
 %{?with_ggz_client:BuildRequires:      ggz-gtk-client-devel}
 BuildRequires: gtk+2-devel
+BuildRequires: gtk+3-devel
 BuildRequires: libggz-devel
 BuildRequires: libpng-devel
 BuildRequires: libtool
 BuildRequires: pkgconfig
 BuildRequires: readline-devel
+BuildRequires: xorg-lib-libXaw-devel
 BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -85,7 +93,7 @@ Ten pakiet zawiera server gry Freeciv.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
+#patch1 -p1
 %patch2 -p1
 
 %build
@@ -97,7 +105,7 @@ Ten pakiet zawiera server gry Freeciv.
 %configure \
        --with-ggzd-confdir=%{_sysconfdir}/ggzd \
        --disable-silent-rules \
-       --enable-client=all \
+       --enable-client=gtk2,gtk3,sdl,xaw,stub \
        %{!?with_ggz_client:--without-ggz-client} \
        %{!?with_ggz_server:--without-ggz-server}
 
@@ -130,6 +138,10 @@ cp -a data/civserver.dsc $RPM_BUILD_ROOT%{_sysconfdir}/ggzd/games/civserver.dsc
 cp -a data/civserver.room $RPM_BUILD_ROOT%{_sysconfdir}/ggzd/rooms/civserver.room
 %endif
 
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc/%{name}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libfreeciv{,-srv}.{a,la}
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man6/freeciv-qt*
+
 %find_lang %{name}
 
 %clean
@@ -137,7 +149,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS README ChangeLog NEWS
+%doc AUTHORS doc/BUGS ChangeLog doc/FAQ doc/HOWTOPLAY
+%doc NEWS NEWS-2.4
+%doc doc/README.SDLClient doc/README.cma doc/README.effects doc/README.fcdb
+%doc doc/README.graphics doc/README.sound
+%doc doc/README.ruleset_experimental doc/README.ruleset_multiplayer doc/README.rulesets
+%doc doc/TODO
 %dir %{_datadir}/%{name}
 %{_datadir}/%{name}/helpdata.txt
 
@@ -145,13 +162,14 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/freeciv-server
 %{_desktopdir}/%{name}-server.desktop
+%{_datadir}/appdata/freeciv-server.appdata.xml
 %{_datadir}/%{name}/civ1
 %{_datadir}/%{name}/civ2
 %{_datadir}/%{name}/default
 %{_datadir}/%{name}/experimental
 %{_datadir}/%{name}/multiplayer
 %{_datadir}/%{name}/nation
-%{_datadir}/%{name}/scenario
+%{_datadir}/%{name}/scenarios
 %{_datadir}/%{name}/*.serv
 %{_mandir}/man6/freeciv-server.6*
 %{_iconsdir}/hicolor/*/apps/freeciv-server.png
@@ -168,12 +186,25 @@ rm -rf $RPM_BUILD_ROOT
 %files client
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/freeciv-gtk2
+%attr(755,root,root) %{_bindir}/freeciv-gtk3
+%attr(755,root,root) %{_bindir}/freeciv-sdl
+%attr(755,root,root) %{_bindir}/freeciv-stub
+%attr(755,root,root) %{_bindir}/freeciv-xaw
 %attr(755,root,root) %{_bindir}/freeciv-manual
 %attr(755,root,root) %{_bindir}/freeciv-modpack
 %{_desktopdir}/%{name}-client.desktop
+%{_desktopdir}/%{name}-gtk3.desktop
+%{_desktopdir}/%{name}-modpack.desktop
+%{_desktopdir}/%{name}-sdl.desktop
+%{_datadir}/appdata/freeciv-gtk2.appdata.xml
+%{_datadir}/appdata/freeciv-gtk3.appdata.xml
+%{_datadir}/appdata/freeciv-modpack.appdata.xml
+%{_datadir}/appdata/freeciv-sdl.appdata.xml
+%{_datadir}/%{name}/Freeciv
 %{_datadir}/%{name}/*.*spec
 %{_datadir}/%{name}/amplio2
 %{_datadir}/%{name}/buildings
+%{_datadir}/%{name}/cimpletoon
 %{_datadir}/%{name}/flags
 %{_datadir}/%{name}/freeciv.rc*
 #%%{_datadir}/%{name}/freeland
@@ -187,10 +218,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/%{name}/trident
 %{_datadir}/%{name}/wonders
 %{_mandir}/man6/freeciv-client.6*
-%{_mandir}/man6/freeciv-ftwl.6*
 %{_mandir}/man6/freeciv-gtk2.6*
+%{_mandir}/man6/freeciv-gtk3.6*
+%{_mandir}/man6/freeciv-manual.6*
+%{_mandir}/man6/freeciv-modpack.6*
 %{_mandir}/man6/freeciv-sdl.6*
-%{_mandir}/man6/freeciv-win32.6*
 %{_mandir}/man6/freeciv-xaw.6*
 %{_iconsdir}/hicolor/*/apps/freeciv-client.png
+%{_iconsdir}/hicolor/*/apps/freeciv-modpack.png
 %{_pixmapsdir}/freeciv-client.png
+%{_pixmapsdir}/freeciv-modpack.png
+
This page took 0.029777 seconds and 4 git commands to generate.