]> git.pld-linux.org Git - packages/fpc.git/blobdiff - fpc.spec
- attempt at fixing 64bit arch inconsistency
[packages/fpc.git] / fpc.spec
index cb57d45c41c3e40a95ecac8b0361fb2afd9d0074..bde1e286422303ab14d4e4b7c13fc53ed04ae4a1 100644 (file)
--- a/fpc.spec
+++ b/fpc.spec
@@ -8,33 +8,37 @@ Summary(pl.UTF-8):    32 bitowy kompilator dla procesorów i386 i m68k
 Summary(ru.UTF-8):     Свободный компилятор Pascal
 Summary(uk.UTF-8):     Вільний компілятор Pascal
 Name:          fpc
-Version:       2.6.0
-Release:       1
-License:       GPL
+Version:       2.6.4
+Release:       2
+License:       GPL v2+
 Group:         Development/Languages
 Source0:       ftp://ftp.freepascal.org/pub/fpc/dist/%{version}/source/%{name}build-%{version}.tar.gz
-# Source0-md5: 17375e665a4e1311f85812fe2754f609
+# Source0-md5: 403da132aed194fd841d46c3b33b022a
 Source1:       ftp://ftp.freepascal.org/pub/fpc/dist/%{version}/i386-linux/%{name}-%{version}.i386-linux.tar
-# Source1-md5: 42b8fcaba867f515446a84aa0430db91
+# Source1-md5: 915f799dd58b5429f06a48d4bd84a9c2
 Source2:       ftp://ftp.freepascal.org/pub/fpc/dist/%{version}/x86_64-linux/%{name}-%{version}.x86_64-linux.tar
-# Source2-md5: 631d93ca49778537cd84fa3a2878883c
+# Source2-md5: ffc3cae4a72b60efb6873b9ce5c8a0f2
 Source3:       ftp://ftp.freepascal.org/pub/fpc/dist/%{version}/powerpc-linux/%{name}-%{version}.powerpc-linux.tar
-# Source3-md5: e08ac5d45747d8a12589b55c7cd58ded
+# Source3-md5: 28eb428bfaa8a72e49be05ed0efa0081
 Patch0:                %{name}-skip-dev-dot.patch
 Patch1:                %{name}-link.patch
 Patch2:                %{name}-gdb.patch
+Patch3:                %{name}-r22920.patch
 URL:           http://www.freepascal.org/
-BuildRequires: binutils-static >= 3:2.17.50
+BuildRequires: binutils-devel >= 3:2.17.50
 BuildRequires: gpm-devel
 BuildRequires: ncurses-devel
 BuildRequires: rpmbuild(macros) >= 1.213
 %if %{with ide}
+BuildRequires: babeltrace-devel
+BuildRequires: expat-devel
 BuildRequires: gdb-lib >= 7.2-7
-BuildRequires: python-static
-BuildRequires: readline-static
-BuildRequires: libselinux-static
-BuildRequires: zlib-static
-BuildRequires: xz-static
+BuildRequires: guile-devel
+BuildRequires: python-devel
+BuildRequires: readline-devel
+BuildRequires: libselinux-devel
+BuildRequires: xz-devel
+BuildRequires: zlib-devel
 %endif
 %if %{with doc}
 BuildRequires: tetex-fonts-jknappen
@@ -116,6 +120,7 @@ Dokumentacja do fpc w formacie PDF.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p0
 
 %ifarch %{ix86}
 tar xf %{SOURCE1}
@@ -148,9 +153,17 @@ done
 ln -sf `pwd`/lib/%{name}/%{_bver}/ppc* bin
 cd ..
 
+find fpcsrc -name Makefile -o -name fpcmake.ini -o -name fpmkunit.pp | \
+       xargs %{__sed} -i -e 's|/usr/lib/|%{_libdir}/|g'
+
 # save for fpc-src
 install -d fpc-src
 cp -af fpcsrc/* fpc-src
+rm -r fpc-src/{ide,tests}
+
+%if 0%{?debug:1}
+find fpcsrc -name Makefile | xargs %{__sed} -i -e 's/-Xs//'
+%endif
 
 %build
 # use ld.bfd
@@ -161,6 +174,7 @@ export PATH=$(pwd)/our-ld:$PATH
 PP=`pwd`/bin/lib/%{name}/%{_bver}/ppc%{_bname}
 NEWPP=`pwd`/fpcsrc/compiler/ppc%{_bname}
 NEWFPDOC=`pwd`/fpcsrc/utils/fpdoc/fpdoc
+DATA2INC=`pwd`/fpcsrc/utils/data2inc
 
 # DO NOT PUT $RPM_OPT_FLAGS IN OPT, IT DOES NOT WORK - baggins
 case "%{_build_cpu}" in
@@ -173,23 +187,24 @@ case "%{_build_cpu}" in
 esac
 
 %{__make} -C fpcsrc compiler_cycle \
-       OPT="$OPTF -Xs -n" \
+       OPT="$OPTF %{!?debug:-Xs} -n" \
        RELEASE="1" \
        BASEINSTALLDIR=%{_libdir}/%{name}/%{version} \
        BININSTALLDIR=%{_bindir} \
+       DATA2INC="$DATA2INC" \
        PP="$PP" \
        FPC="$PP" \
        LINKSMART=YES
 
-%{__make} -C fpcsrc OPT="$OPTF -Xs -n" \
+%{__make} -C fpcsrc OPT="$OPTF %{!?debug:-Xs} -n" \
        RELEASE="1" \
        BASEINSTALLDIR=%{_libdir}/%{name}/%{version} \
        BININSTALLDIR=%{_bindir} \
        GDBLIBDIR=%{_libdir} \
+       DATA2INC="$DATA2INC" \
        PP="$NEWPP" \
        FPC="$NEWPP" \
        FPDOC=$NEWFPDOC \
-       DATA2INC=`pwd`/utils/data2inc \
        LINKSMART=YES \
        NODOCS=YES \
        rtl_clean \
@@ -225,6 +240,7 @@ FPCMAKE=`pwd`/fpcsrc/utils/fpcm/fpcmake
        PP="$NEWPP" \
        FPCMAKE="$FPCMAKE" \
        SMARTLINK=YES \
+       FPCDIR=%{_libdir}/%{name}/%{version} \
        INSTALL_PREFIX=$RPM_BUILD_ROOT%{_prefix} \
        INSTALL_BINDIR=$RPM_BUILD_ROOT%{_bindir} \
        INSTALL_LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
@@ -245,6 +261,14 @@ ln -sf %{_bindir}/ld.bfd $RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}/ld
 sh fpc-src/compiler/utils/samplecfg $RPM_BUILD_ROOT%{_libdir}/%{name}/%{version} $RPM_BUILD_ROOT%{_sysconfdir}
 %{__sed} -i -e "s,$RPM_BUILD_ROOT,,g" $RPM_BUILD_ROOT%{_sysconfdir}/{*.cfg,fppkg/default}
 
+# I have no idea why some units are installed to /usr/lib - baggins
+%if "%{_lib}" != "lib"
+cd $RPM_BUILD_ROOT/usr/lib/%{name}/%{version}/units
+for d in * ; do
+       %{__mv} $d/* $RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}/units/$d/
+done
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.035447 seconds and 4 git commands to generate.