]> git.pld-linux.org Git - packages/fontconfig.git/blobdiff - fontconfig.spec
patch to fix constant (non-ranged) weight in font pattern; rel 2
[packages/fontconfig.git] / fontconfig.spec
index aa4d974e96f99ea58052a766c090fc3c3483a371..8e3b1819c87b1bbbfed4b89697a35e5669d1c79c 100644 (file)
@@ -1,23 +1,26 @@
+#
 # Conditional build
 %bcond_without static_libs     # don't build static library
-%bcond_without doc
+%bcond_without doc             # don't build HTML and man docs
+%bcond_without tests           # don't perform make check
 
 Summary:       Font configuration and customization tools
 Summary(pl.UTF-8):     Narzędzia do konfigurowania fontów
 Summary(pt_BR.UTF-8):  Ferramentas para configuração e customização do acesso a fontes
 Name:          fontconfig
-Version:       2.10.1
-Release:       9
+Version:       2.13.0
+Release:       2
 Epoch:         1
 License:       MIT
 Group:         Libraries
-Source0:       http://fontconfig.org/release/%{name}-%{version}.tar.gz
-# Source0-md5: c94e380eea42f2f23ca9537035ef1899
+Source0:       https://www.freedesktop.org/software/fontconfig/release/%{name}-%{version}.tar.bz2
+# Source0-md5: 60d2394a79d3b2e5db2daea55193fa47
 Source1:       %{name}-lcd-filter.conf
 Patch0:                %{name}-bitstream-cyberbit.patch
+Patch1:                %{name}-constant-weight.patch
 URL:           http://fontconfig.org/
-BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: autoconf >= 2.61
+BuildRequires: automake >= 1:1.11
 %if %{with doc}
 BuildRequires: docbook-dtd31-sgml
 BuildRequires: docbook-dtd41-sgml
@@ -25,11 +28,13 @@ BuildRequires:      docbook-utils >= 0.6.13-3
 %endif
 BuildRequires: ed
 BuildRequires: expat-devel
-BuildRequires: freetype-devel >= 2.1.5
-BuildRequires: libtool
+BuildRequires: freetype-devel >= 2.8.1
+BuildRequires: gettext-tools >= 0.19.8
+BuildRequires: gperf
+BuildRequires: libtool >= 2:2.2
 BuildRequires: pkgconfig
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
-Requires:      freetype >= 2.1.5
+Requires:      freetype >= 2.8.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -125,10 +130,12 @@ Este pacote contém a biblioteca estática do fontconfig
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
+%{__gettextize}
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
@@ -137,11 +144,13 @@ Este pacote contém a biblioteca estática do fontconfig
 export HASDOCBOOK=no
 
 %configure \
-       --%{?with_doc:en}%{!?with_doc:dis}able-docs \
+       --enable-docs%{!?with_doc:=no} \
        --disable-silent-rules \
-       %{!?with_static_libs:--disable-static}
+       --%{?with_static_libs:en}%{!?with_static_libs:dis}able-static
 %{__make}
 
+%{?with_tests:%{__make} check}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig} \
@@ -158,6 +167,9 @@ ln -s %{_datadir}/%{name}/conf.avail $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.av
 
 cp -pf conf.d/README README.confd
 
+%find_lang %{name}
+%find_lang %{name}-conf -a %{name}.lang
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -178,27 +190,25 @@ HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
-%files
+%files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS COPYING ChangeLog README README.confd doc/fontconfig-user.html
-%dir %{_sysconfdir}/fonts
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
 %{_sysconfdir}/fonts/conf.avail
-%dir %{_datadir}/xml/%{name}
-%{_datadir}/xml/%{name}/fonts.dtd
-%dir %{_datadir}/%{name}
-%dir %{_datadir}/%{name}/conf.avail
-%{_datadir}/%{name}/conf.avail/*.conf
-%dir %{_sysconfdir}/fonts/conf.d
 %{_sysconfdir}/fonts/conf.d/README
 %config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
 %attr(755,root,root) %{_bindir}/fc-cache
 %attr(755,root,root) %{_bindir}/fc-cat
+%attr(755,root,root) %{_bindir}/fc-conflist
 %attr(755,root,root) %{_bindir}/fc-list
 %attr(755,root,root) %{_bindir}/fc-match
 %attr(755,root,root) %{_bindir}/fc-query
 %attr(755,root,root) %{_bindir}/fc-pattern
 %attr(755,root,root) %{_bindir}/fc-scan
+%attr(755,root,root) %{_bindir}/fc-validate
+%dir %{_datadir}/xml/%{name}
+%{_datadir}/xml/%{name}/fonts.dtd
+%{_datadir}/%{name}/conf.avail/*.conf
 %if %{with doc}
 %{_mandir}/man1/fc-*.1*
 %{_mandir}/man5/fonts-conf.5*
@@ -217,6 +227,8 @@ HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
 %{_libdir}/libfontconfig.la
 %{_includedir}/fontconfig
 %{_pkgconfigdir}/fontconfig.pc
+%{_datadir}/gettext/its/fontconfig.its
+%{_datadir}/gettext/its/fontconfig.loc
 %if %{with doc}
 %{_mandir}/man3/Fc*.3*
 %endif
This page took 0.048403 seconds and 4 git commands to generate.