]> git.pld-linux.org Git - packages/file.git/blobdiff - file.spec
up to 5.43
[packages/file.git] / file.spec
index 57ee32a7713ce24bc3bb2cfc13858f9fe928098b..f6a005f93643617e930b4264373f4d6ea7a1fe9c 100644 (file)
--- a/file.spec
+++ b/file.spec
@@ -1,9 +1,14 @@
 #
 # Conditional build:
-%bcond_without python2         # don't build python-magic module for Python 2.x
-%bcond_without python3         # don't build python-magic module for Python 3.x
-%bcond_without static_libs     # don't build static libraries
-%bcond_without tests           # don't perform "make check"
+%bcond_without python2         # CPython 2.x python-magic module
+%bcond_without python3         # CPython 3.x python-magic module
+%bcond_without static_libs     # static library
+%bcond_without tests           # unit tests
+%bcond_without seccomp         # SECCOMP support
+
+%ifnarch %{x8664} aarch64
+%undefine      with_seccomp
+%endif
 
 Summary:       A utility for determining file types
 Summary(cs.UTF-8):     Program pro zjišťování typu souborů
@@ -29,34 +34,39 @@ Summary(uk.UTF-8):  Утиліта для визначення типів фай
 Summary(zh_CN.UTF-8):  判定文件类型的工具。
 Summary(zh_TW.UTF-8):  用於決定檔案類型的一個工具程式。
 Name:          file
-Version:       5.18
-Release:       2
+Version:       5.43
+Release:       1
 License:       distributable
 Group:         Applications/File
 Source0:       ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
-# Source0-md5: d420d8f2990cd344673acfbf8d76ff5a
+# Source0-md5: 8effd70da368210a6c6eece037f978eb
 Source1:       http://ftp1.pld-linux.org/people/glen/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 6a45bcaefd19b94db36a1b2b7c5b806b
 Source2:       %{name}-zisofs.magic
 Source3:       %{name}-mscompress.magic
 Source4:       %{name}-magic.mime-gen.awk
-Patch0:                %{name}-sparc.patch
-Patch1:                %{name}-selinux.patch
-Patch2:                searchpath.patch
-Patch3:                automake.patch
+Patch0:                %{name}-selinux.patch
+Patch1:                searchpath.patch
+Patch2:                automake.patch
+Patch3:                %{name}-gettext-no-random-translations.patch
+Patch4:                name-use-count.patch
 URL:           http://www.darwinsys.com/file/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
+BuildRequires: libseccomp-devel
 BuildRequires: libtool >= 2:2.0
-BuildRequires: rpmbuild(macros) >= 1.453
+BuildRequires: rpm-build >= 4.6
+BuildRequires: rpmbuild(macros) >= 1.751
 %if %{with python2}
 BuildRequires: python-devel
 BuildRequires: python-modules
+BuildRequires: python-setuptools
 BuildRequires: rpm-pythonprov
 %endif
 %if %{with python3}
 BuildRequires: python3-devel
 BuildRequires: python3-modules
+BuildRequires: python3-setuptools
 BuildRequires: rpm-pythonprov
 %endif
 BuildRequires: zlib-devel
@@ -208,6 +218,7 @@ Summary:    Header files for libmagic library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libmagic
 Group:         Development/Libraries
 Requires:      libmagic = %{version}-%{release}
+Requires:      libseccomp-devel
 Requires:      zlib-devel
 
 %description -n libmagic-devel
@@ -244,6 +255,7 @@ Summary(pl.UTF-8):  Wiązania Pythona 2 do biblioteki libmagic
 Group:         Libraries/Python
 Requires:      libmagic = %{version}-%{release}
 Requires:      python-libs
+BuildArch:     noarch
 
 %description -n python-magic
 Python 2 bindings for libmagic.
@@ -257,6 +269,7 @@ Summary(pl.UTF-8):  Wiązania Pythona 3 do biblioteki libmagic
 Group:         Libraries/Python
 Requires:      libmagic = %{version}-%{release}
 Requires:      python-libs
+BuildArch:     noarch
 
 %description -n python3-magic
 Python 3 bindings for libmagic.
@@ -270,8 +283,9 @@ Wiązania Pythona 3 do biblioteki libmagic.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
-%if "%{cc_version}" < "3.4"
+%if "%{_ver_lt '%{cc_version}' '3.4'}" == "1"
 %{__sed} -i -e 's,-Wextra,,' configure.ac
 %endif
 
@@ -286,11 +300,12 @@ cp -a python py3
 
 %build
 %{__libtoolize}
-%{__aclocal}
-%{__autoheader}
+%{__aclocal} -I m4
 %{__autoconf}
+%{__autoheader}
 %{__automake}
 %configure \
+       %{!?with_seccomp:--disable-libseccomp} \
        --disable-silent-rules \
        --enable-fsect-man5 \
        %{?with_static_libs:--enable-static}
@@ -299,12 +314,12 @@ cp -a python py3
 
 %if %{with python2}
 cd python
-%{__python} setup.py build
+%py_build
 cd ..
 %endif
 %if %{with python3}
 cd py3
-%{__python3} setup.py build
+%py3_build
 cd ..
 %endif
 
@@ -319,25 +334,20 @@ install -d $RPM_BUILD_ROOT/%{_lib}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_libdir}/libmagic.so.* $RPM_BUILD_ROOT/%{_lib}
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/libmagic.so.* $RPM_BUILD_ROOT/%{_lib}
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libmagic.so.*.*.*) \
         $RPM_BUILD_ROOT%{_libdir}/libmagic.so
 
 %if %{with python2}
 cd python
-%{__python} setup.py install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 cd ..
 %py_postclean
 %endif
 
 %if %{with python3}
 cd py3
-%{__python3} setup.py install \
-       --optimize=2 \
-       --skip-build \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 cd ..
 %endif
 
@@ -366,7 +376,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog COPYING README
+%doc ChangeLog COPYING
 %attr(755,root,root) %{_bindir}/file
 %{_datadir}/file
 %{_datadir}/misc/magic
@@ -395,6 +405,7 @@ fi
 %attr(755,root,root) %{_libdir}/libmagic.so
 %{_libdir}/libmagic.la
 %{_includedir}/magic.h
+%{_pkgconfigdir}/libmagic.pc
 %{_mandir}/man3/libmagic.3*
 
 %if %{with static_libs}
@@ -403,21 +414,19 @@ fi
 %{_libdir}/libmagic.a
 %endif
 
-%if %{with python3}
+%if %{with python2}
 %files -n python-magic
 %defattr(644,root,root,755)
-%doc python/README python/example.py
-%if "%{py_ver}" > "2.4"
-%{py_sitescriptdir}/Magic_file_extensions-*.egg-info
-%endif
+%doc python/README.md python/example.py
 %{py_sitescriptdir}/magic.py[co]
+%{py_sitescriptdir}/file_magic-*-py*.egg-info
 %endif
 
-%if %{with_python3}
+%if %{with python3}
 %files -n python3-magic
 %defattr(644,root,root,755)
-%doc python/README python/example.py
+%doc python/README.md python/example.py
 %{py3_sitescriptdir}/magic.py
 %{py3_sitescriptdir}/__pycache__/magic.*.py[co]
-%{py3_sitescriptdir}/Magic_file_extensions-*.egg-info
+%{py3_sitescriptdir}/file_magic-*-py*.egg-info
 %endif
This page took 0.064317 seconds and 4 git commands to generate.