]> git.pld-linux.org Git - packages/exim.git/blobdiff - exim.spec
- better english
[packages/exim.git] / exim.spec
index 37c8d00eb11b57252ce70e8113a5b8dfa3c72471..9ce81de09dc5b9f97c2842725e27000656e8ce92 100644 (file)
--- a/exim.spec
+++ b/exim.spec
@@ -1,29 +1,28 @@
+#
 # Conditional build:
 %bcond_without pgsql   # without PostgreSQL support
 %bcond_without mysql   # without MySQL support
 %bcond_without whoson  # without whoson support
 %bcond_without sasl    # without SASL
 %bcond_without ldap    # without LDAP support
-%bcond_without exiscan # without exiscan support
 %bcond_without spf     # without spf support
 %bcond_without srs     # without srs support
 %bcond_with    saexim  # with sa-exim support
 #
-%define                exiscan_version 4.44-28
-%define                saexim_version 3.1
+%define                saexim_version 4.2
 Summary:       University of Cambridge Mail Transfer Agent
 Summary(pl):   Agent Transferu Poczty Uniwersytetu w Cambridge
 Summary(pt_BR):        Servidor de correio eletrĂ´nico exim
 Name:          exim
-Version:       4.44
+Version:       4.50
 Release:       1
 Epoch:         2
 License:       GPL
 Group:         Networking/Daemons
 Source0:       ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/exim4/%{name}-%{version}.tar.bz2
-# Source0-md5: 7487274e013b598d97445987d38b2071
-Source1:       ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/exim4/%{name}-texinfo-4.40.tar.bz2
-# Source1-md5: cc91bd804ee0f7fd70991e2e6b529033
+# Source0-md5: 7844eff82171872f6b3971a4183368d9
+Source1:       ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/exim4/%{name}-texinfo-4.50.tar.bz2
+# Source1-md5: a12993436e9943083e3ce5b76cf96b11
 Source2:       %{name}.init
 Source3:       %{name}.cron.db
 Source4:       %{name}4.conf
@@ -32,8 +31,6 @@ Source6:      %{name}on.desktop
 # 20021016: http://www.logic.univie.ac.at/~ametzler/debian/exim4manpages/
 Source7:       %{name}4-man-021016.tar.bz2
 # Source7-md5: b552704ebf853a401946038a2b7e8e98
-Source8:       http://duncanthrax.net/exiscan-acl/exiscan-acl-%{exiscan_version}.patch.bz2
-# Source8-md5: 72ef5567106e89e6cef1cc742ab52525
 Source9:       %{name}.aliases
 Source10:      newaliases
 Source11:      %{name}.logrotate
@@ -45,13 +42,12 @@ Source14:   ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/exim4/config.samples.t
 Source15:      %{name}4-smtp.pamd
 Source16:      %{name}on.png
 Source17:      http://marc.merlins.org/linux/exim/files/sa-exim-%{saexim_version}.tar.gz
-# Source17-md5:        34892f195384c127f7c40c461a9ef421
+# Source17-md5:        ad76f73c6b3d01caa88078e3e622745a
 Patch0:                %{name}4-EDITME.patch
 Patch1:                %{name}4-monitor-EDITME.patch
 Patch2:                %{name}4-texinfo.patch
 Patch3:                %{name}4-use_system_pcre.patch
 Patch4:                %{name}4-Makefile-Default.patch
-Patch5:                %{name}4-exiscan-pld.patch
 URL:           http://www.exim.org/
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.0.0}
 %{?with_spf:BuildRequires:     libspf2-devel}
@@ -67,7 +63,7 @@ BuildRequires:        pam-devel
 BuildRequires: pcre-devel
 BuildRequires: perl-devel >= 1:5.6.0
 BuildRequires: readline-devel
-BuildRequires: rpmbuild(macros) >= 1.159
+BuildRequires: rpmbuild(macros) >= 1.176
 BuildRequires: texinfo
 PreReq:                rc-scripts
 Requires(pre): /bin/id
@@ -153,8 +149,6 @@ desta interface.
 %patch2 -p0
 %patch3 -p1
 %patch4 -p1
-%patch5 -p0
-%{?with_exiscan:test -f %{SOURCE8} || exit 1; bzip2 -d -c %{SOURCE8} | patch -p1 || exit 1}
 %{?with_saexim:test -f %{SOURCE17} || exit 1; gzip -d -c %{SOURCE17} | tar -x || exit 1}
 
 install %{SOURCE13} doc/FAQ.txt.bz2
@@ -177,10 +171,10 @@ cp -f exim_monitor/EDITME Local/eximon.conf
 
 %{__make} -j1 \
        CC="%{__cc}" \
-       CFLAGS="%{rpmcflags} %{?with_spf:-DSPF} %{?with_srs:-DSRS}" \
+       CFLAGS="%{rpmcflags} %{?with_spf:-DEXPERIMENTAL_SPF=yes} %{?with_srs:-DEXPERIMENTAL_SRS=yes}" \
        LOOKUP_CDB=yes \
-XLFLAGS=-L%{_prefix}/X11R6/%{_lib} \
-X11_LD_LIB=%{_prefix}/X11R6/%{_lib} \
+       XLFLAGS=-L%{_prefix}/X11R6/%{_lib} \
+       X11_LD_LIB=%{_prefix}/X11R6/%{_lib} \
        %{?with_mysql:LOOKUP_MYSQL=yes} \
        %{?with_pgsql:LOOKUP_PGSQL=yes} \
        %{?with_whoson:LOOKUP_WHOSON=yes} \
@@ -197,25 +191,25 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}/mail
 install -d $RPM_BUILD_ROOT/etc/{cron.{daily,weekly},logrotate.d,rc.d/init.d,sysconfig,pam.d}
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man8,/usr/lib}
 install -d $RPM_BUILD_ROOT%{_var}/{spool/exim/{db,input,msglog},log/{archiv,}/exim,mail}
-install -d $RPM_BUILD_ROOT{%{_infodir},%{_prefix}/X11R6/bin,%{_desktopdir},%{_pixmapsdir}}
+install -d $RPM_BUILD_ROOT{%{_infodir},%{_desktopdir},%{_pixmapsdir}}
 
 install build-Linux-*/exim{,_fixdb,_tidydb,_dbmbuild,on.bin,_dumpdb,_lock} \
        build-Linux-*/exi{cyclog,next,what} %{SOURCE10} \
        build-Linux-*/{exigrep,eximstats,exiqsumm,convert4r4} \
        util/unknownuser.sh \
        $RPM_BUILD_ROOT%{_bindir}
-install build-Linux-*/eximon.bin $RPM_BUILD_ROOT%{_prefix}/X11R6/bin
-install build-Linux-*/eximon $RPM_BUILD_ROOT%{_prefix}/X11R6/bin
+install build-Linux-*/eximon.bin $RPM_BUILD_ROOT%{_bindir}
+install build-Linux-*/eximon $RPM_BUILD_ROOT%{_bindir}
 
 install %{SOURCE5} .
-install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.weekly/
+install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.weekly
 install %{SOURCE12} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 install        %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mail/exim.conf
-install {doc,man}/*.8 $RPM_BUILD_ROOT%{_mandir}/man8/
+install {doc,man}/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
 install %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
-install        *.info* $RPM_BUILD_ROOT%{_infodir}/
+install        *.info* $RPM_BUILD_ROOT%{_infodir}
 install %{SOURCE15} $RPM_BUILD_ROOT/etc/pam.d/smtp
 
 %{?with_saexim:install sa-exim-%{saexim_version}/sa-exim.conf $RPM_BUILD_ROOT/%{_sysconfdir}/mail/sa-exim.conf}
@@ -238,7 +232,7 @@ rm -rf $RPM_BUILD_ROOT
 %pre
 if [ -n "`/usr/bin/getgid exim`" ]; then
        if [ "`/usr/bin/getgid exim`" != 79 ]; then
-               echo "Warning: group exim haven't gid=79. Correct this before installing exim" 1>&2
+               echo "Warning: group exim doesn't have gid=79. Correct this before installing exim" 1>&2
                exit 1
        fi
 else
@@ -261,7 +255,9 @@ umask 022
 if [ -f /var/lock/subsys/exim ]; then
        /etc/rc.d/init.d/%{name} restart >&2
 else
-       echo "Run \"/etc/rc.d/init.d/%{name} start\" to start exim daemon."
+       %banner %{name} -e <<EOF
+Run \"/etc/rc.d/init.d/%{name} start\" to start exim daemon.
+EOF
 fi
 
 if [ ! -f /etc/mail/mailname ]; then
@@ -295,13 +291,13 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc README* NOTICE LICENCE analyse-log-errors doc/{ChangeLog,NewStuff,dbm.discuss.txt,filter.txt,spec.txt,Exim*.upgrade,OptionLists.txt%{?with_exiscan:,exiscan-*.txt}} build-Linux-*/transport-filter.pl
+%doc README* NOTICE LICENCE analyse-log-errors doc/{ChangeLog,NewStuff,dbm.discuss.txt,filter.txt,spec.txt,Exim*.upgrade,OptionLists.txt,experimental-spec.txt} build-Linux-*/transport-filter.pl
 %dir %{_sysconfdir}/mail
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/exim.conf
-%{?with_saexim:%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/sa-exim.conf}
-%attr(644,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mail/aliases
-%attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/exim
-%attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/exim
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/exim.conf
+%{?with_saexim:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/sa-exim.conf}
+%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
+%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/exim
+%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/exim
 %attr(754,root,root) /etc/rc.d/init.d/exim
 %attr(4755,root,root) %{_bindir}/exim
 %attr(770,root,exim) %dir %{_var}/spool/exim
@@ -328,12 +324,13 @@ fi
 %attr(750,exim,root) %dir %{_var}/log/exim
 %attr(750,exim,root) %dir %{_var}/log/archiv/exim
 %attr(640,exim,root) %ghost %{_var}/log/exim/*
-%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/smtp
-%{_infodir}/*
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
+%{_infodir}/*.info*
 %{_mandir}/man8/*
 
 %files X11
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_prefix}/X11R6/bin/*
-%{_desktopdir}/%{name}on.desktop
-%{_pixmapsdir}/%{name}on.png
+%attr(755,root,root) %{_bindir}/eximon
+%attr(755,root,root) %{_bindir}/eximon.bin
+%{_desktopdir}/eximon.desktop
+%{_pixmapsdir}/eximon.png
This page took 0.097394 seconds and 4 git commands to generate.