]> git.pld-linux.org Git - packages/exact-image.git/blobdiff - exact-image.spec
- release 10 (by relup.sh)
[packages/exact-image.git] / exact-image.spec
index 42a08c147df73b1e2e951c0360c32b40bfa56877..6b809663ce2ec3326d368fc98ba6f65c5b68b37d 100644 (file)
@@ -1,24 +1,21 @@
-# TODO: php, ruby (when ready)
+# TODO: ruby (when ready)
 #
 # Conditional build:
 %bcond_without evas    # Edisplay support
 %bcond_without gif     # GIF support
 %bcond_without lua     # Lua API
 %bcond_without perl    # Perl API
-%bcond_with    php     # PHP API
+%bcond_without php     # PHP API
 %bcond_without python  # Python API
 %bcond_with    ruby    # Ruby API [not finished as of 0.8.9]
 
-%ifarch %{x8664}
-%undefine      with_lua
-%undefine      with_perl
-%undefine      with_python
-%endif
+%define                php_name        php%{?php_suffix}
+%include       /usr/lib/rpm/macros.perl
 Summary:       A fast, modern and generic image processing library
 Summary(pl.UTF-8):     Szybka, nowoczesna i ogólna biblioteka do przetwarzania obrazu
 Name:          exact-image
 Version:       0.8.9
-Release:       2
+Release:       10
 License:       GPL v2
 Group:         Applications/Graphics
 Source0:       http://dl.exactcode.de/oss/exact-image/%{name}-%{version}.tar.bz2
@@ -28,6 +25,7 @@ Patch1:               exactimage_0.8.5-1.patch
 Patch2:                %{name}-giflib.patch
 Patch3:                %{name}-evas.patch
 Patch4:                %{name}-install.patch
+Patch5:                swig.patch
 URL:           http://www.exactcode.de/site/open_source/exactimage/
 BuildRequires: OpenEXR-devel >= 1.2.0
 BuildRequires: agg-devel >= 2.3
@@ -44,9 +42,11 @@ BuildRequires:       libstdc++-devel
 BuildRequires: libtiff-devel
 %{?with_lua:BuildRequires:     lua51-devel >= 5.1}
 BuildRequires: perl-devel >= 1:5.8.0
-%{?with_php:BuildRequires:     php-devel >= 5.2.0}
+%{?with_php:BuildRequires:     %{php_name}-devel >= 5.2.0}
 BuildRequires: pkgconfig
 %{?with_python:BuildRequires:  python-devel >= 1:2.5.0}
+BuildRequires: rpm-perlprov
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.219
 %{?with_ruby:BuildRequires:    ruby-devel >= 1.8.5}
 %{?with_perl:BuildRequires:    swig-perl >= 1.3.32}
@@ -88,6 +88,18 @@ ExactImage API for Perl.
 %description -n perl-ExactImage -l pl.UTF-8
 API ExactImage dla Perla.
 
+%package -n %{php_name}-ExactImage
+Summary:       ExactImage API for PHP
+Summary(pl.UTF-8):     API ExactImage dla PHP
+Group:         Development/Languages/Perl
+%{?requires_php_extension}
+
+%description -n %{php_name}-ExactImage
+ExactImage API for PHP.
+
+%description -n %{php_name}-ExactImage -l pl.UTF-8
+API ExactImage dla PHP.
+
 %package -n python-ExactImage
 Summary:       ExactImage API for Python
 Summary(pl.UTF-8):     API ExactImage dla Pythona
@@ -106,6 +118,7 @@ API ExactImage dla Pythona.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 ./configure \
@@ -118,6 +131,8 @@ API ExactImage dla Pythona.
        %{!?with_python:--without-python}
 
 %{__make} \
+       CC="%{__cc}" \
+       CXX="%{__cxx}" \
        CFLAGS="%{rpmcflags}" \
        CXXFLAGS="%{rpmcflags}" \
        Q=
@@ -128,7 +143,7 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        PERL_INSTALLDIR=%{perl_vendorarch} \
-       PHP_INSTALLDIR=%{_libdir}/php \
+       PHP_INSTALLDIR=%{php_extensiondir} \
        PYTHON_LIBDIR=%{py_sitedir} \
        api/lua/libdir=%{_libdir}/lua \
        Q=
@@ -167,6 +182,13 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_vendorarch}/ExactImage.pm
 %endif
 
+%if %{with php}
+%files -n %{php_name}-ExactImage
+%defattr(644,root,root,755)
+%attr(755,root,root) %{php_extensiondir}/ExactImage.so
+%{php_extensiondir}/ExactImage.php
+%endif
+
 %if %{with python}
 %files -n python-ExactImage
 %defattr(644,root,root,755)
This page took 0.265377 seconds and 4 git commands to generate.