]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
Use relative symlink for webapp config dir
[packages/eventum.git] / eventum.spec
index 5854e01fbcbf0c9eda1dd3ad914b164ab9f5bc28..f12a825fd933fc4a06b152a081a8f9256b39ce8e 100644 (file)
@@ -3,18 +3,18 @@
 %bcond_with    order   # with experimental order patch
 
 %define                rel             1
-#define                subver  26
-#define                githash 89d9eb0f0
-%define                php_min_version 7.1.3
+#define                subver  37
+#define                githash 2276dac77
+%define                php_min_version 7.2.5
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       3.8.4
+Version:       3.9.11
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2+
 Group:         Applications/WWW
 Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: ae0bc49ff54d9b7e170ef0e9cc50dc78
+# Source0-md5: 43ee83c85b1303ebe5bad5df8bd1f75e
 #Source0:      https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
@@ -85,6 +85,7 @@ Conflicts:    logrotate < 3.8.0
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _noautoreq_pear .*
 %define                _libdir         %{_prefix}/lib/%{name}
 %define                _appdir         %{_datadir}/%{name}
 %define                _smartydir      %{php_data_dir}/Smarty
@@ -238,8 +239,6 @@ Summary(pl.UTF-8):  Przekazywanie poczty Eventum - Postfix
 Group:         Applications/Mail
 Requires:      %{name} = %{version}-%{release}
 Requires:      postfix
-Provides:      eventum(router)
-Obsoletes:     eventum(router)
 
 %description router-postfix
 This package provides way of routing notes and emails back to Eventum
@@ -302,7 +301,6 @@ rm config/config.php
 %patch108 -p1
 
 rm htdocs/.htaccess.dist
-rm config/config.dist.php
 
 # cleanup libs taken from system, everything else gets bundled
 rm -r vendor/fonts/liberation
@@ -313,6 +311,8 @@ rm -r vendor/smarty-gettext/smarty-gettext
 rm -r vendor/smarty/smarty
 rm -r vendor/sphinx/php-sphinxapi
 
+%{__sed} -i '1s|^#!.*php\b|#!/usr/bin/php|' config/sphinx.conf.php bin/*.php
+
 # remove backups from patching as we use globs to package files to buildroot
 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
 
@@ -324,7 +324,7 @@ rm -rf $RPM_BUILD_ROOT
 install -d \
        $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
        $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
-       $RPM_BUILD_ROOT/var/{run,lib}/%{name} \
+       $RPM_BUILD_ROOT/var/{run,lib,spool}/%{name} \
        $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
        $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
        $RPM_BUILD_ROOT/var/cache/%{name}/doctrine/proxies \
@@ -335,7 +335,7 @@ install -d \
        localedir=%{_localedir} \
        DESTDIR=$RPM_BUILD_ROOT
 
-ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
+ln -s --relative $RPM_BUILD_ROOT{%{_webappdir},%{_appdir}/config}
 
 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
 
@@ -392,22 +392,16 @@ for a in \
 done
 
 # run database update if configured
-test -s %{_webappdir}/config.php && \
+test -s %{_webappdir}/setup.php && \
 sudo -H -u http -- %{_appdir}/bin/upgrade.php || :
 
 # nuke Smarty templates cache after upgrade
-rm -f /var/cache/eventum/*.php
+rm -f /var/cache/eventum/smarty/*.php
 
 # Restart webserver on upgrade to get .mo translations reloaded.
 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
 %php_webserver_restart
 
-%preun
-if [ "$1" = "0" ]; then
-       # nuke cache
-       rm -f /var/cache/eventum/*.php 2>/dev/null || :
-fi
-
 %postun
 if [ "$1" = "0" ]; then
        %userremove %{name}
@@ -415,13 +409,13 @@ if [ "$1" = "0" ]; then
 fi
 
 %post setup
-chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
-chown root:http %{_webappdir}/{config,private_key,secret_key}.php
+chmod 660 %{_webappdir}/{setup,private_key,secret_key}.php
+chown root:http %{_webappdir}/{setup,private_key,secret_key}.php
 
 %postun setup
-if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
-       chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
-       chown root:http %{_webappdir}/{config,private_key,secret_key}.php
+if [ "$1" = "0" ] && [ -f %{_webappdir}/setup.php ]; then
+       chmod 640 %{_webappdir}/{setup,private_key,secret_key}.php
+       chown root:http %{_webappdir}/{setup,private_key,secret_key}.php
 fi
 
 %triggerin -- apache1 < 1.3.37-3, apache1-base
@@ -449,7 +443,6 @@ fi
 %attr(751,root,http) %dir %{_webappdir}/custom_field
 %attr(751,root,http) %dir %{_webappdir}/partner
 %attr(751,root,http) %dir %{_webappdir}/templates
-%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
@@ -467,30 +460,35 @@ fi
 %{_appdir}/config
 
 %dir %{_appdir}/bin
+%attr(755,root,root) %{_appdir}/bin/check_reminders.php
 %attr(755,root,root) %{_appdir}/bin/console.php
+%attr(755,root,root) %{_appdir}/bin/download_emails.php
 %attr(755,root,root) %{_appdir}/bin/export-issues.php
 %attr(755,root,root) %{_appdir}/bin/extension.php
 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
 %attr(755,root,root) %{_appdir}/bin/migrate_storage_adapter.php
+%attr(755,root,root) %{_appdir}/bin/monitor.php
 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
+%attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
+%attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
 %attr(755,root,root) %{_appdir}/bin/upgrade.php
 
 %{_appdir}/autoload.php
-%{_appdir}/globals.php
 %{_appdir}/init.php
 %{_appdir}/phinx.php
 %dir %{_appdir}/htdocs
 %{_appdir}/htdocs/*.php
 %{_appdir}/htdocs/*.ico
+%{_appdir}/htdocs/mix-manifest.json
 %{_appdir}/htdocs/ajax
 %{_appdir}/htdocs/css
 %{_appdir}/htdocs/customer
+%{_appdir}/htdocs/fonts
 %{_appdir}/htdocs/images
 %{_appdir}/htdocs/js
 %{_appdir}/htdocs/manage
 %{_appdir}/htdocs/reports
 %{_appdir}/htdocs/rpc
-%{_appdir}/htdocs/components
 %{_appdir}/templates
 
 %dir %{_appdir}/db
@@ -504,11 +502,6 @@ fi
 %{_appdir}/vendor
 %dir %{_appdir}/lib
 %{_appdir}/lib/eventum
-%exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
-%exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
-%exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
-%exclude %{_appdir}/src/Console/Command/MonitorCommand.php
-%exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
 
 %dir %{_libdir}
 
@@ -516,6 +509,7 @@ fi
 
 %dir /var/lib/%{name}
 %dir %attr(730,root,http) /var/run/%{name}
+%dir %attr(730,root,http) /var/spool/%{name}
 %dir %attr(730,root,http) /var/cache/%{name}
 %dir %attr(730,root,http) /var/cache/%{name}/doctrine
 %dir %attr(730,root,http) /var/cache/%{name}/doctrine/proxies
@@ -538,28 +532,18 @@ fi
 
 %files mail-queue
 %defattr(644,root,root,755)
-%{_appdir}/src/Console/Command/MailQueueProcessCommand.php
-%{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
-%attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
-%attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
 
 %files mail-download
 %defattr(644,root,root,755)
-%{_appdir}/src/Console/Command/MailDownloadCommand.php
-%attr(755,root,root) %{_appdir}/bin/download_emails.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
 
 %files reminder
 %defattr(644,root,root,755)
-%{_appdir}/src/Console/Command/ReminderCheckCommand.php
-%attr(755,root,root) %{_appdir}/bin/check_reminders.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
 
 %files monitor
 %defattr(644,root,root,755)
-%{_appdir}/src/Console/Command/MonitorCommand.php
-%attr(755,root,root) %{_appdir}/bin/monitor.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
 
 %files router-postfix
This page took 0.04122 seconds and 4 git commands to generate.