]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
- pl for -base
[packages/eventum.git] / eventum.spec
index 09eeb77cfc27a9a6d5a39e31b03698e81b294df0..e15689c588754f53bb5791c4dee0ba7617d5dfd2 100644 (file)
@@ -1,20 +1,17 @@
 # TODO
-# - where to put templates_c (templates cache dir)? /var/run/eventum? /var/run/php/eventum? /var/cache/eventum?
 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
 # - discard bundled packages (from INSTALL):
 #  - JpGraph 1.5.3 (last GPL version)
-#  - PEAR packages
 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
 #  - A few other small javascript libraries
-# - Command-line Interface (misc/cli/eventum)
 # - create eventum-router-qmail, eventum-router-postfix for -route-mails and -route-notes
 # - need start-stop-daemon (from dpkg for now)
 # - use eventum user for irc bot?
 
 # snapshot: DATE
-#define _snap 20050117
+#define _snap 20050124
 
 %if 0%{?_snap}
 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
@@ -22,7 +19,7 @@
 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
 %endif
 
-%define _rel 1.93
+%define _rel 1.129
 
 Summary:       Eventum Issue - a bug tracking system
 Summary(pl):   Eventum - system ¶ledzenia spraw/b³êdów
@@ -41,11 +38,15 @@ Source5:    %{name}-monitor.cron
 Source6:       %{name}-cvs.php
 Source7:       %{name}-irc.php
 Source8:       %{name}-irc.init
+# packaging
 Patch0:                %{name}-paths.patch
-Patch1:                %{name}-clock-status.patch
-Patch2:                %{name}-scm-encode.patch
-Patch3:                %{name}-cvs-config.patch
-Patch4:                %{name}-irc-config.patch
+Patch1:                %{name}-scm-encode.patch
+Patch2:                %{name}-cvs-config.patch
+Patch3:                %{name}-irc-config.patch
+# bug fixes
+Patch10:               %{name}-clock-status.patch
+Patch11:               %{name}-scm_checkin_associated.patch
+Patch12:               %{name}-mail-queue.tpl.patch
 URL:           http://dev.mysql.com/downloads/other/eventum/index.html
 BuildRequires: rpmbuild(macros) >= 1.177
 BuildRequires: sed >= 4.0
@@ -55,6 +56,23 @@ Requires:    php-imap
 Requires:      php-mysql
 Requires:      php-pcre
 Requires:      Smarty >= 2.6.2
+Requires:      %{name}-base = %{epoch}:%{version}-%{release}
+Requires:      php-pear-Benchmark
+Requires:      php-pear-DB
+Requires:      php-pear-Date
+Requires:      php-pear-HTTP_Request
+Requires:      php-pear-Mail
+Requires:      php-pear-Math_Stats
+Requires:      php-pear-Net_DIME
+Requires:      php-pear-Net_POP3
+Requires:      php-pear-Net_SMTP
+Requires:      php-pear-Net_SmartIRC
+Requires:      php-pear-Net_Socket
+Requires:      php-pear-Net_URL
+Requires:      php-pear-Net_UserAgent_Detect
+Requires:      php-pear-PEAR
+Requires:      php-pear-Text_Diff
+Requires:      php-pear-XML_RPC
 #Requires:     apache-mod_dir
 # conflict with non-confdir apache
 Conflicts:     apache1 < 1.3.33-1.1
@@ -82,6 +100,17 @@ szybkiej organizacji zada
 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
 reakcji.
 
+%package base
+Summary:       Eventum base package
+Summary(pl):   Podstawowy pakiet Eventum
+Group:         Applications/WWW
+
+%description base
+This package contains base directory structure for Eventum.
+
+%description base -l pl
+Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
+
 %package setup
 Summary:       Eventum setup package
 Summary(pl):   Pakiet do wstêpnej konfiguracji Eventum
@@ -262,7 +291,8 @@ Summary:    Eventum IRC Notification Bot
 Summary(pl):   IRC-owy bot powiadamiaj±cy dla Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php4 >= 4.1.0
+Requires:      php >= 4.1.0
+Requires:      php-sockets
 # FIXME just need start-stop-daemon
 Requires:      dpkg
 
@@ -298,7 +328,8 @@ Requires:   %{name} = %{epoch}:%{version}-%{release}
 Requires:      php4 >= 4.1.0
 Requires:      php4-cli
 Requires:      php4-curl
-#Requires:     php4-openssl
+Requires:      php4-xml
+Requires:      php-pear-XML_RPC
 
 %description cli
 The Eventum command-line interface allows you to access most of the
@@ -312,7 +343,7 @@ funkcji interfejsu WWW prosto z linii polece
 Summary:       Eventum SCM integration
 Summary(pl):   Integracja SCM dla Eventum
 Group:         Applications/WWW
-Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      %{name}-base = %{epoch}:%{version}-%{release}
 Requires:      php4 >= 4.1.0
 
 %description scm
@@ -342,14 +373,18 @@ Szczeg
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 
-%build
+%patch10 -p1
+%patch11 -p1
+%patch12 -p1
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},/etc/{rc.d/init.d,cron.d},%{_appdir}/{locks,templates_c},/var/log}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_appdir}} \
+       $RPM_BUILD_ROOT{/etc/{rc.d/init.d,cron.d},/var/log} \
+       $RPM_BUILD_ROOT{/var/run/eventum,/var/cache/eventum}
 
+rm -f eventumrc %{name}-scm
 cp -a . $RPM_BUILD_ROOT%{_appdir}
 # argsh! say no words
 find $RPM_BUILD_ROOT%{_appdir} -type f -print0 | xargs -0 sed -i -e 's,
@@ -360,6 +395,8 @@ $,,' misc/cli/eventumrc_example > eventumrc
 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
 
 sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
+echo '#!/usr/bin/php4 -q' > %{name}-scm
+cat $RPM_BUILD_ROOT%{_appdir}/misc/scm/process_cvs_commits.php >> %{name}-scm
 
 # change private key, so we can easily grep
 sed -i -e '
@@ -399,9 +436,14 @@ install -d $RPM_BUILD_ROOT%{_smartyplugindir}
 # These plugins are not in Smarty package (Smarty-2.6.2-3)
 cp -a include/Smarty/plugins/function.{calendar,get_display_style,get_innerhtml,get_textarea_size}.php $RPM_BUILD_ROOT%{_smartyplugindir}
 
-# in _bindir
+# in bindir
 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum $RPM_BUILD_ROOT%{_bindir}
-rm -f $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventumrc_example
+rm -f $RPM_BUILD_ROOT%{_appdir}/misc/{cli/eventumrc_example,scm/process_cvs_commits.php}
+install %{name}-scm $RPM_BUILD_ROOT%{_bindir}/%{name}-scm
+
+# provided by PEAR
+rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/cli/include/pear
+rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -490,18 +532,19 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade docs/* rpc/xmlrpc_client.php
-%attr(751,root,root) %dir %{_sysconfdir}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
 
+%dir %{_appdir}
+%dir %{_appdir}/misc
+
 %dir %attr(731,root,http) /var/log/%{name}
 %attr(620,root,http) %ghost /var/log/%{name}/*
 
 %{_smartyplugindir}/*
 
-%dir %{_appdir}
 %{_appdir}/*.php
 %{_appdir}/css
 %{_appdir}/customer
@@ -512,20 +555,21 @@ fi
 %{_appdir}/rpc
 %{_appdir}/templates
 
-%dir %attr(730,root,http) %{_appdir}/locks
-
 %dir %{_appdir}/include
 %{_appdir}/include/customer
 %{_appdir}/include/jpgraph
-%{_appdir}/include/pear
 %{_appdir}/include/workflow
 %{_appdir}/include/*.php
 
-%dir %attr(730,root,http) %{_appdir}/templates_c
+%dir %attr(730,root,http) /var/run/%{name}
+%dir %attr(730,root,http) /var/cache/%{name}
 
-%dir %{_appdir}/misc
 %{_appdir}/misc/blank.html
 
+%files base
+%defattr(644,root,root,755)
+%attr(751,root,root) %dir %{_sysconfdir}
+
 %files setup
 %defattr(644,root,root,755)
 %{_appdir}/setup
@@ -569,12 +613,12 @@ fi
 %defattr(644,root,root,755)
 %doc eventumrc
 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.php
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/%{name}
 %dir %{_appdir}/misc/cli
 %{_appdir}/misc/cli/include
 
 %files scm
 %defattr(644,root,root,755)
 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
-%dir %{_appdir}/misc/scm
-%{_appdir}/misc/scm/process_cvs_commits.php
+# FIXME: not sure about this naming.
+%attr(755,root,root) %{_bindir}/%{name}-scm
This page took 0.049118 seconds and 4 git commands to generate.