]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
- eventum 1.6.0-RC2
[packages/eventum.git] / eventum.spec
index 03b911390803d0925e9acb4918c947e838f42642..883d0998cdbc329bea24a43918f12c8887d80a88 100644 (file)
 # TODO
-# - where to put templates_c (templates cache dir)? /var/run/eventum? /var/run/php/eventum? /var/cache/eventum?
+# - system pear is incompatible, at least pear DB class seems broke Eventum
 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
 # - discard bundled packages (from INSTALL):
 #  - JpGraph 1.5.3 (last GPL version)
-#  - Smarty 2.3.0 (http://smarty.php.net)
-#  - PEAR packages
 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
 #  - A few other small javascript libraries
-# - Reminder System (misc/check_reminders.php)
-# - Heartbeat Monitor (misc/monitor.php)
-# - Email Routing Script (misc/route_emails.php)
-# - Note Routing Script (misc/route_notes.php)
-# - IRC Notification Bot (misc/irc/bot.php)
-# - Command-line Interface (misc/cli/eventum)
-# - scm subpackage doesn't work (yet)
+# - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
+
+%bcond_with    pear    # build with system PEAR packages (or use bundled ones)
+%bcond_with    qmail   # build the router-qmail subpackage
 
 # snapshot: DATE
-#define _snap 20050117
+#define        _snap 20050227
+
+# release candidate
+%define _rc            RC2
+
+%define        _rel    6
 
 %if 0%{?_snap}
-%define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
+%if 0%{?_rc}
+%define        _source http://pessoal.org/%{name}-%{version}-%{_rc}.tar.gz
 %else
-%define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
+%define        _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
+%endif
+%else
+%define        _source http://mysql.dataphone.se/Downloads/%{name}/%{name}-%{version}.tar.gz
 %endif
 
-%define _rel 1.61
-
-Summary:       Eventum Issue / Bug Tracking System
+Summary:       Eventum Issue / Bug tracking system
 Summary(pl):   Eventum - system ¶ledzenia spraw/b³êdów
 Name:          eventum
-Version:       1.4
-Release:       %{?_snap:0.%{_snap}.}%{_rel}
+Version:       1.6.0
+Release:       %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
 License:       GPL
 Group:         Applications/WWW
 Source0:       %{_source}
-# Source0-md5: 361c1355e46a6bbfa54e420964ec92cf
+# Source0-md5: a13d95ff52264d7460c688419794ffcc
+%{?_snap:NoSource:     0}
 Source1:       %{name}-apache.conf
-Source2:       %{name}-mail-queue.sh
-Source3:       %{name}-mail-download.sh
-Patch0:                %{name}-rpm.patch
-Patch1:                %{name}-clock-status.patch
-URL:           http://dev.mysql.com/downloads/other/eventum/index.html
-BuildRequires: rpmbuild(macros) >= 1.177
+Source2:       %{name}-mail-queue.cron
+Source3:       %{name}-mail-download.cron
+Source4:       %{name}-reminder.cron
+Source5:       %{name}-monitor.cron
+Source6:       %{name}-cvs.php
+Source7:       %{name}-irc.php
+Source8:       %{name}-irc.init
+Source9:       %{name}-irc.sysconfig
+Source10:      %{name}-config.php
+Source11:      %{name}-router-qmail.sh
+Source12:      http://dev.mysql.com/common/favicon.ico
+# Source12-md5:        858be0130832da4144c08d4b59116411
+Source13:      %{name}-config-setup.php
+Source14:      %{name}-upgrade.sh
+Patch0:                %{name}-paths.patch
+Patch1:                %{name}-cvs-config.patch
+Patch2:                %{name}-irc-config.patch
+Patch3:                %{name}-PEAR.patch
+Patch4:                http://glen.alkohol.ee/pld/%{name}-reply-subject.patch
+Patch5:                %{name}-lf.patch
+Patch6:                http://glen.alkohol.ee/pld/%{name}-maq-subject.patch
+Patch7:                %{name}-bot-reconnect.patch
+Patch22:       eventum-cli-wr-separated.patch
+URL:           http://dev.mysql.com/downloads/other/eventum/
+BuildRequires: rpmbuild(macros) >= 1.223
 BuildRequires: sed >= 4.0
-Requires:      php >= 4.1.0
+Requires:      php >= 4.2.0
 Requires:      php-gd
 Requires:      php-imap
 Requires:      php-mysql
 Requires:      php-pcre
-#Requires:     apache-mod_dir
-# conflict with non-confdir apache
-Conflicts:     apache1 < 1.3.33-1.1
+Requires:      php-session
+Requires:      %{name}-base = %{epoch}:%{version}-%{release}
+Requires:      Smarty >= 2.6.2
+%if %{with pear}
+Requires:      php-pear-Benchmark
+Requires:      php-pear-DB
+Requires:      php-pear-Date
+Requires:      php-pear-HTTP_Request
+Requires:      php-pear-Mail
+Requires:      php-pear-Math_Stats
+Requires:      php-pear-Net_DIME
+Requires:      php-pear-Net_POP3
+Requires:      php-pear-Net_SMTP
+Requires:      php-pear-Net_SmartIRC
+Requires:      php-pear-Net_Socket
+Requires:      php-pear-Net_URL
+Requires:      php-pear-Net_UserAgent_Detect
+Requires:      php-pear-PEAR
+Requires:      php-pear-Text_Diff
+Requires:      php-pear-XML_RPC
+%endif
+Requires:      apache >= 1.3.33-2
+Requires:      apache(mod_dir)
+Requires(triggerpostun):       sed >= 4.0
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/%{name}
+%define                _libdir         %{_prefix}/lib/%{name}
 %define                _appdir %{_datadir}/%{name}
-
-%define                _apache1dir     /etc/apache
-%define                _apache2dir     /etc/httpd
+%define                _smartyplugindir        %{php_pear_dir}/Smarty/plugins
 
 %description
 Eventum is a user-friendly and flexible issue tracking system that can
@@ -76,6 +119,25 @@ szybkiej organizacji zada
 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
 reakcji.
 
+%package base
+Summary:       Eventum base package
+Summary(pl):   Podstawowy pakiet Eventum
+Group:         Applications/WWW
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/useradd
+Requires(pre): /usr/sbin/groupadd
+Requires(postun):      /usr/sbin/userdel
+Requires(postun):      /usr/sbin/groupdel
+Provides:      user(eventum)
+Provides:      group(eventum)
+
+%description base
+This package contains base directory structure for Eventum.
+
+%description base -l pl
+Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
+
 %package setup
 Summary:       Eventum setup package
 Summary(pl):   Pakiet do wstêpnej konfiguracji Eventum
@@ -93,12 +155,12 @@ pierwszej instalacji. Potem nale
 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
 
 %package mail-queue
-Summary:       Eventum Mail Queue Process
+Summary:       Eventum mail queue process
 Summary(pl):   Przetwarzanie kolejki poczty Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      crondaemon
-Requires:      php4 >= 4.1.0
+Requires:      php >= 4.1.0
 
 %description mail-queue
 Beginning with the first release of Eventum, emails are not directly
@@ -116,13 +178,15 @@ Je
 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
 nastêpnym razem.
 
+Ten pakiet zawiera zadanie dla crona.
+
 %package mail-download
-Summary:       Eventum Email Download
+Summary:       Eventum email download
 Summary(pl):   ¦ci±ganie poczty Eventum
 Group:         Applications/WWW
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      crondaemon
-Requires:      php4 >= 4.1.0
+Requires:      php >= 4.1.0
 
 %description mail-download
 In order for Eventum's email integration feature to work, you need to
@@ -137,12 +201,212 @@ cz
 
 Ten pakiet zawiera zadanie dla crona.
 
+%package reminder
+Summary:       Eventum Reminder System
+Summary(pl):   System przypominania dla Eventum
+Group:         Applications/WWW
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      php >= 4.1.0
+Requires:      crondaemon
+
+%description reminder
+The reminder system was designed with the objective as serving as a
+safe net for issues that need attention. Depending on what
+configuration you create, you may have several reminders (or alerts)
+be sent out whenever an issue needs attention, for whatever parameter
+you may deem necessary.
+
+This package contains the cron job.
+
+%description reminder -l pl
+System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
+bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
+konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
+przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
+uwa¿aæ za potrzebny.
+
+Ten pakiet zawiera zadanie dla crona.
+
+%package monitor
+Summary:       Eventum Heartbeat Monitor
+Summary(pl):   Monitor ¿ycia dla Eventum
+Group:         Applications/WWW
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      php >= 4.1.0
+Requires:      php-posix
+Requires:      crondaemon
+
+%description monitor
+The heartbeat monitor is a feature designed for the administrator that
+wants to be alerted whenever a common problem in Eventum is detected,
+like the database server not being available anymore, or maybe when
+the recommended permissions for certain configuration files are
+changed.
+
+Please note that before running the heartbeat monitor, you may need to
+customize some of the checks to be appropriate for your own system,
+particularly the permission and file checks on
+Monitor::checkConfiguration().
+
+This package contains the cron job.
+
+%description monitor -l pl
+Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
+chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
+Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
+do plików konfiguracyjnych.
+
+Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
+konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
+testów uprawnieñ i plików w Monitor::checkConfiguration().
+
+Ten pakiet zawiera zadanie dla crona.
+
+%package route-emails
+Summary:       Eventum Email Routing
+Summary(pl):   Przekazywanie poczty dla Eventum
+Group:         Applications/WWW
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      php >= 4.1.0
+Requires:      eventum(router)
+
+%description route-emails
+The email routing feature is used to automatically associate a thread
+of emails into an Eventum issue. By setting up qmail (or even postfix)
+to deliver emails sent to a specific address (usually
+issue-<number>@<domain>) to the above script, users are able to use
+their email clients to reply to emails coming from Eventum, and those
+replies will be automatically associated with the issue and
+broadcasted to the entire notification list.
+
+%description route-emails -l pl
+Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
+w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
+postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
+issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
+u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
+Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
+rozprowadzane do ca³ej listy og³oszeniowej.
+
+%package route-notes
+Summary:       Eventum Note Routing
+Summary(pl):   Przekazywanie notatek dla Eventum
+Group:         Applications/WWW
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      php >= 4.1.0
+Requires:      eventum(router)
+
+%description route-notes
+The note routing feature is used to automatically associate a thread
+of notes into an Eventum issue. By setting up qmail (or even postfix)
+to deliver emails sent to a specific address (usually
+note-<number>@<domain>) to the above script, users are able to use
+their email clients to reply to internal notes coming from Eventum,
+and those replies will be automatically associated with the issue and
+broadcasted to the notification list staff members.
+
+%description route-notes -l pl
+Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
+w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
+postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
+note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
+u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
+pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
+spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
+
+%package router-qmail
+Summary:       Eventum Mail Routing - qmail
+Summary(pl):   Przekazywanie poczty Eventum - qmail
+Group:         Applications/Mail
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      qmail >= 1.03
+Provides:      eventum(router)
+Obsoletes:     eventum(router)
+
+%description router-qmail
+This package provides way of routing notes and emails back to Eventum
+via qmail.
+
+%description router-qmail -l pl
+Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
+przez qmaila.
+
+%package router-postfix
+Summary:       Eventum Mail Routing - Postfix
+Summary(pl):   Przekazywanie poczty Eventum - Postfix
+Group:         Applications/Mail
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      postfix
+Provides:      eventum(router)
+Obsoletes:     eventum(router)
+
+%description router-postfix
+This package provides way of routing notes and emails back to Eventum
+via Postfix.
+
+%description router-postfix -l pl
+Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
+przez Postfiksa.
+
+%package irc
+Summary:       Eventum IRC Notification Bot
+Summary(pl):   IRC-owy bot powiadamiaj±cy dla Eventum
+Group:         Applications/WWW
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      php >= 4.1.0
+Requires:      php-sockets
+PreReq:                rc-scripts >= 0.4.0.18
+
+%description irc
+The IRC notification bot is a nice feature for remote teams that want
+to handle issues and want to have a quick and easy way to get simple
+notifications. Right now the bot notifies of the following actions:
+- New Issues
+- Blocked emails
+- Issues that got their assignment list changed
+
+NOTE: You will need to manually edit the bot.php script to set your
+appropriate preferences, like IRC server and channel that the bot
+should join.
+
+%description irc -l pl
+IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
+zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
+uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
+nastêpuj±cych zdarzeniach:
+- nowych sprawach
+- zablokowanych listach
+- sprawach, dla których zmieni³a siê lista powi±zañ
+
+UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
+kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
+
+%package cli
+Summary:       Eventum command-line interface
+Summary(pl):   Interfejs linii poleceñ dla Eventum
+Group:         Applications/WWW
+Requires:      %{name}-base = %{epoch}:%{version}-%{release}
+Requires:      php >= 4.1.0
+Requires:      php-cli
+Requires:      php-curl
+Requires:      php-xml
+Requires:      php-pear-XML_RPC
+
+%description cli
+The Eventum command-line interface allows you to access most of the
+features of the web interface straight from your command shell.
+
+%description cli -l pl
+Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
+funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
+
 %package scm
-Summary:       Eventum SCM Integration
+Summary:       Eventum SCM integration
 Summary(pl):   Integracja SCM dla Eventum
 Group:         Applications/WWW
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      php4 >= 4.1.0
+Requires:      %{name}-base = %{epoch}:%{version}-%{release}
+Requires:      php-cli >= 4.1.0
+Requires:      php-pcre
 
 %description scm
 This feature allows your software development teams to integrate your
@@ -152,7 +416,7 @@ The integration is implemented in such a way that it will be forward
 compatible with pretty much any SCM system, such as CVS.
 
 For installation see
-/eventum/help.php?topic=scm_integration_installation .
+</eventum/help.php?topic=scm_integration_installation>.
 
 %description scm -l pl
 Ten pakiet pozwala zespo³om programistów na integracjê systemu
@@ -163,82 +427,168 @@ Integracja jest zaimplementowana tak, aby by
 prawie ka¿dym systemem SCM, jak np. CVS.
 
 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
-/eventum/help.php?topic=scm_integration_installation .
+</eventum/help.php?topic=scm_integration_installation>.
 
 %prep
 %setup -q %{?_snap:-n %{name}-%{_snap}}
-%patch0 -p1
+# undos the source
+find . -type f -print0 | xargs -0 sed -i -e 's,
+$,,'
+
+rm -f setup.conf.php
+rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD
+
+# packaging
+%patch0 -p1 -b .paths
 %patch1 -p1
+%patch2 -p1
+%{?with_pear:%patch3 -p1 -b .PEAR}
+
+# bug fixes.
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch22 -p1
+
+# replace in remaining scripts config.inc.php to system one
+grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
+       s,include_once(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
+'
+sed -i -e '
+       s,include(".*config.inc.php"),include_once("%{_sysconfdir}/core.php"),
+' misc/download_emails.php
 
-%build
+grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
+       s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_sysconfdir}/private_key.php"),
+'
+find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/cron.d,%{_appdir}/{locks,templates_c},/var/log}
-
-cp -a . $RPM_BUILD_ROOT%{_appdir}
-
-> $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
-
-sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
-
+install -d \
+       $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir}} \
+       $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
+       $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
+       $RPM_BUILD_ROOT/var/lib/%{name}/routed_emails \
+       $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
+
+cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
+cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
+cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
+cp -a misc/irc $RPM_BUILD_ROOT%{_appdir}
+cp -a templates $RPM_BUILD_ROOT%{_appdir}
+cp -a include/{customer,jpgraph,pear,workflow} $RPM_BUILD_ROOT%{_appdir}/include
+cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
+cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
+cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
+
+install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
+install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
+install %{SOURCE14} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
+
+# cli
+install -d $RPM_BUILD_ROOT%{_appdir}/cli
+install misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
+install misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
+sed -e '1s,#!.*/bin/php,#!%{_bindir}/php4,' \
+       misc/cli/eventum > $RPM_BUILD_ROOT%{_bindir}/%{name}
+cp -f misc/cli/eventumrc_example eventumrc
+
+# scm
+echo '#!%{_bindir}/php4 -q' > %{name}-scm
+cat misc/scm/process_cvs_commits.php >> %{name}-scm
+install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
+
+# private key
+mv $RPM_BUILD_ROOT{%{_appdir}/include/private_key.php,%{_sysconfdir}}
 # change private key, so we can easily grep
 sed -i -e '
 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
-' $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
+' $RPM_BUILD_ROOT%{_sysconfdir}/private_key.php
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
+install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
+install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
+install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
+install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
+install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
+install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
+sed -e 's,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}},' \
+       %{SOURCE10} > $RPM_BUILD_ROOT%{_sysconfdir}/core.php
+
+# config
+> $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
+mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_sysconfdir}/config}.php
+
+# sample, not used in eventum
+rm -f $RPM_BUILD_ROOT%{_appdir}/htdocs/rpc/xmlrpc_client.php
+
+%if %{with pear}
+# provided by PEAR
+rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
+%endif
 
-# in conf
-mv $RPM_BUILD_ROOT%{_appdir}/{config.inc.php,setup.conf.php} $RPM_BUILD_ROOT%{_sysconfdir}
-ln -s %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}
-ln -s %{_sysconfdir}/setup.conf.php $RPM_BUILD_ROOT%{_appdir}
-mv $RPM_BUILD_ROOT%{_appdir}/include/private_key.php $RPM_BUILD_ROOT%{_sysconfdir}
-ln -s %{_sysconfdir}/private_key.php $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
-
-# log directory
-mv $RPM_BUILD_ROOT%{_appdir}/logs $RPM_BUILD_ROOT/var/log/%{name}
-ln -s /var/log/%{name} $RPM_BUILD_ROOT%{_appdir}/logs
-
-# in doc
-rm -f $RPM_BUILD_ROOT%{_appdir}/{COPYING,ChangeLog,FAQ,INSTALL,README,UPGRADE}
-rm -rf $RPM_BUILD_ROOT%{_appdir}/{docs,misc/upgrade}
+# use system Smarty
+rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
+install -d $RPM_BUILD_ROOT%{_smartyplugindir}
+# These plugins are not in Smarty package (Smarty-2.6.2-3)
+cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
+       $RPM_BUILD_ROOT%{_smartyplugindir}
+
+# qmail router
+%if %{with qmail}
+d=$RPM_BUILD_ROOT/var/lib/%{name}
+echo 'root' > $d/.qmail
+echo 'root' > $d/.qmail-default
+echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
+echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
+echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
+install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-# apache1
-if [ -f %{_apache1dir}/apache.conf ]; then
-       ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
-       if [ -f /var/lock/subsys/apache ]; then
-               /etc/rc.d/init.d/apache restart 1>&2
-       fi
-fi
-# apache2
-if [ -d %{_apache2dir}/httpd.conf ]; then
-       ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
-fi
+%pre
+%addusertogroup http %{name}
 
+%post
 # check if the package is configured.
-if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.inc.php; then
+if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
+if [ -f %{_appdir}/htdocs/setup/index.php ]; then
 %banner %{name} -e <<EOF
 
 You haven't yet configured Eventum!
+Please open in browser <http://localhost/eventum/>
+If you need access from elsewhere, you need to edit
+%{_sysconfdir}/apache.conf and restart apache.
 
-Install %{name}-setup and open up http://yourserver/eventum/
--- that will help you setup initial config.
+IMPORTANT: When You have configured Eventum, please uninstall the
+setup package, so that %{name}-setup is able to secure your Eventum
+installation.
 
-when have configured Eventum, please uninstall the setup package,
-so that %{name}-setup is able to secure your Eventum installation.
+EOF
+#' vim stupidity.
+else
+%banner %{name} -e <<EOF
+
+You haven't yet configured Eventum!
+
+To setup eventum, please install %{name}-setup and open in browser
+<http://localhost/eventum/>.
+If you need access from elsewhere, you need to edit
+%{_sysconfdir}/apache.conf and restart apache.
+
+IMPORTANT: When You have configured Eventum, please uninstall the
+setup package, so that %{name}-setup is able to secure your Eventum
+installation.
 
 EOF
 #' vim stupidity.
+fi
 
 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
 %banner %{name} -e <<EOF
@@ -261,96 +611,222 @@ so that %{name}-setup is able to secure your Eventum installation.
 EOF
 fi
 
+# nuke Smarty templates cache after upgrade
+rm -f /var/cache/eventum/*.php
 
 %preun
 if [ "$1" = "0" ]; then
-       # apache1
-       if [ -f %{_apache1dir}/apache.conf ]; then
-               rm -f %{_apache1dir}/conf.d/99_%{name}.conf
-               if [ -f /var/lock/subsys/apache ]; then
-                       /etc/rc.d/init.d/apache restart 1>&2
-               fi
-       fi
-       # apache2
-       if [ -d %{_apache2dir}/httpd.conf ]; then
-               rm -f %{_apache1dir}/httpd.conf/99_%{name}.conf
-               if [ -f /var/lock/subsys/httpd ]; then
-                       /etc/rc.d/init.d/httpd restart 1>&2
-               fi
-       fi
+       # nuke cache
+       rm -f /var/cache/eventum/*.php 2>/dev/null || :
+fi
+
+%pre base
+%groupadd -P %{name}-base -g 146 %{name}
+%useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
+
+%postun base
+if [ "$1" = "0" ]; then
+       %userremove %{name}
+       %groupremove %{name}
+fi
+
+%if %{with qmail}
+%post router-qmail
+CF=/etc/qmail/control/virtualdomains
+if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
+       FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_sysconfdir}/config.php 2>/dev/null)
+       [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
+       umask 022
+       echo "#${FQDN}:%{name}" >> $CF
+
+%banner %{name}-qmail -e <<EOF
+
+Added "#${FQDN}:%{name}" to $CF,
+Please verify that it is correct and restart qmail:
+# service qmail reload
+
+Consult qmail-send(8) for more information on virtualdomains.
+
+EOF
+fi
+
+%preun router-qmail
+if [ "$1" = "0" ]; then
+       sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
 fi
+%endif
 
 %post setup
-chmod 660 %{_sysconfdir}/{config.inc,private_key}.php
-chown root:http %{_sysconfdir}/{config.inc,private_key}.php
+chmod 660 %{_sysconfdir}/{config,private_key}.php
+chown root:eventum %{_sysconfdir}/{config,private_key}.php
 
 %postun setup
 if [ "$1" = "0" ]; then
-       chmod 640 %{_sysconfdir}/{config.inc,private_key}.php
-       chown root:http %{_sysconfdir}/{config.inc,private_key}.php
+       chmod 640 %{_sysconfdir}/{config,private_key}.php
+       chown root:eventum %{_sysconfdir}/{config,private_key}.php
 fi
 
+%triggerin -- apache1 >= 1.3.33-2
+%apache_config_install -v 1 -c %{_sysconfdir}/apache.conf
+
+%triggerun -- apache1 >= 1.3.33-2
+%apache_config_uninstall -v 1
+
+%triggerin -- apache >= 2.0.0
+%apache_config_install -v 2 -c %{_sysconfdir}/apache.conf
+
+%triggerun -- apache >= 2.0.0
+%apache_config_uninstall -v 2
+
+# FIXME
+# only one upgrade trigger is called if you're upgrading over two
+# versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
+# use common trigger (the highest version and rpmvercmp from poldek?)
+%triggerpostun -- eventum < 1.5.1-0.257
+%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
+database_changes.php Perform database changes
+EOF
+
+%triggerpostun -- eventum < 1.5.2-0.289
+%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
+database_changes.php Perform database changes
+set_priority_ranks.php Fix the ranking of priority values
+EOF
+
+%triggerpostun -- eventum < 1.5.3-0.291
+%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
+database_changes.php Perform database changes
+EOF
+
+%triggerpostun -- eventum < 1.5.4-1.12
+%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
+database_changes.php Perform database changes
+EOF
+
+%triggerpostun -- eventum < 1.6.0-RC2.6
+%{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
+database_changes.php Perform database changes
+upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
+EOF
+
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade docs/*
-%attr(751,root,root) %dir %{_sysconfdir}
+%doc ChangeLog FAQ INSTALL README UPGRADE
+%doc docs/* rpc/xmlrpc_client.php setup/schema.sql
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.inc.php
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
-%attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.conf.php
-
-%dir %attr(731,root,http) /var/log/%{name}
-%attr(620,root,http) %ghost /var/log/%{name}/*
+%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
+%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
+%attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
+%attr(640,root,eventum) %config %verify(not mtime) %{_sysconfdir}/core.php
+
+%dir %attr(731,root,eventum) /var/log/%{name}
+%attr(620,root,eventum) %ghost /var/log/%{name}/*
+
+%dir %{_appdir}/htdocs
+%{_appdir}/htdocs/*.php
+%{_appdir}/htdocs/*.ico
+%{_appdir}/htdocs/css
+%{_appdir}/htdocs/customer
+%{_appdir}/htdocs/images
+%{_appdir}/htdocs/js
+%{_appdir}/htdocs/manage
+%{_appdir}/htdocs/reports
+%{_appdir}/htdocs/rpc
+%{_appdir}/htdocs/misc
 
-%dir %{_appdir}
-%{_appdir}/*.php
-%{_appdir}/css
-%{_appdir}/customer
-%{_appdir}/images
-%{_appdir}/js
-%{_appdir}/logs
-%{_appdir}/manage
-%{_appdir}/reports
-%{_appdir}/rpc
 %{_appdir}/templates
+%dir %{_appdir}/upgrade
+%attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
+%{_appdir}/upgrade/[!u]*
 
-%dir %attr(730,root,http) %{_appdir}/locks
+%{_smartyplugindir}/*
+%if %{without pear}
+%{_appdir}/include/pear
+%endif
 
 %dir %{_appdir}/include
 %{_appdir}/include/customer
 %{_appdir}/include/jpgraph
-%{_appdir}/include/pear
-%{_appdir}/include/Smarty
 %{_appdir}/include/workflow
-%{_appdir}/include/*.php
+%{_appdir}/include/class.[!m]*.php
+%{_appdir}/include/class.mail.php
+%{_appdir}/include/class.mail_queue.php
+%{_appdir}/include/class.mime_helper.php
+%{_appdir}/include/class.misc.php
+%{_appdir}/include/db_access.php
 
-%dir %attr(730,root,http) %{_appdir}/templates_c
+%dir %attr(730,root,eventum) /var/run/%{name}
+%dir %attr(730,root,eventum) /var/cache/%{name}
 
-%dir %{_appdir}/misc
-%{_appdir}/misc/cli
-%{_appdir}/misc/irc
-%{_appdir}/misc/blank.html
-%{_appdir}/misc/check_reminders.php
-%{_appdir}/misc/monitor.php
-%{_appdir}/misc/route_drafts.php
-%{_appdir}/misc/route_emails.php
-%{_appdir}/misc/route_notes.php
+%files base
+%defattr(644,root,root,755)
+%attr(751,root,root) %dir %{_sysconfdir}
+%dir %{_libdir}
+%dir %{_appdir}
+# qmail will ignore user, if it's home directory is not owned
+%attr(750,eventum,eventum) %dir /var/lib/%{name}
+# for saved routed emails
+%attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
 
 %files setup
 %defattr(644,root,root,755)
-%{_appdir}/setup
+%{_appdir}/htdocs/setup
 
 %files mail-queue
 %defattr(644,root,root,755)
-%{_appdir}/misc/process_mail_queue.php
+%{_appdir}/process_mail_queue.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
 
 %files mail-download
 %defattr(644,root,root,755)
-%{_appdir}/misc/download_emails.php
+%{_appdir}/download_emails.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
 
+%files reminder
+%defattr(644,root,root,755)
+%{_appdir}/check_reminders.php
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
+
+%files monitor
+%defattr(644,root,root,755)
+%{_appdir}/include/class.monitor.php
+%{_appdir}/monitor.php
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
+
+%files route-emails
+%defattr(644,root,root,755)
+%{_appdir}/route_emails.php
+
+%files route-notes
+%defattr(644,root,root,755)
+%{_appdir}/route_drafts.php
+%{_appdir}/route_notes.php
+
+%if %{with qmail}
+%files router-qmail
+%defattr(644,root,root,755)
+%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
+%attr(755,root,root) %{_libdir}/router-qmail
+%endif
+
+%files router-postfix
+%defattr(644,root,root,755)
+
+%files irc
+%defattr(644,root,root,755)
+%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
+%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
+%{_appdir}/irc
+%attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
+
+%files cli
+%defattr(644,root,root,755)
+%doc eventumrc
+%attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
+%attr(755,root,root) %{_bindir}/%{name}
+%{_appdir}/cli
+
 %files scm
 %defattr(644,root,root,755)
-%dir %{_appdir}/misc/scm
-%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/misc/scm/process_cvs_commits.php
+%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
+%attr(755,root,root) %{_libdir}/scm
This page took 0.068224 seconds and 4 git commands to generate.