]> git.pld-linux.org Git - packages/epiphany.git/blobdiff - epiphany.spec
- fixes for xdg menu
[packages/epiphany.git] / epiphany.spec
index 8311db8e44f4b04d367ce127369e168cbd08fc6d..71344ea45bdad2c7a8224017ebb00fa84ab6effc 100644 (file)
@@ -1,40 +1,42 @@
 
-%define                minmozver       5:1.5
+%define                minmozver       5:1.7
 
 Summary:       Epiphany - gecko-based GNOME web browser
 Summary(es):   Epiphany - navigador Web de GNOME basado en gecko
 Summary(pl):   Epiphany - przegl±darka WWW dla GNOME
 Name:          epiphany
-Version:       1.0.6
-Release:       1
+Version:       1.2.6
+Release:       3
 License:       GPL
 Group:         X11/Applications/Networking
-Source0:       http://ftp.gnome.org/pub/gnome/sources/%{name}/1.0/%{name}-%{version}.tar.bz2
-# Source0-md5: eeb1c339aaf62d7f85a39c93c706b45d
-#Source0:      http://downloads.uk1.mozdev.org/rsync/%{name}/%{name}-%{version}.tar.gz
+Source0:       http://ftp.gnome.org/pub/gnome/sources/%{name}/1.2/%{name}-%{version}.tar.bz2
+# Source0-md5: 6dedf570ddb9106ecd6be624f009a35a
 Patch0:                %{name}-MOZILLA_FIVE_HOME.patch
-Patch1:                %{name}-tabsmenu.patch
-Patch2:                %{name}-first-tab.patch
+Patch1:                %{name}-first-tab.patch
+Patch2:                %{name}-locale-names.patch
+Patch3:                %{name}-desktop-name-entry.patch
 URL:           http://www.gnome.org/projects/epiphany/
-BuildRequires: GConf2-devel >= 2.4.0
-BuildRequires: ORBit2-devel >= 2.8.0
+BuildRequires: GConf2-devel
+BuildRequires: ORBit2-devel >= 1:2.10.0
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: gnome-common >= 2.4.0
-BuildRequires: gnome-vfs2-devel >= 2.4.0
-BuildRequires: gtk+2-devel >= 2.2.0
-BuildRequires: intltool
-BuildRequires: libbonoboui-devel >= 2.4.0
-BuildRequires: libglade2-devel >= 2.0.1
-BuildRequires: libgnomeui-devel >= 2.4.0
-BuildRequires: libtool
-BuildRequires: libxml2-devel >= 2.5.9
-BuildRequires: mozilla-embedded-devel >= %{minmozver}
-BuildRequires: nautilus-devel >= 2.4.0
+BuildRequires: gnome-vfs2-devel >= 2.6.0
+BuildRequires: gtk+2-devel >= 2:2.4.0
+BuildRequires: gtk-doc
+BuildRequires: intltool >= 0.29
+BuildRequires: libbonoboui-devel >= 2.6.0
+BuildRequires: libglade2-devel >= 1:2.3.6
+BuildRequires: libgnomeui-devel >= 2.6.0
+BuildRequires: libxml2-devel >=  2.6.6
+BuildRequires: mozilla-devel >= %{minmozver}
+BuildRequires: nautilus-devel >= 2.6.0
 BuildRequires: rpm-build >= 4.1-10
 BuildRequires: scrollkeeper
 Requires(post):        GConf2
 Requires(post):        scrollkeeper
+Requires:      gnome-icon-theme >= 1.2.0
+Requires:      gtk+2 >= 2:2.4.0
 Requires:      mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -56,9 +58,9 @@ Summary:      Epiphany header files
 Summary(es):   Ficheros de cabecera de Epiphany
 Summary(pl):   Pliki nag³ówkowe Epiphany
 Group:         X11/Applications/Networking
-Requires:      %{name} = %{version}
-Requires:      gtk+2-devel >= 2.2.0
-Requires:      libxml2-devel >= 2.5.9
+# doesn't require base
+Requires:      gtk+2-devel >= 2:2.4.0
+Requires:      libxml2-devel >= 2.6.6
 
 %description devel
 Epiphany header files for plugin development.
@@ -74,28 +76,28 @@ Pliki nag
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+
+mv po/{no,nb}.po
 
 %build
 rm -f acconfig.h
+cp /usr/share/automake/mkinstalldirs .
 glib-gettextize --copy --force
 intltoolize --copy --force
+gnome-doc-common --copy
 %{__libtoolize}
 %{__aclocal} -I %{_aclocaldir}/gnome2-macros
 %{__autoheader}
 %{__automake}
 %{__autoconf}
 
-# rebuild for new ORBit2
-cd idl
-orbit-idl-2 -I/usr/share/idl -I/usr/share/idl/bonobo-2.0 \
-       -I/usr/share/idl/bonobo-activation-2.0 EphyAutomation.idl
-mv -f *.h *.c ../src
-cd ..
-
 %configure \
        --disable-schemas-install \
        --enable-nautilus-view=yes \
-       --with-mozilla-snapshot=1.5
+       --enable-gtk-doc \
+       --with-mozilla-snapshot=branch1.7 \
+       --with-html-dir=%{_gtkdocdir}
 
 # CFLAGS is a hack for gcc 3.3
 %{__make} \
@@ -103,10 +105,11 @@ cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
+install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       HTML_DIR=%{_gtkdocdir}
 
 # epiphany-2.0.mo, but gnome/help/epiphany
 %find_lang %{name}-2.0 --with-gnome --all-name
@@ -135,5 +138,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%{_includedir}/epiphany-1.0
+%{_includedir}/epiphany-1.2
 %{_pkgconfigdir}/*.pc
+%{_gtkdocdir}/*
This page took 0.042542 seconds and 4 git commands to generate.