]> git.pld-linux.org Git - packages/dtc.git/blobdiff - dtc.spec
- versioned Obsoletes
[packages/dtc.git] / dtc.spec
index 2185ed3a7c66f3c4d3fe0e4fb7c29e25cf4b87fa..85b775011ecf66edeea7c01425f9488e2ec2b20b 100644 (file)
--- a/dtc.spec
+++ b/dtc.spec
@@ -1,31 +1,52 @@
 #
 # Conditional build:
-%bcond_without python          # Python module
+%bcond_without python          # Python module (any)
+%bcond_without python2         # CPython 2.x module
+%bcond_without python3         # CPython 3.x module
 %bcond_without verbose         # verbose build (V=1)
 
+%if %{without python}
+%undefine      with_python2
+%undefine      with_python3
+%endif
 Summary:       The Device Tree Compiler
 Summary(pl.UTF-8):     Kompilator drzewiastej struktury urządzeń
 Name:          dtc
-Version:       1.5.0
+Version:       1.7.0
 Release:       1
 License:       GPL v2+ (dtc), GPL v2+ or BSD (fdt library)
 Group:         Libraries
 Source0:       https://www.kernel.org/pub/software/utils/dtc/%{name}-%{version}.tar.xz
-# Source0-md5: 1e7f54238d991b81c54fb5aabf71ff23
+# Source0-md5: 228576aceed3aa89f54283aa0f1eb820
 Patch0:                %{name}-python.patch
-URL:           http://www.devicetree.org/Device_Tree_Compiler
+Patch1:                python2.patch
+URL:           https://www.devicetree.org/
 BuildRequires: bison
 BuildRequires: flex
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.714
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
+BuildRequires: yaml-devel
 %if %{with python}
+%if %{with python2}
 BuildRequires: python-devel >= 2
-BuildRequires: swig-python
+BuildRequires: python-setuptools
+BuildRequires: python-setuptools_scm
+%endif
+%if %{with python3}
+BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+%endif
+BuildRequires: swig-python >= 2.0.10
 %endif
 Requires:      libfdt = %{version}-%{release}
 Obsoletes:     dtc-doc < 1.3.0-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                abi_ver %{version}
+
 %{?debug:%define with_verbose 1}
 
 %description
@@ -61,7 +82,7 @@ Summary(pl.UTF-8):    Pliki nagłówkowe biblioteki fdt
 License:       GPL v2+ or BSD
 Group:         Development/Libraries
 Requires:      libfdt = %{version}-%{release}
-Obsoletes:     dtc-devel
+Obsoletes:     dtc-devel < 1.3.0
 Obsoletes:     dtc-doc < 1.3.0-2
 
 %description -n libfdt-devel
@@ -76,7 +97,7 @@ Summary(pl.UTF-8):    Statyczna biblioteka fdt
 License:       GPL v2+ or BSD
 Group:         Development/Libraries
 Requires:      libfdt-devel = %{version}-%{release}
-Obsoletes:     dtc-static
+Obsoletes:     dtc-static < 1.3.0
 
 %description -n libfdt-static
 Static fdt library.
@@ -85,41 +106,73 @@ Static fdt library.
 Statyczna biblioteka fdt.
 
 %package -n python-libfdt
-Summary:       Python binding for fdt library
-Summary(pl.UTF-8):     Wiązanie Pythona do biblioteki fdt
+Summary:       Python binding for fdt library
+Summary(pl.UTF-8):     Wiązanie Pythona do biblioteki fdt
 License:       GPL v2+ or BSD
 Group:         Libraries/Python
 
 %description -n python-libfdt
-Python binding for fdt library.
+Python binding for fdt library.
 
 %description -n python-libfdt -l pl.UTF-8
-Wiązanie Pythona do biblioteki fdt.
+Wiązanie Pythona 2 do biblioteki fdt.
+
+%package -n python3-libfdt
+Summary:       Python 3 binding for fdt library
+Summary(pl.UTF-8):     Wiązanie Pythona 3 do biblioteki fdt
+License:       GPL v2+ or BSD
+Group:         Libraries/Python
+
+%description -n python3-libfdt
+Python 3 binding for fdt library.
+
+%description -n python3-libfdt -l pl.UTF-8
+Wiązanie Pythona 3 do biblioteki fdt.
 
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
-%{__make} \
+%{__make} -j1 \
        %{?with_verbose:V=1} \
        CC="%{__cc}" \
        CFLAGS="%{rpmcflags} -fPIC" \
-       %{!?with_python:NO_PYTHON=1}
+       NO_PYTHON=1
+
+%if %{with python}
+export SETUPTOOLS_SCM_PRETEND_VERSION=%{version}
+%if %{with python2}
+%py_build
+%endif
+%if %{with python3}
+%py3_build
+%endif
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install \
+
+%{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT \
        %{?with_verbose:V=1} \
        PREFIX=%{_prefix} \
        LIBDIR=%{_libdir} \
-       %{!?with_python:NO_PYTHON=1} \
+       NO_PYTHON=1 \
        SETUP_PREFIX=%{_prefix}
 
 %if %{with python}
+export SETUPTOOLS_SCM_PRETEND_VERSION=%{version}
+%if %{with python2}
+%py_install
+
 %py_postclean
 %endif
+%if %{with python3}
+%py3_install
+%endif
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -129,7 +182,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README README.license
+%doc README.license README.md
 %attr(755,root,root) %{_bindir}/convert-dtsv0
 %attr(755,root,root) %{_bindir}/dtc
 %attr(755,root,root) %{_bindir}/dtdiff
@@ -140,7 +193,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n libfdt
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libfdt-%{version}.so
+%attr(755,root,root) %{_libdir}/libfdt-%{abi_ver}.so
 %attr(755,root,root) %ghost %{_libdir}/libfdt.so.1
 
 %files -n libfdt-devel
@@ -155,10 +208,19 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libfdt.a
 
-%if %{with python}
+%if %{with python2}
 %files -n python-libfdt
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/_libfdt.so
 %{py_sitedir}/libfdt.py[co]
-%{py_sitedir}/libfdt-%{version}-py*.egg-info
+%{py_sitedir}/libfdt-%{abi_ver}*.egg-info
+%endif
+
+%if %{with python3}
+%files -n python3-libfdt
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py3_sitedir}/_libfdt.cpython-*.so
+%{py3_sitedir}/libfdt.py
+%{py3_sitedir}/__pycache__/libfdt.cpython-*.py[co]
+%{py3_sitedir}/libfdt-%{abi_ver}*.egg-info
 %endif
This page took 0.032552 seconds and 4 git commands to generate.