]> git.pld-linux.org Git - packages/dovecot.git/blobdiff - dovecot.spec
- rel 2
[packages/dovecot.git] / dovecot.spec
index af813de34b54bf0e18d949b96c8dc76087de54e1..13fac291ef4b16b9a9ee7a8944a2c192fc02e0e9 100644 (file)
 Summary:       IMAP and POP3 server written with security primarily in mind
 Summary(pl.UTF-8):     Serwer IMAP i POP3 pisany głównie z myślą o bezpieczeństwie
 Name:          dovecot
-Version:       2.0.2
-Release:       0.1
+Version:       2.0.4
+Release:       2
 Epoch:         1
 License:       MIT (libraries), LGPL v2.1 (the rest)
 Group:         Networking/Daemons
 Source0:       http://dovecot.org/releases/2.0/%{name}-%{version}.tar.gz
-# Source0-md5: e6386f44d027bd3f3f21400e162cf4f6
+# Source0-md5: ff1cd0dbfca4a26cce782f7d31cb2028
 Source1:       %{name}.pamd
 Source2:       %{name}.init
 Source3:       %{name}.sysconfig
@@ -52,6 +52,8 @@ Provides:     imapdaemon
 Provides:      user(dovecot)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                no_install_post_check_so        1
+
 %description
 Dovecot is an IMAP and POP3 server for Linux/UNIX-like systems,
 written with security primarily in mind. Although it's written with C,
@@ -146,14 +148,16 @@ touch config.rpath
        %{?with_mysql:--with-mysql} \
        %{?with_pgsql:--with-pgsql} \
        %{?with_sqlite:--with-sqlite} \
-       %{?with_gssapi:--with-gssapi} \
+       %{?with_gssapi:--with-gssapi=plugin} \
+       --with-sql=plugin \
+       --with-pam \
        --with-zlib \
        --with-bzlib \
        --with-libcap \
        --with-ssl=openssl \
        --with-moduledir=%{_libdir}/%{name}/plugins \
        --with-ssldir=/var/lib/openssl \
-       --sysconfdir=/etc/%{name}
+       --sysconfdir=/etc
 
 %{__make}
 
@@ -185,6 +189,8 @@ rm -rf $RPM_BUILD_ROOT
 %pre
 %groupadd -g 172 dovecot
 %useradd -u 172 -d /usr/share/empty -s /bin/false -c "Dovecot server" -g dovecot dovecot
+%groupadd -g 254 dovenull
+%useradd -u 254 -d /usr/share/empty -s /bin/false -c "Dovecot server" -g dovenull dovenull
 
 %post
 /sbin/chkconfig --add dovecot
@@ -206,11 +212,35 @@ fi
 if [ "$1" = "0" ]; then
        %userremove dovecot
        %groupremove dovecot
+       %userremove dovenull
+       %groupremove dovenull
 fi
 
-%triggerpostun -- dovecot < 1:1.1
+%triggerpostun -- dovecot < 1:2.0.0
+# upgrading dovecot < 1.1
 echo "Configuration change default_mail_env -> mail_location"
 %{__sed} -i -e "s/^default_mail_env/mail_location/" /etc/dovecot/dovecot.conf
+# upgrading dovecot < 2.0
+i=0
+for a in /etc/dovecot/dovecot-db-example.conf \
+       /etc/dovecot/dovecot-dict-sql-example.conf \
+       /etc/dovecot/dovecot-ldap-example.conf \
+       /etc/dovecot/dovecot-sql-example.conf \
+       /etc/dovecot/dovecot.conf; do
+       if [ -f "$a" ]; then
+               [ "$i" -eq 0 ] && echo "Read http://wiki2.dovecot.org/Upgrading/2.0"
+               i=1
+               echo "Trying to migrate $a config file to dovecot 2."
+               cp -a "$a" "$a-1.2.org"
+               :> "$a.log"
+               chmod 600 "$a.log"
+               # convert config and prefix stderr lines with #
+               %{_bindir}/doveconf -n -c "$a-1.2.org" > "$a" 2> "$a.log" || :
+       fi
+done
+if [ "$i" -eq 1 ]; then
+       echo "Please verify contents of %{_sysconfdir}/%{name}/* files."
+fi
 
 %files
 %defattr(644,root,root,755)
@@ -257,11 +287,15 @@ echo "Configuration change default_mail_env -> mail_location"
 %attr(755,root,root)%{_libdir}/%{name}/lib*.so*
 %dir %{_libdir}/%{name}/plugins
 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
+%dir %{_libdir}/%{name}/plugins/auth
+%attr(755,root,root)%{_libdir}/%{name}/plugins/auth/*.so
+%dir %{_libdir}/%{name}/plugins/dict
+%attr(755,root,root)%{_libdir}/%{name}/plugins/dict/*.so
 %dir %{_libdir}/%{name}/plugins/doveadm
 %attr(755,root,root)%{_libdir}/%{name}/plugins/doveadm/*.so
 %dir /var/lib/dovecot
 %dir /var/run/dovecot
-%attr(750,root,dovecot) %dir /var/run/dovecot/login
+%attr(750,root,dovenull) %dir /var/run/dovecot/login
 
 %{_mandir}/man1/deliver.1*
 %{_mandir}/man1/dove*.1*
This page took 0.082369 seconds and 4 git commands to generate.