]> git.pld-linux.org Git - packages/dovecot.git/blobdiff - dovecot.spec
- up to 1.1.14
[packages/dovecot.git] / dovecot.spec
index e6c664e50292218864b9fe568400de8b93d13458..118d1acb5684e0caffca8894f91496bde87fb826 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Conditional build:
+%bcond_with    gssapi  # with GSSAPI support
 %bcond_without ldap    # without LDAP auth
 %bcond_without mysql   # without MySQL auth
 %bcond_without pgsql   # without PostgreSQL auth
 Summary:       IMAP and POP3 server written with security primarily in mind
 Summary(pl.UTF-8):     Serwer IMAP i POP3 pisany głównie z myślą o bezpieczeństwie
 Name:          dovecot
-Version:       1.0.10
-Release:       2
+Version:       1.1.14
+Release:       1
+Epoch:         1
 License:       MIT (libraries), LGPL v2.1 (the rest)
 Group:         Networking/Daemons
-Source0:       http://dovecot.org/releases/1.0/%{name}-%{version}.tar.gz
-# Source0-md5: c050fa2a7dae8984d432595e3e8183e1
+Source0:       http://dovecot.org/releases/1.1/%{name}-%{version}.tar.gz
+# Source0-md5: 60b1deccc0ae77e5669060d2b1894e5e
 Source1:       %{name}.pamd
 Source2:       %{name}.init
 Source3:       %{name}.sysconfig
 Patch0:                %{name}-config.patch
-#Patch1:               %{name}-dspam-plugin.patch
 URL:           http://dovecot.org/
 BuildRequires: autoconf
 BuildRequires: automake
 %{?with_sasl:BuildRequires:    cyrus-sasl-devel >= 2.0}
 BuildRequires: gettext-devel
-BuildRequires: krb5-devel
+%{?with_gssapi:BuildRequires:  krb5-devel}
 BuildRequires: libtool
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.3}
@@ -44,8 +45,8 @@ Requires(pre):        /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      pam >= 0.79.0
 Provides:      group(dovecot)
-Provides:      user(dovecot)
 Provides:      imapdaemon
+Provides:      user(dovecot)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -125,7 +126,6 @@ Pakiet programistyczny do tworzenia wtyczek dla dovecota.
 %prep
 %setup -q
 %patch0 -p1
-#%patch1 -p1
 
 %{__sed} -i 's,/usr/lib/dovecot,%{_libdir}/dovecot,g' dovecot-example.conf
 
@@ -145,7 +145,7 @@ touch config.rpath
        %{?with_pgsql:--with-pgsql} \
        %{?with_sasl:--with-cyrus-sasl2} \
        %{?with_sqlite:--with-sqlite} \
-       --with-gssapi \
+       %{?with_gssapi:--with-gssapi} \
        --with-ssl=openssl \
        --with-ssl-dir=/var/lib/openssl \
        --sysconfdir=/etc/%{name}
@@ -155,7 +155,6 @@ touch config.rpath
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,sysconfig,security}
-install -d $RPM_BUILD_ROOT{%{_libdir},%{_bindir}}
 install -d $RPM_BUILD_ROOT{/var/lib/dovecot,/var/run/dovecot/login}
 
 %{__make} install \
@@ -173,13 +172,17 @@ touch $RPM_BUILD_ROOT/etc/security/blacklist.imap
 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins{,/imap}/*.la
 
 # devel
+for folder in deliver imap lib lib-imap lib-mail lib-storage; do
+       install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/$folder
+       install -p -m644 src/$folder/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/$folder/
+done
 for dir in lib lib-imap lib-mail lib-storage; do
        install -d $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/src/$dir
        install -p -m644 src/$dir/*.a $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/src/$dir
 done
-ln -sf %{_includedir}/%{name}/dovecot-config $RPM_BUILD_ROOT%{_libdir}/%{name}-devel
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/dovecot-config $RPM_BUILD_ROOT%{_libdir}/%{name}-devel
 
-rm -r $RPM_BUILD_ROOT%{_docdir}/%{name}/wiki
+rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -210,6 +213,10 @@ if [ "$1" = "0" ]; then
        %groupremove dovecot
 fi
 
+%triggerpostun -- dovecot < 1:1.1
+echo "Configuration change default_mail_env -> mail_location"
+%{__sed} -i -e "s/^default_mail_env/mail_location/" /etc/dovecot/dovecot.conf
+
 %files
 %defattr(644,root,root,755)
 # COPYING contains some notes, not actual LGPL text
@@ -218,6 +225,9 @@ fi
 %attr(755,root,root) %{_sbindir}/%{name}pw
 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}-db-example.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}-ldap-example.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}-sql-example.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.imap
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
@@ -231,7 +241,11 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/idxview
 %attr(755,root,root) %{_libdir}/%{name}/imap
 %attr(755,root,root) %{_libdir}/%{name}/imap-login
+%attr(755,root,root) %{_libdir}/%{name}/convert-tool
+%attr(755,root,root) %{_libdir}/%{name}/expire-tool
+%attr(755,root,root) %{_libdir}/%{name}/listview
 %attr(755,root,root) %{_libdir}/%{name}/logview
+%attr(755,root,root) %{_libdir}/%{name}/maildirlock
 %attr(755,root,root) %{_libdir}/%{name}/pop3
 %attr(755,root,root) %{_libdir}/%{name}/pop3-login
 %attr(755,root,root) %{_libdir}/%{name}/rawlog
This page took 0.041752 seconds and 4 git commands to generate.